summaryrefslogtreecommitdiff
path: root/nonprism/claws-mail/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-07-26 17:43:21 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-07-26 17:43:21 -0300
commit4878c2d72cccd41734ea9f707eefa32ccc05e5d8 (patch)
treeb8d7d0a687d73444b2a34ccd35a606fa4da2af14 /nonprism/claws-mail/PKGBUILD
parentad93a228ed76f21247395bac8734e59ed8dada84 (diff)
downloadabslibre-4878c2d72cccd41734ea9f707eefa32ccc05e5d8.tar.gz
abslibre-4878c2d72cccd41734ea9f707eefa32ccc05e5d8.tar.bz2
abslibre-4878c2d72cccd41734ea9f707eefa32ccc05e5d8.zip
claws-mail-3.12.0-1.nonprism1: updating version
Diffstat (limited to 'nonprism/claws-mail/PKGBUILD')
-rw-r--r--nonprism/claws-mail/PKGBUILD48
1 files changed, 20 insertions, 28 deletions
diff --git a/nonprism/claws-mail/PKGBUILD b/nonprism/claws-mail/PKGBUILD
index cf3f61990..17f760d57 100644
--- a/nonprism/claws-mail/PKGBUILD
+++ b/nonprism/claws-mail/PKGBUILD
@@ -1,14 +1,14 @@
-# $Id: PKGBUILD 241764 2015-07-03 17:39:10Z andyrtr $
+# $Id: PKGBUILD 242517 2015-07-26 12:20:39Z andyrtr $
# Maintainer (Arch): Andreas Radke <andyrtr@archlinux.org>
# Maintainer: Márcio Silva <coadde@parabola.nu>
pkgname=claws-mail
-pkgver=3.11.1
-pkgrel=4.nonprism1
+pkgver=3.12.0
+pkgrel=1.nonprism1
pkgdesc="A GTK+ based e-mail client, without libgdata support"
-arch=('i686' 'x86_64' 'mips64el')
+arch=('i686' 'x86_64')
license=('GPL3')
-url="http://www.$pkgname.org"
+url="http://www.claws-mail.org"
depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('spamassassin' 'bogofilter' 'valgrind'
@@ -30,33 +30,25 @@ optdepends=('python2: needed for some tools and python plugin'
'libsoup: for the fancy webkit html plugin'
'poppler-glib: for pdf viewer plugin'
'ghostscript: for pdf viewer plugin')
-replaces=("sylpheed-claws" "$pkgname-extra-plugins" "$pkgname-libre" "$pkgname-libre-nonprism" "$pkgname-nonprism")
-conflicts=("$pkgname-extra-plugins" "$pkgname-libre" "$pkgname-libre-nonprism" "$pkgname-nonprism")
+replaces=('sylpheed-claws' 'claws-mail-extra-plugins' 'claws-mail-libre' 'claws-mail-libre-nonprism' 'claws-mail-nonprism')
+conflicts=('claws-mail-extra-plugins' 'claws-mail-libre' 'claws-mail-libre-nonprism' 'claws-mail-nonprism')
provides=('claws')
-install=$pkgname.install
-source=(http://downloads.sourceforge.net/sourceforge/claws-mail/$pkgname-$pkgver.tar.xz{,.asc}
- git_fixes.diff)
-sha1sums=('b0c07906043f7a3ec726c7a96d6dcfc3c148b9cc'
- 'SKIP'
- '0e1bd9d696d531040f7b15b5b6164fc44784fdfc')
+install=claws-mail.install
+source=(#http://downloads.sourceforge.net/sourceforge/claws-mail/${pkgname}-${pkgver}.tar.xz{,.asc}
+ http://www.claws-mail.org/download.php?file=releases/claws-mail-3.12.0.tar.xz{,.asc})
+md5sums=('73c11bf9f260473abe0e888af19e23b8'
+ 'SKIP')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
-prepare() {
- cd $pkgname-$pkgver
- # fix .desktop file creation
- patch -Np1 -i $srcdir/git_fixes.diff
- autoreconf -vfi
-}
-
build() {
- cd $pkgname-$pkgver
+ cd ${pkgname}-${pkgver}
# fixes for python2
export PYTHON="/usr/bin/python2"
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
sed -i 's:python -c:python2 -c:g' configure
- setarch $CARCH ./configure --prefix=/usr --disable-static \
+ ./configure --prefix=/usr --disable-static \
--enable-enchant \
--enable-gnutls \
--enable-ldap \
@@ -67,19 +59,19 @@ build() {
--enable-appdata \
--disable-gdata-plugin
#--help
- setarch $CARCH make
+ make
}
package() {
- cd $pkgname-$pkgver
- setarch $CARCH make DESTDIR=$pkgdir install
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
# build and install extra tools
cd tools
- setarch $CARCH make
+ make
# all executables and .conf files ; only top directory
find -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i ; do
- install -D -m755 $i \
- $pkgdir/usr/lib/$pkgname/tools/$i
+ install -D -m755 ${i} \
+ ${pkgdir}/usr/lib/claws-mail/tools/${i}
done
}