summaryrefslogtreecommitdiff
path: root/libre/xulrunner-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-24 12:14:20 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-24 12:14:20 -0200
commit2164e1ef618dc439826a761e2d759e3027fa8976 (patch)
tree676b05a8f454a9a0de63ba41ab4a6646dad89775 /libre/xulrunner-libre/PKGBUILD
parentcdddbc73dc45964f15c9bb92573dddf427de1258 (diff)
downloadabslibre-2164e1ef618dc439826a761e2d759e3027fa8976.tar.gz
abslibre-2164e1ef618dc439826a761e2d759e3027fa8976.tar.bz2
abslibre-2164e1ef618dc439826a761e2d759e3027fa8976.zip
xulrunner-libre-19.0.1-1: updating version
Diffstat (limited to 'libre/xulrunner-libre/PKGBUILD')
-rw-r--r--libre/xulrunner-libre/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/libre/xulrunner-libre/PKGBUILD b/libre/xulrunner-libre/PKGBUILD
index c2847b2e8..66154fb0c 100644
--- a/libre/xulrunner-libre/PKGBUILD
+++ b/libre/xulrunner-libre/PKGBUILD
@@ -6,7 +6,7 @@
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=18.0.1
+_debver=19.0
_debrel=1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -15,7 +15,7 @@ _pkgname=xulrunner
pkgname=xulrunner-libre
pkgver=${_debver}.${_debrel}
pkgrel=1
-pkgdesc="Mozilla Runtime Environment"
+pkgdesc="Mozilla Runtime Environment (built from Debian Iceweasel source code)"
arch=('i686' 'x86_64' 'mips64el')
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'mozilla-common' 'nss>=3.14.1' 'libxt' 'libxrender' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'libevent' 'sqlite3>=3.7.4' 'libvpx' 'python2')
@@ -31,12 +31,12 @@ options=('!emptydirs')
conflicts=('xulrunner')
provides=("xulrunner=${_debver}")
replaces=('xulrunner-oss' 'xulrunner')
-md5sums=('5d481dd35a304702d1f311eeb3f1149f'
- '6a4781e8ddc1b166f36930c4864e095f'
+md5sums=('b4c109e987f869f94220188a901d4425'
+ 'e1d6920cb49c9de88b8e00eb14b1b0e7'
'7f3317c25308a631ca31d8d280991bb4'
'27271ce647a83906ef7a24605e840d61'
'52e52f840a49eb1d14be1c0065b03a93'
- '46a4b19b414065b99b870ea79b454f6e')
+ '2fde2f4bc158b217f3d71b33ef0bc626')
build() {
# WebRTC build tries to execute "python" and expects Python 2
@@ -45,9 +45,13 @@ build() {
ln -s /usr/bin/python2 "$srcdir/python2-path/python"
export PATH="$srcdir/python2-path:$PATH"
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/xulrunner-${_debver::4}"
+ export PYTHON="/usr/bin/python2"
+
export QUILT_PATCHES=debian/patches
export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
export QUILT_DIFF_ARGS='--no-timestamps'
+
mv mozilla-release "${_debname}-${_debver}"
mv debian "${_debname}-${_debver}"
cd "${_debname}-${_debver}"
@@ -73,9 +77,6 @@ build() {
patch -Np1 -i "$srcdir/mozilla-pkgconfig.patch"
patch -Np1 -i "$srcdir/shared-libs.patch"
- export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/xulrunner-${_debver::4}"
- export PYTHON="/usr/bin/python2"
-
make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
}