summaryrefslogtreecommitdiff
path: root/libre/xtensa-elf-binutils/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2021-03-08 15:03:26 -0300
committerDavid P <megver83@parabola.nu>2021-03-08 15:03:26 -0300
commit68573b2974ed954e29f42d3f8150b2efc983a176 (patch)
treebf9994d458cda368e38beece883d2ae2fe2a0ac5 /libre/xtensa-elf-binutils/PKGBUILD
parent0ae2d610a9d75dd770959ac4bcad82adc40d58d8 (diff)
downloadabslibre-68573b2974ed954e29f42d3f8150b2efc983a176.tar.gz
abslibre-68573b2974ed954e29f42d3f8150b2efc983a176.tar.bz2
abslibre-68573b2974ed954e29f42d3f8150b2efc983a176.zip
updpkg: libre/xtensa-elf-binutils 2.36.1-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/xtensa-elf-binutils/PKGBUILD')
-rw-r--r--libre/xtensa-elf-binutils/PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/libre/xtensa-elf-binutils/PKGBUILD b/libre/xtensa-elf-binutils/PKGBUILD
index 3f8197f28..e5aa96e84 100644
--- a/libre/xtensa-elf-binutils/PKGBUILD
+++ b/libre/xtensa-elf-binutils/PKGBUILD
@@ -2,17 +2,18 @@
_target=xtensa-elf
pkgname=$_target-binutils
-pkgver=2.34
-pkgrel=2
-pkgdesc='A set of programs to assemble and manipulate binary and object files for the Xtensa target'
+pkgver=2.36.1
+pkgrel=1
+pkgdesc='A set of programs to assemble and manipulate binary and object files for the Xtensa (bare-metal) target'
arch=('x86_64' 'i686' 'armv7h')
url="https://www.gnu.org/software/binutils/"
license=('GPL')
depends=('zlib')
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig}
- binutils-2.34_fixup.patch binutils.patch)
-sha512sums=('f47e7304e102c7bbc97958a08093e27796b9051d1567ce4fbb723d39ef3e29efa325ee14a1bdcc462a925a7f9bbbc9aee28294c6dc23850f371030f3835a8067'
+ binutils-2.36_fixup.patch binutils-2.34_fixup.patch binutils.patch)
+sha512sums=('5c40cfe05b922492627db71990dd2ba6030fd2de4bdba3f53a3f274543ff161fb56e2f6bdac107e0ffdcfd095e499c54e1157ee1865723baefa67b5b4d3da201'
'SKIP'
+ 'fa1e3e1b30d625eae4e59f1396079cc3fa4d77ec4f119ad20c52db1e1ff1819989ff16dc583d7c719caeb7c0ece48d76fe7c08a85b960c7bc924fe780ffa4ac2'
'4e5bbba907eec565f5c3ea00fa5a19c146ec19b1f2db38c6581f80a524475ad9b066839ca671da05c6fab9af402f2bb76e01d227e7456b3ef48c6d685605c8d1'
'e10ed358794d7aa32ac25087afd804dc4c3028c4664d7608eb86147f041561d16209afa6501bc8a19e02386674011d567640175f6b8bf89275c243dc3b3a9980')
validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
@@ -20,9 +21,14 @@ validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gin
prepare() {
cd binutils-$pkgver
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+
+ # https://github.com/qca/open-ath9k-htc-firmware/pull/168
+ patch -Np1 -i ../binutils-2.36_fixup.patch
+
+ # https://github.com/qca/open-ath9k-htc-firmware/tree/master/local/patches
patch -Np1 -i ../binutils-2.34_fixup.patch
patch -Np1 -i ../binutils.patch
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
}
build() {
@@ -50,7 +56,7 @@ build() {
check() {
cd binutils-$pkgver
-
+
# unset LDFLAGS as testsuite makes assumptions about which ones are active
# do not abort on errors - manually check log files
make LDFLAGS="" -k check || true
@@ -63,6 +69,7 @@ package() {
# Remove file conflicting with host binutils and manpages for MS Windows tools
rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
+ rm "$pkgdir"/usr/lib/bfd-plugins/libdep.so
# Remove info documents that conflict with host version
rm -r "$pkgdir"/usr/share/info