summaryrefslogtreecommitdiff
path: root/libre/vim-colorsamplerpack/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-04 08:01:25 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-04 08:01:25 -0300
commit5f717336745883bc05059daad60e95ff74be71c5 (patch)
treeb60747eddab88c9410127480c9d217a273acb25c /libre/vim-colorsamplerpack/PKGBUILD
parent2a47bb0200fef649fb4ac1694048c87f7de3f97d (diff)
downloadabslibre-5f717336745883bc05059daad60e95ff74be71c5.tar.gz
abslibre-5f717336745883bc05059daad60e95ff74be71c5.tar.bz2
abslibre-5f717336745883bc05059daad60e95ff74be71c5.zip
vim-colorsamplerpack: remove libre suffix and add complex pkgrel
Diffstat (limited to 'libre/vim-colorsamplerpack/PKGBUILD')
-rw-r--r--libre/vim-colorsamplerpack/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/libre/vim-colorsamplerpack/PKGBUILD b/libre/vim-colorsamplerpack/PKGBUILD
new file mode 100644
index 000000000..9ae357196
--- /dev/null
+++ b/libre/vim-colorsamplerpack/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 95528 2013-08-13 11:23:39Z svenstaro $
+# Contributor (Arch): Aaron Griffin <aaron@archlinux.org>
+# Maintainer (Arch): Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+_pkgname=vim-colorsamplerpack-libre
+pkgname=vim-colorsamplerpack
+pkgver=2012.10.28
+pkgrel=3.parabola1
+_scriptid=18915
+pkgdesc="Different colorschemes for vim, without nonfree colorschemes"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=625"
+license=('GPL2' 'GPL3' 'custom')
+replaces=($_pkgname)
+conflicts=($_pkgname)
+depends=('vim')
+makedepends=('unzip')
+groups=('vim-plugins')
+mksource=(ColorSamplerPack.zip::"http://www.vim.org/scripts/download_script.php?src_id=$_scriptid")
+source=("https://repo.parabolagnulinux.org/other/${_pkgname}/ColorSamplerPack-libre.tar.xz"
+ 'LICENSE')
+mkmd5sums=('b0f1bd54b396e3d6032c01ef1fb421b6')
+md5sums=('73d62829a9ad2cde3f1d03a3fbe154ee'
+ '6db49cf0613715ff3b7c50072367981c')
+
+mksource() {
+ # Remove nonfree colorschemes
+ cd ${srcdir}
+ mv colors colors-tmp
+ install -d colors
+ install -m644 colors-tmp/{calmar256-light,cleanphp,dante,ekvoli,lettuce,marklar,martin_krischik,motus,railscasts,relaxedgreen,synic,tabula,vibrantink,vividchalk,xoria256,zenburn}.vim colors
+ rm -rv colors-tmp
+}
+
+package() {
+ cd ${srcdir}
+ installpath="${pkgdir}/usr/share/vim/vim74"
+ install -d $installpath/colors/
+ install -m644 colors/* $installpath/colors
+ install -D -m644 plugin/color_sample_pack.vim $installpath/plugin/themes.vim
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}