summaryrefslogtreecommitdiff
path: root/libre/vhba-module-parabola-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-23 01:36:15 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-23 01:36:15 -0300
commit28529fefc594bf968ca30905a5a2d6c9ae1d6f3c (patch)
tree4c2428f259eb8d14153d27c38659293f4a970f03 /libre/vhba-module-parabola-lts/PKGBUILD
parentb1852341008bbce6f23ebc4c300112d98c96ab8d (diff)
downloadabslibre-28529fefc594bf968ca30905a5a2d6c9ae1d6f3c.tar.gz
abslibre-28529fefc594bf968ca30905a5a2d6c9ae1d6f3c.tar.bz2
abslibre-28529fefc594bf968ca30905a5a2d6c9ae1d6f3c.zip
add modifications from coadde and lukeshu contributions for linux-libre* and dependencies
Diffstat (limited to 'libre/vhba-module-parabola-lts/PKGBUILD')
-rw-r--r--libre/vhba-module-parabola-lts/PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/libre/vhba-module-parabola-lts/PKGBUILD b/libre/vhba-module-parabola-lts/PKGBUILD
new file mode 100644
index 000000000..d6f99bef9
--- /dev/null
+++ b/libre/vhba-module-parabola-lts/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id: PKGBUILD 116828 2014-08-04 07:19:43Z tpowa $
+# Maintainer (Arch): Ray Rashif <schiv@archlinux.org>
+# Contributor (Arch): Mateusz Herych <heniekk@gmail.com>
+# Contributor (Arch): Charles Lindsay <charles@chaoslizard.org>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
+# Contributor: Márcio Silva <coadde@parabola.nu>
+
+# Kernel info
+_basekernel=3.14
+_kernelname=-lts
+
+# Source info
+_pkgname=vhba-module
+pkgver=20140629
+pkgdesc="Kernel module that emulates SCSI devices (built for the linux-libre${_kernelname} kernel package)"
+url="http://cdemu.sourceforge.net/"
+license=('GPL')
+source=("http://downloads.sourceforge.net/cdemu/$_pkgname-$pkgver.tar.bz2"
+ '60-vhba.rules')
+md5sums=('6b307a80df9c163768cc7ecb3ccebb71'
+ '4dc37dc348b5a2c83585829bde790dcc')
+
+# Package info
+pkgrel=7.${_basekernel/./}
+arch=('i686' 'x86_64' 'mips64el')
+options=(!makeflags)
+install=$_pkgname.install
+
+# Generic (you shouldn't have to modify any of these variables)
+pkgname=${_pkgname}-parabola${_kernelname}
+_toohigh=$(IFS=. read a b <<<$_basekernel; echo $a.$((b+1)))
+_extramodules=extramodules-${_basekernel}${_kernelname}
+depends=("linux-libre${_kernelname}>=${_basekernel}" "linux-libre${_kernelname}<${_toohigh}")
+makedepends=("linux-libre${_kernelname}-headers>=${_basekernel}" "linux-libre${_kernelname}-headers<${_toohigh}")
+replaces=( "${_pkgname}${_kernelname}") # for Arch-compatability
+conflicts=("${_pkgname}${_kernelname}") # for Arch-compatability
+provides=( "${_pkgname}${_kernelname}=${pkgver}") # for Arch-compatability
+if [[ -n "${_kernelname}" ]]; then
+ provides+=("${_pkgname}-parabola=${pkgver}") # pkgname without _kernelname
+fi
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+
+ make KDIR=/usr/lib/modules/$_kernver/build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Set the correct extramodules directory for install
+ cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
+ true && install=${install}.pkg
+ sed -r "s/(_extramodules=).*/\1${_extramodules}/" -i "${startdir}/${install}"
+
+ # Actually install
+ install -Dm644 vhba.ko "$pkgdir/usr/lib/modules/$_extramodules/vhba.ko"
+ install -Dm644 ../60-vhba.rules "$pkgdir/usr/lib/udev/rules.d/60-vhba.rules"
+}