summaryrefslogtreecommitdiff
path: root/libre/uboot4extlinux-imx/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-06-13 19:14:08 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-06-13 23:51:26 +0200
commitba68da7a10c253816a8adef2020213b2bd988c3b (patch)
treee56e756f89d91d05b25f20664b0fd92928fab752 /libre/uboot4extlinux-imx/PKGBUILD
parentfe26f06b688ddbe57a0a3320bedfa3424991ec3a (diff)
downloadabslibre-ba68da7a10c253816a8adef2020213b2bd988c3b.tar.gz
abslibre-ba68da7a10c253816a8adef2020213b2bd988c3b.tar.bz2
abslibre-ba68da7a10c253816a8adef2020213b2bd988c3b.zip
libre: uboot4extlinux-imx: Update to 2020.04, cleanup PKGBUILD and extlinux.conf
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'libre/uboot4extlinux-imx/PKGBUILD')
-rw-r--r--libre/uboot4extlinux-imx/PKGBUILD146
1 files changed, 49 insertions, 97 deletions
diff --git a/libre/uboot4extlinux-imx/PKGBUILD b/libre/uboot4extlinux-imx/PKGBUILD
index b6b7652a7..f4bb6aec0 100644
--- a/libre/uboot4extlinux-imx/PKGBUILD
+++ b/libre/uboot4extlinux-imx/PKGBUILD
@@ -4,14 +4,25 @@
# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Maintainer: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# TODO:
+# - Add the following boards
+# - 'mx6cuboxi'
+# - 'nitrogen6q'
+# - 'udoo'
+# - 'usbarmory'
+# - 'wandboard'
+# - Improve the .install:
+# - Make it more generic: share the main part of the code.
+# - Check for the machine name with the device tree and ask for confirmation
+# if the machine is not the same but don't prevent users from installing
+# this bootloader on a totally different machine as the installation could
+# be done in a chroot or in other ways that packagers can't predict.
+# - Handle more than one boot device (microSD, eMMC, USB, etc)
+# - Point to the device documentation if there is some
+
pkgbase=uboot4extlinux-imx
-pkgname=('uboot4extlinux-mx6cuboxi'
- 'uboot4extlinux-nitrogen6q'
- 'uboot4extlinux-tbs2910'
- 'uboot4extlinux-udoo'
- 'uboot4extlinux-usbarmory'
- 'uboot4extlinux-wandboard')
-pkgver=2020.01
+pkgname=('uboot4extlinux-tbs2910')
+pkgver=2020.04
pkgrel=1
arch=('armv7h')
url="http://git.denx.de/u-boot.git/"
@@ -19,38 +30,40 @@ license=('GPL')
makedepends=('bc' 'dtc' 'python' 'python2' 'swig')
backup=(boot/extlinux/extlinux.conf)
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
- 'extlinux.conf'
- 'tbs2910.h'
- 'tbs2910_defconfig')
-sha256sums=('aa453c603208b1b27bd03525775a7f79b443adec577fdc6e8f06974025a135f1'
- 'SKIP'
- 'SKIP'
+ 'extlinux.conf')
+
+sha256sums=('fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372'
'SKIP')
-# TODO
-# boards=('mx6cuboxi'
-# 'nitrogen6q'
-# 'tbs2910'
-# 'udoo'
-# 'usbarmory'
-# 'wandboard')
+# Distro boot config and documentation for the TBS TBS2910
+# The patches are from the next branch of u-boot git
+# a bit after the v2020.07-rc4 tag. They should make it in 1 or two
+# u-boot release.
+source+=('0001-board-tbs2910-disable-loadb-and-loads-commands.patch'
+ '0002-board-tbs2910-disable-CONFIG_GZIP.patch'
+ '0003-board-tbs2910-move-CONFIG_BOOTCOMMAND-from-header-to.patch'
+ '0004-board-tbs2910_defconfig-Add-support-for-booting-gene.patch'
+ '0005-board-tbs2910-Enable-distro_boot-support.patch'
+ '0006-board-tbs2910-add-documentation.patch')
+sha256sums+=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
boards=('tbs2910')
prepare() {
cd u-boot-${pkgver}
- # TODO: send patches upstream
- # tbs2910.h: needed for generic distro booting
- # tbs2910_defconfig: needed for generic distro booting
- # and to fit within the size constraints
- cp -f ../tbs2910.h include/configs/tbs2910.h
- cp -f ../tbs2910_defconfig configs/tbs2910_defconfig
-
- for i in ${boards[@]}; do
- echo 'CONFIG_DISTRO_DEFAULTS=y' >> configs/${i}_defconfig
- echo 'CONFIG_SD_BOOT=y' >> configs/${i}_defconfig
- echo 'CONFIG_SATA_BOOT=y' >> configs/${i}_defconfig
- done
+ # TBS2910 patches
+ patch -Np1 -i ../0001-board-tbs2910-disable-loadb-and-loads-commands.patch
+ patch -Np1 -i ../0002-board-tbs2910-disable-CONFIG_GZIP.patch
+ patch -Np1 -i ../0003-board-tbs2910-move-CONFIG_BOOTCOMMAND-from-header-to.patch
+ patch -Np1 -i ../0004-board-tbs2910_defconfig-Add-support-for-booting-gene.patch
+ patch -Np1 -i ../0005-board-tbs2910-Enable-distro_boot-support.patch
+ patch -Np1 -i ../0006-board-tbs2910-add-documentation.patch
}
@@ -69,35 +82,9 @@ build() {
done
}
-package_uboot4extlinux-nitrogen6q() {
- pkgdesc="U-Boot with Extlinux support for the Boundary Devices i.MX6 Quad Nitrogen6"
- install=${pkgbase}.install
- provides=('uboot4extlinux-imx')
- conflicts=('uboot-nitrogen6q')
-
- install -d "${pkgdir}"/boot/extlinux
- install -d "${pkgdir}"/boot/u-boot/images/
- install -Dm644 bin_nitrogen6q/u-boot.imx "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
-}
-
-package_uboot4extlinux-mx6cuboxi() {
- pkgdesc="U-Boot with Extlinux support for the SolidRun Cubox-i"
- install=${pkgbase}.install
- provides=('uboot4extlinux-imx')
- conflicts=('uboot-mx6_cubox-i')
-
- install -d "${pkgdir}"/boot/extlinux
- install -d "${pkgdir}"/boot/u-boot/images/
- install -Dm644 bin_mx6cuboxi/u-boot.imx "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
-}
-
package_uboot4extlinux-tbs2910() {
pkgdesc="U-Boot with Extlinux support for the TBS2910 Matrix ARM mini PC"
- install=${pkgbase}.install
+ install=tbs2910.install
provides=('uboot4extlinux-imx')
install -d "${pkgdir}"/boot/extlinux
@@ -105,43 +92,8 @@ package_uboot4extlinux-tbs2910() {
install -Dm644 bin_tbs2910/u-boot.imx "${pkgdir}"/boot/u-boot/images/
install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
-}
-package_uboot4extlinux-udoo() {
- pkgdesc="U-Boot with Extlinux support for the Udoo Board"
- install=${pkgbase}.install
- provides=('uboot4extlinux-imx')
- conflicts=('uboot-udoo')
-
- install -d "${pkgdir}"/boot/extlinux
- install -d "${pkgdir}"/boot/u-boot/images/
- install -Dm644 udoo/u-boot.imx "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
-}
-
-package_uboot4extlinux-usbarmory() {
- pkgdesc="U-Boot with Extlinux support for the Inverse Path USB armory"
- install=${pkgbase}.install
- provides=('uboot4extlinux-imx')
- conflicts=('uboot-usbarmory')
-
- install -d "${pkgdir}"/boot/extlinux
- install -d "${pkgdir}"/boot/u-boot/images/
- install -Dm644 usbarmory/u-boot.imx "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
-}
-
-package_uboot4extlinux-wandboard() {
- pkgdesc="U-Boot with Extlinux support for the Wandboard"
- install=${pkgbase}.install
- provides=('uboot4extlinux-imx')
- conflicts=('uboot-wandboard')
-
- install -d "${pkgdir}"/boot/extlinux
- install -d "${pkgdir}"/boot/u-boot/images/
- install -Dm644 wandboard/u-boot.imx "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
+ # Package documentation as well
+ install -d "${pkgdir}"/usr/share/doc/u-boot
+ install -Dm644 u-boot-${pkgver}/doc/board/tbs/tbs2910.rst "${pkgdir}"/usr/share/doc/u-boot
}