summaryrefslogtreecommitdiff
path: root/libre/uboot4extlinux-am335x_bone/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-02-25 03:23:06 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-02-25 07:30:23 -0300
commit2c83ecbd26706dbdaaa7ea9405cf9f3f7703f5ee (patch)
treebbc18da6cada6cf297245870b23475406a7de3cc /libre/uboot4extlinux-am335x_bone/PKGBUILD
parent7fe43b1d13a26841b458e7d71485a3049ba57c8f (diff)
downloadabslibre-2c83ecbd26706dbdaaa7ea9405cf9f3f7703f5ee.tar.gz
abslibre-2c83ecbd26706dbdaaa7ea9405cf9f3f7703f5ee.tar.bz2
abslibre-2c83ecbd26706dbdaaa7ea9405cf9f3f7703f5ee.zip
rename uboot packages with Extlinux support to uboot4extlinux
Diffstat (limited to 'libre/uboot4extlinux-am335x_bone/PKGBUILD')
-rw-r--r--libre/uboot4extlinux-am335x_bone/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/libre/uboot4extlinux-am335x_bone/PKGBUILD b/libre/uboot4extlinux-am335x_bone/PKGBUILD
new file mode 100644
index 000000000..f1436af02
--- /dev/null
+++ b/libre/uboot4extlinux-am335x_bone/PKGBUILD
@@ -0,0 +1,53 @@
+# U-Boot: BeagleBone and BeagleBone Black
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: Jookia <166291@gmail.com>
+# Contributor: Márcio Silva <coadde@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot4extlinux-am335x_bone
+pkgver=2015.04
+pkgrel=1
+pkgdesc="U-Boot with Extlinux support for BeagleBone and BeagleBone Black"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+replaces=('uboot-beaglebone-linux-libre' 'uboot-beaglebone-linux-libre-lts'
+ 'uboot-beaglebone-linux-libre-grsec' 'uboot-beaglebone-linux-libre-pck'
+ 'uboot-beaglebone' 'uboot-am335x_bone')
+conflicts=('uboot-beaglebone-linux-libre' 'uboot-beaglebone-linux-libre-lts'
+ 'uboot-beaglebone-linux-libre-grsec' 'uboot-beaglebone-linux-libre-pck'
+ 'uboot-beaglebone' 'uboot-am335x_bone' 'uboot4grub-am335x_bone')
+makedepends=('bc')
+license=('GPL')
+backup=(boot/extlinux/extlinux.conf)
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch'
+ 'extlinux.conf'
+ 'uEnv.txt')
+md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
+ '37784c8f8f52a615d65e775018d237fb'
+ '068f6b4e8047115e73f29af5f384889b'
+ 'ccb79775b81654e16fca18825c7f2506')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset CFLAGS CXXFLAGS LDFLAGS
+
+ make distclean
+ make am335x_evm_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+ mkdir -p "${pkgdir}"/boot/extlinux
+ cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
+ cp "${srcdir}"/extlinux.conf "${pkgdir}"/boot/extlinux
+}