summaryrefslogtreecommitdiff
path: root/libre/uboot-am335x_bone/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 03:14:06 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 03:14:06 -0300
commit4ee6202c549ae1d8d31425916454c0e35726a819 (patch)
tree5b7613e4a17c53a0ab9a86ae708b31e05fd3a30e /libre/uboot-am335x_bone/PKGBUILD
parent820895f2adc8539cd8add8231253c37ad8c44f5d (diff)
downloadabslibre-4ee6202c549ae1d8d31425916454c0e35726a819.tar.gz
abslibre-4ee6202c549ae1d8d31425916454c0e35726a819.tar.bz2
abslibre-4ee6202c549ae1d8d31425916454c0e35726a819.zip
uboot-am335x_bone: add new package to [libre]
Diffstat (limited to 'libre/uboot-am335x_bone/PKGBUILD')
-rw-r--r--libre/uboot-am335x_bone/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/libre/uboot-am335x_bone/PKGBUILD b/libre/uboot-am335x_bone/PKGBUILD
new file mode 100644
index 000000000..0061b8611
--- /dev/null
+++ b/libre/uboot-am335x_bone/PKGBUILD
@@ -0,0 +1,46 @@
+# U-Boot: BeagleBone and BeagleBone Black
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot-am335x_bone
+pkgver=2015.04
+pkgrel=1
+pkgdesc="U-Boot for BeagleBone and BeagleBone Black"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+makedepends=('git' 'bc')
+depends=('linux-libre')
+replaces=('uboot-beaglebone-linux-libre' 'uboot-beaglebone-linux-libre-lts'
+ 'uboot-beaglebone-linux-libre-grsec' 'uboot-beaglebone-linux-libre-pck'
+ 'uboot-beaglebone')
+conflicts=('uboot4extlinux-am335x_bone' 'uboot4grub-am335x_bone')
+license=('GPL')
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch'
+ 'uEnv.txt')
+md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
+ '0196a4e91c2e7b4c0183a19cdf651c07'
+ 'ccb79775b81654e16fca18825c7f2506')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset CFLAGS CXXFLAGS LDFLAGS
+
+ make distclean
+ make am335x_evm_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+ mkdir -p "${pkgdir}"/boot
+ cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
+}