summaryrefslogtreecommitdiff
path: root/libre/ttf-thai-libre/PKGBUILD
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-02-10 13:53:23 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-02-10 13:53:23 -0600
commitbe9dd340ef7d752d61d0d3b4b6b18164016f4605 (patch)
tree22466eb7977fbe9ae29dc83ac61ea9f77f86d0e7 /libre/ttf-thai-libre/PKGBUILD
parent9b6fb533bdf48dc4bc3adb21c57366090aa6c5f6 (diff)
parentca888a4fabb768d38874b5f983cd84eba801ae7f (diff)
downloadabslibre-be9dd340ef7d752d61d0d3b4b6b18164016f4605.tar.gz
abslibre-be9dd340ef7d752d61d0d3b4b6b18164016f4605.tar.bz2
abslibre-be9dd340ef7d752d61d0d3b4b6b18164016f4605.zip
Merge http://projects.parabolagnulinux.org/abslibre
Diffstat (limited to 'libre/ttf-thai-libre/PKGBUILD')
-rw-r--r--libre/ttf-thai-libre/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/libre/ttf-thai-libre/PKGBUILD b/libre/ttf-thai-libre/PKGBUILD
new file mode 100644
index 000000000..3d1d4ec3d
--- /dev/null
+++ b/libre/ttf-thai-libre/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Henry Jensen <hjensen@connochaetos.org>
+
+pkgname=ttf-thai-libre
+pkgver=0.4.14
+pkgrel=1
+pkgdesc="A collection of basic Thai fonts, libre version"
+arch=(any)
+license=('GPL')
+depends=(xorg-fonts-encodings xorg-fonts-alias xorg-font-utils fontconfig)
+makedepends=(fontforge)
+provides=('thai-ttf' "ttf-thai=$pkgver")
+conflicts=('ttf-thai')
+replaces=('ttf-thai')
+url="http://www.connochaetos.org"
+install=ttf.install
+source=(http://www.connochaetos.org/misc/thaifonts-scalable-libre-${pkgver}.tar.gz)
+md5sums=('205436d69d273aca33dbbf31c61fa6b9')
+
+build() {
+ cd ${srcdir}/thaifonts-scalable-libre-${pkgver}
+ ./configure --prefix=/usr --with-ttfdir=/usr/share/fonts/TTF --sysconfdir=/etc
+ make
+ make DESTDIR=${pkgdir}/ install
+ rm ${pkgdir}/usr/share/fonts/TTF/fonts.dir
+ rm ${pkgdir}/usr/share/fonts/TTF/fonts.scale
+}
+