summaryrefslogtreecommitdiff
path: root/libre/smplayer/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-08-14 03:22:44 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-08-14 03:22:44 -0300
commit8ae3e0dfab83a5a721f011c881b76f77510ebae2 (patch)
tree74676ee99c0d39c0f97ec9ec4470c3b79a0c377c /libre/smplayer/PKGBUILD
parent62d0bf5c9f55c359f2128a2d4fa95f14dce1d416 (diff)
downloadabslibre-8ae3e0dfab83a5a721f011c881b76f77510ebae2.tar.gz
abslibre-8ae3e0dfab83a5a721f011c881b76f77510ebae2.tar.bz2
abslibre-8ae3e0dfab83a5a721f011c881b76f77510ebae2.zip
smplayer-16.8.0-1.parabola1: updating version
Diffstat (limited to 'libre/smplayer/PKGBUILD')
-rw-r--r--libre/smplayer/PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/libre/smplayer/PKGBUILD b/libre/smplayer/PKGBUILD
index b639e88ac..8709a2821 100644
--- a/libre/smplayer/PKGBUILD
+++ b/libre/smplayer/PKGBUILD
@@ -1,5 +1,4 @@
-# $Id: PKGBUILD 179682 2016-06-11 17:09:39Z arojas $
-# Maintainer (Arch):
+# Maintainer (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Allan McRae <allan@archlinux.org>
# Contributor (Arch): Alessio 'mOLOk' Bolognino <themolok@gmail.com>
@@ -8,26 +7,28 @@
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=smplayer
-pkgver=16.6.0
+pkgver=16.8.0
pkgrel=1.parabola1
-pkgdesc="A complete front-end for MPlayer, without nonfree smtube recommendation"
+pkgdesc='Media player with built-in codecs that can play virtually all video and audio formats, without nonfree smtube support'
+url='http://smplayer.sourceforge.net/'
arch=('i686' 'x86_64' 'armv7h')
-url="http://smplayer.sourceforge.net/"
license=('GPL')
-depends=('qt5-script' 'mplayer' 'hicolor-icon-theme')
+depends=('qt5-script' 'mpv' 'hicolor-icon-theme')
makedepends=('qt5-tools')
optdepends=('smplayer-themes: icon themes collection'
'smplayer-skins: skin themes collection'
- 'mpv: for using mpv instead of mplayer')
-source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2)
-md5sums=('61d6fc855d13b33eccb3f5d2a1472220')
+ 'youtube-dl: youtube videos and streaming'
+ 'mplayer: alternative multimedia engine')
+source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
+ disable-smtube-support.patch)
+md5sums=('48b001b6c00e5495be4316c9e1589d11'
+ '0a22c31bb756226617664b1a6e5c4f1d')
prepare() {
cd $pkgname-$pkgver
- sed -i 's|DEFINES [+][=] YOUTUBE_SUPPORT|#DEFINES += YOUTUBE_SUPPORT|
- s|DEFINES [+][=] YT_USE_SCRIPT|#DEFINES += YT_USE_SCRIPT|
- ' src/smplayer.pro
+ # disable SMTube support
+ patch -p1 -i $srcdir/disable-smtube-support.patch
# fix GNU/Linux name
sed -i 's|Linux|GNU/Linux|' src/smplayer.cpp
@@ -43,5 +44,5 @@ build() {
package() {
cd $pkgname-$pkgver
make DOC_PATH=/usr/share/doc/smplayer \
- DESTDIR="$pkgdir" PREFIX="/usr" install
+ DESTDIR="$pkgdir" PREFIX=/usr install
}