summaryrefslogtreecommitdiff
path: root/libre/sh-elf-binutils/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-08-28 09:59:28 -0300
committerDavid P <megver83@parabola.nu>2018-08-28 09:59:28 -0300
commit37130550e7f3bb50136c8e3d0daca563373591b1 (patch)
tree627150b4b66e180d310ae97aa6dc3c8190a4c651 /libre/sh-elf-binutils/PKGBUILD
parentdcf0e62c22e1ae74b800ee57a2e7a7ed3390bf6a (diff)
downloadabslibre-37130550e7f3bb50136c8e3d0daca563373591b1.tar.gz
abslibre-37130550e7f3bb50136c8e3d0daca563373591b1.tar.bz2
abslibre-37130550e7f3bb50136c8e3d0daca563373591b1.zip
libre/x86_64-pc-linux-gnu-binutils 2.31.1-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/sh-elf-binutils/PKGBUILD')
-rw-r--r--libre/sh-elf-binutils/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/libre/sh-elf-binutils/PKGBUILD b/libre/sh-elf-binutils/PKGBUILD
index 988fb964f..00c5a76ae 100644
--- a/libre/sh-elf-binutils/PKGBUILD
+++ b/libre/sh-elf-binutils/PKGBUILD
@@ -2,15 +2,15 @@
_target=sh-elf
pkgname=$_target-binutils
-pkgver=2.30
+pkgver=2.31.1
pkgrel=1
-pkgdesc='A set of programs to assemble and manipulate binary and object files'
+pkgdesc='A set of programs to assemble and manipulate binary and object files for the SuperH target'
arch=('x86_64' 'i686' 'armv7h')
url='http://www.gnu.org/software/binutils/'
license=(GPL)
depends=(zlib)
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
-sha512sums=('c3ce91aa20f058ec589bf18c722bf651331b394db6378900cc813cc0eea3a331a96584d5ae090630b627369510397dccc9edfcd43d4aeefc99579f277a05c72c'
+sha512sums=('b42954e6f49a0adcd2676bdd77dfb59bfc25cec8184b007521d1e2b1d5d0593b58639e3d9448d5a40fe024c3cea386a37743627d6bb16d502f52a4a32b9573bd'
'SKIP')
validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
'3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
@@ -48,7 +48,7 @@ check() {
# unset LDFLAGS as testsuite makes assumptions about which ones are active
# do not abort on errors - manually check log files
- make -k LDFLAGS="" check || true
+ make LDFLAGS="" -k check || true
}
package() {
@@ -57,7 +57,7 @@ package() {
make DESTDIR="$pkgdir" install
# Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
# Remove info documents that conflict with host version
rm -r "$pkgdir"/usr/share/info