summaryrefslogtreecommitdiff
path: root/libre/ruby/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2020-01-11 17:07:49 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2020-01-11 19:13:41 -0500
commit81f0a20cd5ab93943dbb55f2102cd77ec5e402dc (patch)
tree53bfec5fec69bafc9c758e40ce8a53f0a86799e9 /libre/ruby/PKGBUILD
parent79a43052cb2f2f1bb92914effd7b852dc9280c17 (diff)
downloadabslibre-81f0a20cd5ab93943dbb55f2102cd77ec5e402dc.tar.gz
abslibre-81f0a20cd5ab93943dbb55f2102cd77ec5e402dc.tar.bz2
abslibre-81f0a20cd5ab93943dbb55f2102cd77ec5e402dc.zip
[ruby]: upgrade to v2.7.0
Diffstat (limited to 'libre/ruby/PKGBUILD')
-rw-r--r--libre/ruby/PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/libre/ruby/PKGBUILD b/libre/ruby/PKGBUILD
index 1adcb5155..7c25ce147 100644
--- a/libre/ruby/PKGBUILD
+++ b/libre/ruby/PKGBUILD
@@ -18,14 +18,14 @@
pkgname=(ruby ruby-docs)
-pkgver=2.6.5
+pkgver=2.7.0
_jsonver=2.1.0
pkgrel=1
-pkgrel+=.par1
+pkgrel+=.parabola1
_srcrel=1 # increment this to rebuild the sourceball without bumping pkgver
arch=(x86_64)
arch+=(i686 armv7h)
-url='http://www.ruby-lang.org/en/'
+url='https://www.ruby-lang.org/en/'
license=(BSD2 custom)
makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
options=(!emptydirs)
@@ -34,26 +34,28 @@ source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
remove-json-ext.patch
add-json_pure.patch
json-libre.patch)
-sha512sums=('e8ae3b5d4d23a93d0ef6057235ad0e573665a8b4b6544e1c70b4cce9c4d2fb9094e5c8fe8a9ab7b9996efe3ada603f9b4ef1fd08fb5a83253c1ae2b5e3f202db'
+sha512sums=('dd5690c631bf3a2b76cdc06902bcd76a89713a045e136debab9b8a81ff8c433bbb254aa09e4014ca1cf85a69ff4bcb13de11da5e40c224e7268be43ef2194af7'
'6019cc26a0919e4d39ae0bf737b51cd9a474c74a55d25f6931ac04d61826bb810d063190a80a29810e57d7457d1a247acd82fd78de2c4c01acb7d73ee9fde603'
- '412dff58c77f6cbc598bf49fb09cb416ad88635e9213acc60a1d103e5d093b2d80260c41e07fbc0634047c655756f5bdd8b2f5e59ae8e4b992b598b251b4c3e9'
- '303172561a4ba54515fddfd9ea7e0c833e550b0ae5e9f331956f178f8c5e20aa0e3c4036251ddfd04312769ef7d71d83fde0afe64f6fa8e9052ca5a294c62927'
+ 'cce1402a062ab5a065e7554ae23189cb9c8de0acc27a4c96db5a90a52cfce37fde8d128e95b997e6df05d327d2279a8368276820dfad8b744747ea619ad187ab'
+ '9ff8a2ec9fdecd05fd506ed6f977dcd483e47611dc6bbe6c4622100a2071c0f6c7b3f813a94b73bebb9f0ed7fe9f6257289cdf971030ad525a3c8a0d065b09c2'
'582017bd0f98878c0ac6f4625854422662d83ae6274a34762082a720052023780dceb17694b1f4e18d9a0dcbb525990341176eac31040aa63099a8b3a8d52071')
prepare() {
- # Start with the vanilla version of json
cd "$srcdir/json-${_jsonver}"
- # Modify it so that 'json' doesn't try to load (non-free!) 'json/ext'
+
+ # Modify 'json' so that it doesn't try to load (non-free!) 'json/ext'
+ msg "applying json-libre.patch"
rm -rf -- json.gemspec ext lib/json/ext*
patch -p1 -i ../json-libre.patch
- # Now modify the ruby sources to include the json_pure lib instead
- # of the json ext
+ # Now remove the json ext from the ruby sources
cd "$srcdir/ruby-${pkgver}"
- # remove the json ext
- rm -rv ext/json test/json
+ msg "applying remove-json-ext.patch"
+ rm -r ext/json test/json
patch -p1 -i ../remove-json-ext.patch
- # and insert the json_pure lib
+
+ # and insert the json_pure lib instead
+ msg "applying add-json_pure.patch"
cp -r ../json-${_jsonver}/lib/* -t lib/
cp ../json-${_jsonver}/json_pure.gemspec -t lib/json/
cp -rT ../json-${_jsonver}/tests test/json
@@ -92,7 +94,7 @@ check() {
package_ruby() {
pkgdesc='An object-oriented language for quick and easy programming'
- depends=(gdbm openssl libffi libyaml gmp zlib rubygems)
+ depends=(gdbm openssl libffi libyaml gmp zlib rubygems ruby-irb)
optdepends=(
'ruby-docs: Ruby documentation'
'tk: for Ruby/TK'