summaryrefslogtreecommitdiff
path: root/libre/riscv32-elf-binutils/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2020-06-16 15:51:02 -0400
committerDavid P <megver83@parabola.nu>2020-06-16 15:51:02 -0400
commit39f8f90b08589d919da37661c694a8406f317db8 (patch)
tree53c46dd4e4d0c42a6697b44059b59da48f29a9cc /libre/riscv32-elf-binutils/PKGBUILD
parenta1c34ae9dca91df484dc14b5361ccb40b1289c30 (diff)
downloadabslibre-39f8f90b08589d919da37661c694a8406f317db8.tar.gz
abslibre-39f8f90b08589d919da37661c694a8406f317db8.tar.bz2
abslibre-39f8f90b08589d919da37661c694a8406f317db8.zip
remove toolchains, now they're in Arch
arm-linux-gnueabihf is not in Arch, however, but it's not built in [libre], and the PKGBUILD has been here doing nothing during many months Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/riscv32-elf-binutils/PKGBUILD')
-rw-r--r--libre/riscv32-elf-binutils/PKGBUILD64
1 files changed, 0 insertions, 64 deletions
diff --git a/libre/riscv32-elf-binutils/PKGBUILD b/libre/riscv32-elf-binutils/PKGBUILD
deleted file mode 100644
index 27ddba63a..000000000
--- a/libre/riscv32-elf-binutils/PKGBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Maintainer: David P. <megver83@parabola.nu>
-
-_target=riscv32-elf
-pkgname=$_target-binutils
-pkgver=2.32
-pkgrel=1
-pkgdesc='A set of programs to assemble and manipulate binary and object files for the RISC V 32 target'
-arch=('x86_64' 'i686' 'armv7h')
-url='http://www.gnu.org/software/binutils/'
-license=(GPL)
-depends=(zlib)
-source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
-sha512sums=('99ec7ed2b5ebfd3ac16cecb1567ec4a72f81ac30717002d601708f7547b2f8122ffcce076c986f22894aede33c54c73012210a4e973ba9b6e2d87a242a2bee12'
- 'SKIP')
-validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
- '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
-
-prepare() {
- cd binutils-$pkgver
- sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
-}
-
-build() {
- cd binutils-$pkgver
-
- if [ "${CARCH}" != "i686" ]; then
- # enabling gold linker at i686 makes the install fail
- enable_gold='--enable-gold'
- fi
-
- ./configure --target=$_target \
- --with-sysroot=/usr/$_target \
- --prefix=/usr \
- --disable-multilib \
- --with-gnu-as \
- --with-gnu-ld \
- --disable-nls \
- --enable-ld=default \
- $enable_gold \
- --enable-plugins \
- --enable-deterministic-archives
-
- make
-}
-
-check() {
- cd binutils-$pkgver
-
- # unset LDFLAGS as testsuite makes assumptions about which ones are active
- # do not abort on errors - manually check log files
- make LDFLAGS="" -k check || true
-}
-
-package() {
- cd binutils-$pkgver
-
- make DESTDIR="$pkgdir" install
-
- # Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
-
- # Remove info documents that conflict with host version
- rm -r "$pkgdir"/usr/share/info
-}