summaryrefslogtreecommitdiff
path: root/libre/reflector/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-12-14 16:43:40 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-12-14 16:43:40 -0200
commitf6b9bfb88971e2fb17bd6f3529ba78836436c504 (patch)
tree402e74ab70087f3db614484735a70114e4f80e2a /libre/reflector/PKGBUILD
parentd21c17ec461dfdcb8873807f3cac7c522d44706d (diff)
downloadabslibre-f6b9bfb88971e2fb17bd6f3529ba78836436c504.tar.gz
abslibre-f6b9bfb88971e2fb17bd6f3529ba78836436c504.tar.bz2
abslibre-f6b9bfb88971e2fb17bd6f3529ba78836436c504.zip
reflector: add new package to libre repo
Diffstat (limited to 'libre/reflector/PKGBUILD')
-rw-r--r--libre/reflector/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/libre/reflector/PKGBUILD b/libre/reflector/PKGBUILD
new file mode 100644
index 000000000..ac83b14e9
--- /dev/null
+++ b/libre/reflector/PKGBUILD
@@ -0,0 +1,41 @@
+#Maintainer: Xyne <ac xunilhcra enyx, backwards>
+#Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
+pkgname=reflector
+pkgver=2013
+pkgrel=3.1
+pkgdesc='A Python 3 module and script to retrieve and filter the latest Pacman mirror list (Parabola rebranded)'
+arch=(any)
+license=(GPL)
+url="http://xyne.archlinux.ca/projects/reflector"
+depends=(python3)
+source=(
+ http://xyne.archlinux.ca/projects/reflector/src/reflector-2013.tar.xz
+ http://xyne.archlinux.ca/projects/reflector/src/reflector-2013.tar.xz.sig
+ rebranding.patch
+)
+sha512sums=(
+ 78351923edfafbf900e610d4461d341896e7618ceb4031120bb75155c5922cd6ba78b6309a04cf3802307e52d5b038ac7e7932ed8ccd59faa1acd197bd4765c5
+ SKIP
+ 29ff0df25cfc93bb0d6d8fdec69ba6e0160a8da249f4bbcaf57b9b82fb735659de6e2c1bf9a63a782bb17f29f841f8397dd48d7f60234cda292bc2eea63f8cd5
+)
+md5sums=(
+ 3ea0857cdb4ca3e3f9c9c243d09b1fea
+ SKIP
+ c96302d6afc183d12c10f6e8a23b2d21
+)
+
+prepare ()
+{
+ # Rebranding for Parabola
+ patch -Np1 -i "$srcdir/rebranding.patch"
+}
+
+package ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+
+# vim: set ts=2 sw=2 et: