summaryrefslogtreecommitdiff
path: root/libre/qtcreator/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-03-29 08:30:07 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-03-29 08:30:07 +0100
commit58aca5610d21eed65ac4ee4b5f44d2298cf8f886 (patch)
tree6ef63985709325fb0750b73fba0b6ed56c861741 /libre/qtcreator/PKGBUILD
parent7b7b2ff2f189b8c48a8299f4972a9f2cfd9f91d9 (diff)
downloadabslibre-58aca5610d21eed65ac4ee4b5f44d2298cf8f886.tar.gz
abslibre-58aca5610d21eed65ac4ee4b5f44d2298cf8f886.tar.bz2
abslibre-58aca5610d21eed65ac4ee4b5f44d2298cf8f886.zip
libre/qtcreator: updated to 4.8.2
Diffstat (limited to 'libre/qtcreator/PKGBUILD')
-rw-r--r--libre/qtcreator/PKGBUILD48
1 files changed, 14 insertions, 34 deletions
diff --git a/libre/qtcreator/PKGBUILD b/libre/qtcreator/PKGBUILD
index b2ecd0e08..c1a4048b6 100644
--- a/libre/qtcreator/PKGBUILD
+++ b/libre/qtcreator/PKGBUILD
@@ -10,11 +10,10 @@
# parabola changes and rationale:
# - removed support for qt5-webengine
-# - added patch to build on arm
pkgname=qtcreator
-pkgver=4.7.1
+pkgver=4.8.2
_clangver=7.0.1
pkgrel=1
pkgrel+=.parabola2
@@ -22,10 +21,9 @@ pkgdesc='Lightweight, cross-platform integrated development environment'
pkgdesc+=', without nonfree qt5-webengine support'
arch=(x86_64)
arch+=(i686 armv7h)
-url='http://qt-project.org'
+url='https://www.qt.io'
license=(LGPL)
-
-depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 clang=$_clangver qbs)
+depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 clang=$_clangver qbs clazy)
makedepends=(git mesa llvm python)
options=(docs)
optdepends=('qt5-doc: integrated Qt documentation'
@@ -38,54 +36,36 @@ optdepends=('qt5-doc: integrated Qt documentation'
'mercurial: mercurial support'
'bzr: bazaar support'
'valgrind: analyze support')
-source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
- qtcreator-clang-plugins.patch qtcreator-clang7.patch
- qtcreatorbug-19367a.patch::"http://code.qt.io/cgit/qt-creator/qt-creator.git/patch/?id=807b0f78"
- qtcreatorbug-19367b.patch::"http://code.qt.io/cgit/qt-creator/qt-creator.git/patch/?id=813c1685")
-source+=('0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch'
- 'libre.patch')
-sha256sums=('c98254336953f637015f14b8b4ddb5e274454a5416fd20dd09747a6e50762565'
- '6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6'
- '88b78c8ebd72cdad8f59bba8172cc5d1f3f9577e2bb31d841d5cabdd76eba36c'
- 'a7a00a390fb46f13d53055b1862dcd916deb595dbba20c2340662cab51e5a8c1'
- '89a3fff5e398f11367ab060d910098c295968e909fcca3f35d30073cd80cbf03'
- '56e6876f41ee8909ee197f7ab5a2bb18ad5a7fe26ce490a48cdf062fa199ffc6'
- '53d119a70047c6b64d8227e65d402d308017cc1d99d8886421bf2da4f7407c80')
+source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
+ qtcreator-clang-plugins.patch)
+source+=('libre.patch')
+sha256sums=('a8257daf39f6025c8523285dc73fd6b66645f3ff071e112b484325966eee0c92'
+ '34ea74698ddff9925e06bff6b4c995bf93488d1104e8cc517bcfdd621effb428'
+ 'b44b9217770573b16e7bea873b0a0fb1b9f6f59502686eb6136d78bebc671ddb')
prepare() {
mkdir -p build
+ cd qt-creator-opensource-src-$pkgver
# fix hardcoded libexec path
- sed -e 's|libexec\/qtcreator|lib\/qtcreator|g' -i qt-creator-opensource-src-${pkgver}/qtcreator.pri
-
+ sed -e 's|libexec\/qtcreator|lib\/qtcreator|g' -i qtcreator.pri
# use system qbs
- rm -r qt-creator-opensource-src-${pkgver}/src/shared/qbs
+ rm -r src/shared/qbs
# Load analyzer plugins on demand, since upstream clang doesn't link to all plugins
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
# and https://bugs.archlinux.org/task/59492
- cd qt-creator-opensource-src-${pkgver}
- patch -p1 -i "$srcdir"/qtcreator-clang-plugins.patch
- # Don't use unreleased API when building against clang 7
- patch -p1 -i "$srcdir"/qtcreator-clang7.patch
- # https://bugreports.qt.io/browse/QTCREATORBUG-19367
- patch -p1 -i "$srcdir"/qtcreatorbug-19367a.patch
- patch -p1 -i "$srcdir"/qtcreatorbug-19367b.patch
+ patch -p1 -i ../qtcreator-clang-plugins.patch
# remove qt5-webengine support
patch -Np1 -i "$srcdir"/libre.patch
rm -rv src/plugins/help/webenginehelpviewer.{cpp,h}
-
- # fix arm build
- if [[ "$CARCH" == arm* ]]; then
- git apply ../0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
- fi
}
build() {
cd build
qmake LLVM_INSTALL_DIR=/usr QBS_INSTALL_DIR=/usr CONFIG+=journald QMAKE_CFLAGS_ISYSTEM=-I \
- DEFINES+=QBS_ENABLE_PROJECT_FILE_UPDATES "$srcdir"/qt-creator-opensource-src-${pkgver}/qtcreator.pro
+ DEFINES+=QBS_ENABLE_PROJECT_FILE_UPDATES "$srcdir"/qt-creator-opensource-src-$pkgver/qtcreator.pro
make
make docs
}