summaryrefslogtreecommitdiff
path: root/libre/python2-bencode/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@parabola.nu>2013-07-03 10:33:32 -0300
committerNicolás Reynolds <fauno@parabola.nu>2013-07-03 10:33:32 -0300
commit8647aee53c2f9f5458e57fe7ac212da40a555594 (patch)
treeb99a8fbc859d18a244ea5ac496083e66ffaa330d /libre/python2-bencode/PKGBUILD
parent3a14409a347f3423bf2a4ab847edff625b671e20 (diff)
parent0a5c7083d197551290bc762f4ba90210cb733a5e (diff)
downloadabslibre-8647aee53c2f9f5458e57fe7ac212da40a555594.tar.gz
abslibre-8647aee53c2f9f5458e57fe7ac212da40a555594.tar.bz2
abslibre-8647aee53c2f9f5458e57fe7ac212da40a555594.zip
Merge branch 'master' of vparabola:abslibre
Conflicts: java/not-working/java-bnd/PKGBUILD libre/parabola-keyring/PKGBUILD
Diffstat (limited to 'libre/python2-bencode/PKGBUILD')
-rw-r--r--libre/python2-bencode/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/libre/python2-bencode/PKGBUILD b/libre/python2-bencode/PKGBUILD
new file mode 100644
index 000000000..762d55cad
--- /dev/null
+++ b/libre/python2-bencode/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+_pkgname=bencode
+pkgname=python2-bencode
+pkgver=1.0
+pkgdesc="BitTorrent bencode module as leight-weight, standalone package"
+url="http://pypi.python.org/pypi/BitTorrent-bencode"
+license=('custom:BitTorrent Open Source License')
+
+pkgrel=1
+arch=('any')
+depends=('python2')
+makedepends=('python2-distribute')
+source=(http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz
+ bittorrent-osl.txt)
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "$srcdir"/bittorrent-osl.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums=('400dd42ff346eb7db91245403f8f2b7b'
+ '016d959cb9f7a319e48d9699c4ef2f42')