summaryrefslogtreecommitdiff
path: root/libre/python-reportlab/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-09-04 11:55:29 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-09-04 11:55:29 -0500
commit5259949cb6cac53dd95d04ef5b81ae8bb933ec4a (patch)
treec0c3aa9e2d7302df9eafdae582bd84f4d2d66695 /libre/python-reportlab/PKGBUILD
parentdaab1372185ead237c61cf92ecc76514acd58fd9 (diff)
downloadabslibre-5259949cb6cac53dd95d04ef5b81ae8bb933ec4a.tar.gz
abslibre-5259949cb6cac53dd95d04ef5b81ae8bb933ec4a.tar.bz2
abslibre-5259949cb6cac53dd95d04ef5b81ae8bb933ec4a.zip
python-reportlab-3.5.6-1.parabola1: updating version
Diffstat (limited to 'libre/python-reportlab/PKGBUILD')
-rw-r--r--libre/python-reportlab/PKGBUILD54
1 files changed, 25 insertions, 29 deletions
diff --git a/libre/python-reportlab/PKGBUILD b/libre/python-reportlab/PKGBUILD
index 3b8374959..1e06723cb 100644
--- a/libre/python-reportlab/PKGBUILD
+++ b/libre/python-reportlab/PKGBUILD
@@ -2,68 +2,64 @@
# Maintainer (Arch):
# Contributor (Arch): Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Contributor (Arch): William Rea <sillywilly@gmail.com>
-# Maintainer: fauno <fauno@kiwwwi.com.ar>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: borgo <nomail>
# Contributor: André Silva <emulatorman@hyperbola.info>
+_origname=reportlab
pkgbase=python-reportlab
pkgname=(python2-reportlab python-reportlab)
-_origname=reportlab
-pkgver=3.4.0
-pkgrel=1.parabola1
+pkgver=3.5.6
+pkgrel=1
+pkgrel+=.parabola1
pkgdesc="A proven industry-strength PDF generating solution, without nonfree Adobe T1 fonts support"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://www.reportlab.org/rl_toolkit.html"
+arch=('x86_64')
+arch+=('i686' 'armv7h')
+url="https://bitbucket.org/rptlab/reportlab"
depends=('freetype2')
conflicts=('python-reportlab<=2.5-2')
-makedepends+=('python' 'python2' 'freetype2' 'python2-pillow' 'python-pillow')
+makedepends+=('python' 'python2' 'freetype2' 'python2-pillow' 'python-pillow' 'mercurial')
replaces=('python-reportlab<=2.5-2')
license=('custom')
-source=("https://pypi.python.org/packages/87/f9/53b34c58d3735a6df7d5c542bf4de60d699cfa6035e113ca08b3ecdcca3f/reportlab-3.4.0.tar.gz"
+source=(https://files.pythonhosted.org/packages/source/${_origname::1}/${_origname}/${_origname}-${pkgver}.tar.gz
'free-fonts.patch')
-md5sums=('3f2522cf3b69cd84426c216619bbff53'
- 'eb3ac47734efb05b939fb88026aff8ed')
+sha256sums=('3836a49e7ea7bce458f437cbc094633c7fd4ac027180565875c18ecc726f261e'
+ '7e31b2a2bde509d628cb7da9fec301d730d38ea8a8dc9956cdfc8da4ebeec370')
prepare() {
- cd $srcdir
- cp -rf ${_origname}-$pkgver "${_origname}2-$pkgver"
-
- _reportlab_source=("${_origname}-$pkgver" "${_origname}2-$pkgver")
+ cd "$srcdir/${_origname}-${pkgver}"
- for x in ${_reportlab_source[@]}; do
- cd $srcdir/$x
+ # remove nonfree Adobe T1 fonts support
+ patch -p1 -i ../free-fonts.patch
- # remove nonfree Adobe T1 fonts support
- patch -p1 -i $srcdir/free-fonts.patch
+ # Parabola contains those fonts from the ttf-bitstream-vera package
+ rm -fv src/reportlab/fonts/{bitstream-vera-license.txt,Vera*}
+}
- # Parabola contains those fonts from the ttf-bitstream-vera package
- rm -fv src/reportlab/fonts/{bitstream-vera-license.txt,Vera*}
- done
+build() {
+ cd $srcdir
+ cp -rf ${_origname}-${pkgver} "${_origname}2"
}
package_python2-reportlab() {
- conflicts+=('python2-reportlab-libre')
- replaces+=('python2-reportlab-libre')
depends+=('python2' 'python2-pip' 'python2-pillow')
- cd "$srcdir/${_origname}2-$pkgver"
+ cd "$srcdir/${_origname}2"
python2 setup.py install --root=$pkgdir --optimize=1
install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
}
package_python-reportlab() {
- conflicts+=('python-reportlab-libre')
- replaces+=('python-reportlab-libre')
depends+=('python3' 'python-pip' 'python-pillow')
- cd "$srcdir/${_origname}-$pkgver"
+ cd "$srcdir/${_origname}-${pkgver}"
python3 setup.py install --root=$pkgdir --optimize=1
install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
}
-
check() {
- cd ${srcdir}/${_origname}-${pkgver}
+ cd "${srcdir}/${_origname}-${pkgver}"
python2 setup.py tests
python setup.py tests
}