summaryrefslogtreecommitdiff
path: root/libre/python-django-countries/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-26 12:49:51 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-26 12:49:51 -0300
commitd21915a8e1c4130cbd5cf6d0d58ae8448de8b085 (patch)
treea383814d0c248bb11543ca8a3e7f1a6c721c7455 /libre/python-django-countries/PKGBUILD
parent7093cd981cafcf8dcf5619d4c5a7876c9acade4f (diff)
parentde4f0d5e3c54d11f8ef1fa859bc64089924b1bbc (diff)
downloadabslibre-d21915a8e1c4130cbd5cf6d0d58ae8448de8b085.tar.gz
abslibre-d21915a8e1c4130cbd5cf6d0d58ae8448de8b085.tar.bz2
abslibre-d21915a8e1c4130cbd5cf6d0d58ae8448de8b085.zip
Merge branch 'master' of ssh://projects.parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'libre/python-django-countries/PKGBUILD')
-rw-r--r--libre/python-django-countries/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/libre/python-django-countries/PKGBUILD b/libre/python-django-countries/PKGBUILD
new file mode 100644
index 000000000..93e7c8a31
--- /dev/null
+++ b/libre/python-django-countries/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+_pkgname=django-countries
+pkgname=(python-$_pkgname python2-$_pkgname)
+pkgver=2.1.2
+pkgdesc="Provides a country field for Django models"
+url="http://bitbucket.org/smileychris/$_pkgname/"
+license=('custom:MIT')
+
+conflicts=($_pkgname)
+
+pkgrel=3
+arch=(any)
+makedepends=(python{,2}-{django,setuptools})
+source=(http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
+md5sums=('15e19fd70be1e8939f1bffcfe008e878')
+
+package_python-django-countries() {
+ depends=('python-django')
+
+ cd "$srcdir/$_pkgname-$pkgver"
+ LC_ALL=en_US.UTF-8 python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-django-countries() {
+ depends=('python2-django')
+ replaces=($_pkgname)
+
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}