summaryrefslogtreecommitdiff
path: root/libre/pyqt5/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-03-31 18:20:14 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-03-31 18:20:14 -0400
commitaeaecdbf798fabfbc3d9f02ab2b20dbea67c2bc0 (patch)
treea5191315ebb1dbb8de6136c1957d569aae696c30 /libre/pyqt5/PKGBUILD
parent44726719fee67ba34d3ad3b88747136ddfbe0dbe (diff)
downloadabslibre-aeaecdbf798fabfbc3d9f02ab2b20dbea67c2bc0.tar.gz
abslibre-aeaecdbf798fabfbc3d9f02ab2b20dbea67c2bc0.tar.bz2
abslibre-aeaecdbf798fabfbc3d9f02ab2b20dbea67c2bc0.zip
libre/pyqt5: bump pkgrel for rebuild, tidy the PKGBUILD
Diffstat (limited to 'libre/pyqt5/PKGBUILD')
-rw-r--r--libre/pyqt5/PKGBUILD44
1 files changed, 27 insertions, 17 deletions
diff --git a/libre/pyqt5/PKGBUILD b/libre/pyqt5/PKGBUILD
index 2475258c5..a2ccad1e3 100644
--- a/libre/pyqt5/PKGBUILD
+++ b/libre/pyqt5/PKGBUILD
@@ -7,36 +7,46 @@
# Maintainer: André Silva <emulatorman@parabola.nu>
# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
+# Rationale: build without support for nonfree qt5-webengine.
+#
+# Differences between extra/pyqt5 and this:
+# - We a apply opengles-hack.patch on ARM
+# - We don't list qt5-webengine as a dependency. The configure
+# script will pick up on it not being there, and automatically
+# disable that module.
+# - We apply a patch to the configure to make it print which modules
+# it decides to enable/disable, so the package maintainer can tell
+# if something went wrong earlier.
+
pkgbase=pyqt5
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
pkgver=5.8
_pkgver=$pkgver
-pkgrel=2.parabola1
+pkgrel=2.parabola2
arch=('i686' 'x86_64' 'armv7h')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
'python2-dbus' 'python-dbus' 'qt5-connectivity'
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
- 'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
-source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" "pyqt-5.8-segfault.patch"
- 'opengles-hack.patch')
+ 'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
+source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" "pyqt-5.8-segfault.patch")
md5sums=('ac04c0bfc1f05f5a1c2a1edd2640235c'
- 'de7b2781874ff0c7c0d710f718cfa01a'
- 'ad09b1c84c26d5e92de192477cb3a2d1')
+ 'de7b2781874ff0c7c0d710f718cfa01a')
+source+=('pyqt5-verbose-configure.patch')
+md5sums+=('741c4b3ed85e4bf306ae2e73826d8a8b')
+source_armv7h=('opengles-hack.patch')
+md5sums_armv7h=('ad09b1c84c26d5e92de192477cb3a2d1')
prepare() {
pushd PyQt5_gpl-${_pkgver}
patch -Np1 -i "${srcdir}/pyqt-5.8-segfault.patch"
- if [[ "$CARCH" =~ ^arm*|^aarch64$ ]]; then
- patch -p1 -i ../opengles-hack.patch
- fi
- # Support Qt 5.8
- # patch -p1 -i ../pyqt-qt5.8.patch
+ case "$CARCH" in
+ armv7h) patch -p1 -i ../opengles-hack.patch;;
+ esac
+ patch -Np1 -i "${srcdir}/pyqt5-verbose-configure.patch"
popd
- # Support new versions of Qt - don't remove, needs to be reapplied after every new Qt release
- # patch -p1 -i ../pyqt-support-new-qt.patch
# The additional include path was removed due to this line, I don't really know why they are doing this...
sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-${_pkgver}/configure.py
@@ -71,7 +81,7 @@ build() {
}
package_pyqt5-common(){
- pkgdesc="Common PyQt files shared between python-pyqt5 and python2-pyqt5, without nonfree qt5-webengine support"
+ pkgdesc="Common PyQt files shared between python-pyqt5 and python2-pyqt5"
depends=('qt5-base')
cd PyQt5_gpl-${_pkgver}
@@ -82,7 +92,7 @@ package_pyqt5-common(){
}
package_python-pyqt5(){
- pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit, without nonfree qt5-webengine support"
+ pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit"
depends=('python-sip' 'pyqt5-common')
optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
'python-dbus: for python-dbus mainloop support'
@@ -103,7 +113,7 @@ package_python-pyqt5(){
}
package_python2-pyqt5(){
- pkgdesc="A set of Python 2.x bindings for the Qt5 toolkit, without nonfree qt5-webengine support"
+ pkgdesc="A set of Python 2.x bindings for the Qt5 toolkit"
depends=('python2-sip' 'pyqt5-common')
optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
'python-dbus: for python-dbus mainloop support'
@@ -124,7 +134,7 @@ package_python2-pyqt5(){
mv "${pkgdir}"/usr/bin/{,python2-}pylupdate5
mv "${pkgdir}"/usr/bin/{,python2-}pyrcc5
- #rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpyqt5.so
+ rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpyqt5.so
rm "${pkgdir}"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
}