summaryrefslogtreecommitdiff
path: root/libre/openshot-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@parabola.nu>2013-03-15 11:02:35 -0300
committerNicolás Reynolds <fauno@parabola.nu>2013-03-15 11:02:35 -0300
commit7ffee940f2966ee3f7d8511fd22bb76b77f23ae4 (patch)
tree2d8ff640511b9e52e5b3773ee947710948c6f76e /libre/openshot-libre/PKGBUILD
parente1a9a599638f8e61a3dcdbed92f9ee25ce4d0394 (diff)
parent171bf3bdded6c553ed0acd817ff85e84e309e24b (diff)
downloadabslibre-7ffee940f2966ee3f7d8511fd22bb76b77f23ae4.tar.gz
abslibre-7ffee940f2966ee3f7d8511fd22bb76b77f23ae4.tar.bz2
abslibre-7ffee940f2966ee3f7d8511fd22bb76b77f23ae4.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'libre/openshot-libre/PKGBUILD')
-rw-r--r--libre/openshot-libre/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/libre/openshot-libre/PKGBUILD b/libre/openshot-libre/PKGBUILD
new file mode 100644
index 000000000..31ea71824
--- /dev/null
+++ b/libre/openshot-libre/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Asa Marco <marcoasa90[at]gmail[.]com>
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
+
+_pkgname=openshot
+pkgname=openshot-libre
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="a free, non-linear video editor for GNU/Linux based on MLT framework (without nonfree faac recommendation)"
+arch=('any')
+url="http://www.openshotvideo.com/"
+license=('GPL')
+depends=('mlt-python-bindings' 'pygoocanvas' 'sdl' 'librsvg' 'mplayer'
+ 'pyxdg' 'pygtk' 'python2-httplib2' 'python-imaging')
+optdepends=('dvgrab: for IEEE digital sources'
+ 'libquicktime' 'libavc1394' 'jack' 'jack-rack' 'ladspa')
+replaces=$_pkgname
+conflicts=$_pkgname
+provides=$_pkgname=$pkgver
+install=openshot.install
+source=(http://launchpad.net/openshot/${pkgver%.*}/$pkgver/+download/$_pkgname-$pkgver.tar.gz)
+md5sums=('5ec82a7e8b7700ee4a359458aedf19e9')
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+}