summaryrefslogtreecommitdiff
path: root/libre/openmw/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-07-16 13:03:32 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-07-16 13:26:07 -0400
commit2a625aeac74ebc4ef3a3367bee3a8c0fe27d149a (patch)
tree9de9aaca1776844c91d818475bb2db05e0f6f51a /libre/openmw/PKGBUILD
parentc71ac506218dbe61be0b39fd0b71a44a2fd22c6c (diff)
downloadabslibre-2a625aeac74ebc4ef3a3367bee3a8c0fe27d149a.tar.gz
abslibre-2a625aeac74ebc4ef3a3367bee3a8c0fe27d149a.tar.bz2
abslibre-2a625aeac74ebc4ef3a3367bee3a8c0fe27d149a.zip
[openmw]: upgrade to v0.45.0 - fix issue #2377
Diffstat (limited to 'libre/openmw/PKGBUILD')
-rw-r--r--libre/openmw/PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/libre/openmw/PKGBUILD b/libre/openmw/PKGBUILD
index bb8fe950f..378cdc96a 100644
--- a/libre/openmw/PKGBUILD
+++ b/libre/openmw/PKGBUILD
@@ -2,22 +2,33 @@
# Contributor (Arch): Sandy Carter <bwrsandman@gmail.com>
# Contributor: André Silva <emulatorman@hyperbola.info>
pkgname=openmw
-pkgver=0.44.0
-pkgrel=6
+pkgver=0.45.0
+pkgrel=1
pkgrel+=.parabola1
pkgdesc="Open-source engine reimplementation for the role-playing game Morrowind"
-pkgdesc+=", without without wizard installation support to install nonfree assets from Morrowind to run Morrowind"
+pkgdesc+=", without without downloader/installer wizard"
arch=('x86_64')
arch+=('i686')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
depends=('openal' 'openscenegraph34' 'mygui' 'bullet' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt')
makedepends=('cmake' 'boost' 'doxygen' 'ninja')
-source=("https://github.com/OpenMW/openmw/archive/openmw-${pkgver}.tar.gz")
-sha512sums=('1b178891274361b7821ac1d3d66976ed5d443545531499d98f7ed30823f3891172cc5dcb3f7382ba0f561774a92b9ad8805e0c9582b78d2f010e4ed661219017')
+source=("https://github.com/OpenMW/openmw/archive/openmw-${pkgver}.tar.gz"
+ disable_wizard.patch)
+sha256sums=('b63cf971f406ef5f28019f65e9e2bd9641a227459ede45d147562917f67e1c64'
+ 'bb60055d501186cada01e151551a3db5c1d67c3ae6584a2799eef0e273ba14eb')
prepare() {
mkdir build
+
+ # this patch could be upstreamed
+ # when the user is missing game data (the default case),
+ # the program asks to run the dowloader wizard
+ # even though it could have detected that the wizard was not compiled (BUILD_WIZARD=OFF)
+ # then if the user presses the wizard button,
+ # it fails with a GUI warning about the non-existing wizard
+ cd "$srcdir"/$pkgname-$pkgname-$pkgver
+ patch -p1 < "$srcdir"/disable_wizard.patch
}
build() {
@@ -35,5 +46,3 @@ build() {
package() {
DESTDIR="$pkgdir" ninja -C build install
}
-
-# vim: ts=2 sw=2 et: