summaryrefslogtreecommitdiff
path: root/libre/openexr/PKGBUILD
diff options
context:
space:
mode:
authorgrizzlyuser <grizzlyuser@protonmail.com>2020-04-07 16:36:26 +0300
committerAndreas Grapentin <andreas@grapentin.org>2020-04-09 11:34:09 +0200
commit68a32222bf891a2dfc33130d1ae1897c396f4337 (patch)
tree596e4b6b75a0c6b8d867e6747a6679865e3193c5 /libre/openexr/PKGBUILD
parent9876f782ec415db7a879d5e25f8a7b5fcde5c4de (diff)
downloadabslibre-68a32222bf891a2dfc33130d1ae1897c396f4337.tar.gz
abslibre-68a32222bf891a2dfc33130d1ae1897c396f4337.tar.bz2
abslibre-68a32222bf891a2dfc33130d1ae1897c396f4337.zip
libre/openexr 2.4.1-2.parabola2: Update URL, cleanup, add missing fonts
[1] redirects to [2], so changed source URL accordingly. Since the documents are already in the tarball, no need to fetch them separately. Added most of the fonts used in the documents as makedepends. Without them, generated PDF files will display mostly tofu instead of glyphs. Of course these documents expect mostly Microsoft fonts, but luckily we have metric-compatible substitutions for them (please find the details in fontconfig file: /etc/fonts/conf.avail/30-metric-aliases.conf ) [1] https://github.com/openexr/openexr/ [2] https://github.com/AcademySoftwareFoundation/openexr Signed-off-by: Andreas Grapentin <andreas@grapentin.org>
Diffstat (limited to 'libre/openexr/PKGBUILD')
-rw-r--r--libre/openexr/PKGBUILD35
1 files changed, 7 insertions, 28 deletions
diff --git a/libre/openexr/PKGBUILD b/libre/openexr/PKGBUILD
index 3831c2d48..ac5bf7377 100644
--- a/libre/openexr/PKGBUILD
+++ b/libre/openexr/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: grizzlyuser <grizzlyuser@protonmail.com>
pkgname=openexr
pkgver=2.4.1
pkgrel=2
-pkgrel+=.parabola1
+pkgrel+=.parabola2
pkgdesc="An high dynamic-range image file format library"
pkgdesc+=", without embedded nonfree fonts in the documentation"
url="https://www.openexr.com/"
@@ -14,32 +15,14 @@ arch+=('i686' 'armv7h')
license=('BSD3')
depends=('zlib')
makedepends=('cmake' 'fltk' 'python' 'boost' 'freeglut' 'python-numpy' 'chrpath')
-makedepends+=('unoconv' 'libepoxy')
-optdepends=('fltk: for exrdisplay' 'boost-libs: python support' 'python: python support')
+makedepends+=('unoconv' 'libepoxy' 'ttf-croscore' 'ttf-caladea' 'ttf-carlito' 'gsfonts' 'ttf-bitstream-vera')
+optdepends=('fltk: for exrdisplay' 'boost-libs: python support' 'python: python support')
conflicts=('ilmbase')
replaces=('ilmbase')
-source=($pkgname-$pkgver.tar.gz::"https://github.com/openexr/openexr/archive/v$pkgver.tar.gz"
- openexr-pc-prefix.patch::"https://github.com/AcademySoftwareFoundation/openexr/commit/0b26a9de.patch"
- "https://github.com/${pkgname}/${pkgname}/raw/master/OpenEXR/doc/InterpretingDeepPixels.docx"
- "https://github.com/${pkgname}/${pkgname}/raw/master/OpenEXR/doc/MultiViewOpenEXR.odt"
- "https://github.com/${pkgname}/${pkgname}/raw/master/OpenEXR/doc/OpenEXRFileLayout.odt"
- "https://github.com/${pkgname}/${pkgname}/raw/master/OpenEXR/doc/ReadingAndWritingImageFiles.odt"
- "https://github.com/${pkgname}/${pkgname}/raw/master/OpenEXR/doc/TechnicalIntroduction.odt"
- "https://github.com/${pkgname}/${pkgname}/raw/master/OpenEXR_Viewers/doc/OpenEXRViewers.odt")
+source=($pkgname-$pkgver.tar.gz::"https://github.com/AcademySoftwareFoundation/openexr/archive/v$pkgver.tar.gz"
+ openexr-pc-prefix.patch::"https://github.com/AcademySoftwareFoundation/openexr/commit/0b26a9de.patch")
sha256sums=('3ebbe9a8e67edb4a25890b98c598e9fe23b10f96d1416d6a3ff0732e99d001c1'
- 'f20d7588badb679828816e0ada201705b7d1cc5a4d82df3d586707a792b10950'
- '6fc748b44fc4c52680db233143b53a199988f51682b206c623b05238a6fdbcbe'
- '38c46075f7efe02e231d32753966ffa463f2a3c4673dd8ea71dd47560c403db0'
- '854942160870b4c442dc249e10d8f540aa554bd793ce40576bda430f90b7f995'
- 'a4fdf678244f6c37e5ae126a9385a2e154b824b67e1746ed10bc17907c6b45ba'
- 'fab77bb2afb3d580387249807300fa26c70eaf46ca23a0036165bafee607dc4e'
- '27467ce4cad8a84cb63b2da2d58454834eac8830c2516cbe8846f32324517a92')
-noextract=(InterpretingDeepPixels.docx
- MultiViewOpenEXR.odt
- OpenEXRFileLayout.odt
- ReadingAndWritingImageFiles.odt
- TechnicalIntroduction.odt
- OpenEXRViewers.odt)
+ 'f20d7588badb679828816e0ada201705b7d1cc5a4d82df3d586707a792b10950')
prepare() {
cd $pkgname-$pkgver
@@ -49,10 +32,6 @@ prepare() {
rm -v OpenEXR/doc/{InterpretingDeepPixels,MultiViewOpenEXR,OpenEXRFileLayout,ReadingAndWritingImageFiles,TechnicalIntroduction,TheoryDeepPixels}.pdf
rm -v OpenEXR_Viewers/doc/OpenEXRViewers.pdf
- # add source documentation
- install -m644 -v "$srcdir/"{InterpretingDeepPixels.docx,{MultiViewOpenEXR,OpenEXRFileLayout,ReadingAndWritingImageFiles,TechnicalIntroduction}.odt} OpenEXR/doc
- install -m644 -v "$srcdir/"OpenEXRViewers.odt OpenEXR_Viewers/doc
-
# convert source documentation to pdf format and clean source code
pushd OpenEXR/doc
unoconv -v -f pdf {InterpretingDeepPixels.docx,{MultiViewOpenEXR,OpenEXRFileLayout,ReadingAndWritingImageFiles,TechnicalIntroduction}.odt}