summaryrefslogtreecommitdiff
path: root/libre/notsystemd/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-07-21 17:27:13 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-07-24 00:58:10 -0400
commit5cda8090484becc96da80c15f1db5b8c137a79b9 (patch)
tree633acd19dd3ac32e1f5a58285af2788a070fe0e4 /libre/notsystemd/PKGBUILD
parentb24f38ea39ad553c4cc428b189687ac6eccf1cfa (diff)
downloadabslibre-5cda8090484becc96da80c15f1db5b8c137a79b9.tar.gz
abslibre-5cda8090484becc96da80c15f1db5b8c137a79b9.tar.bz2
abslibre-5cda8090484becc96da80c15f1db5b8c137a79b9.zip
libre/notsystemd: Update to 239.1
Diffstat (limited to 'libre/notsystemd/PKGBUILD')
-rw-r--r--libre/notsystemd/PKGBUILD335
1 files changed, 187 insertions, 148 deletions
diff --git a/libre/notsystemd/PKGBUILD b/libre/notsystemd/PKGBUILD
index f8c8b88bf..6a123681a 100644
--- a/libre/notsystemd/PKGBUILD
+++ b/libre/notsystemd/PKGBUILD
@@ -1,36 +1,41 @@
-# Maintainer (Arch): Christian Hesse <mail@eworm.de>
-# Maintainer (Arch): Dave Reisner <dreisner@archlinux.org>
-# Maintainer (Arch): Tom Gundersen <teg@jklm.no>
-# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+# Maintainer (Arch:systemd): Christian Hesse <mail@eworm.de>
+# Maintainer (Arch:systemd): Dave Reisner <dreisner@archlinux.org>
+# Maintainer (Arch:systemd): Tom Gundersen <teg@jklm.no>
+# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Justification for being in [libre]: Potential dependency of
+# libretools.
+
_pkgbase=systemd
-# latest commit on stable branch
-_commit='d52e2bb9c20216972754c054e8534bca28baab66'
-# Bump this to latest major release for signed tag verification,
-# the commit count is handled by pkgver() function.
-_pkgver=234.11
-_pkgrel=8
-_pkgrel+=.parabola3
-
-pkgname=notsystemd
-pkgver=234.1
+# Can be from either systemd or systemd-stable
+_commit='de7436b02badc82200dc127ff190b8155769b8e7'
+_pkgver=239.0
+
+pkgbase=notsystemd
+# Include only split packages that link against libsystemd-shared-XXX.so
+pkgname=('notsystemd' 'notsystemd-udev' 'notsystemd-resolvconf' 'notsystemd-common')
+pkgver=239.1
pkgrel=1
-arch=('i686' 'x86_64')
-arch+=('armv7h')
+arch=('x86_64')
+arch+=('i686' 'armv7h')
url="https://repo.parabola.nu/other/${pkgname}"
-license=('GPL2' 'LGPL2.1')
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow' 'git'
- 'meson' 'libseccomp')
+ 'meson' 'libseccomp' 'pcre2')
makedepends_i686=('gnu-efi-libs')
makedepends_x86_64=('gnu-efi-libs')
options=('strip')
-source=("git://github.com/systemd/systemd-stable.git#commit=${_commit}"
- 'git://github.com/systemd/systemd.git' # pull in for tags
- "https://repo.parabola.nu/other/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
+validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
+ '5C251B5FC54EB2F80F407AAAC54CA336CFEB557E' # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
+ '99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
+source=(# fragment is latest tag for source verification, final merge in prepare()
+ "git+https://github.com/systemd/systemd-stable#tag=v${_pkgver%.*}?signed"
+ "git+https://github.com/systemd/systemd#tag=v${_pkgver%.*}?signed"
+ '0001-Use-Arch-Linux-device-access-groups.patch'
+ "https://repo.parabola.nu/other/${pkgname}/${pkgbase}-${pkgver}.tar.gz"{,.sig}
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
@@ -38,108 +43,80 @@ source=("git://github.com/systemd/systemd-stable.git#commit=${_commit}"
'loader.conf'
'splash-parabola.bmp'
'systemd-user.pam'
+ 'systemd-hook'
+ 'udev-hook'
+ 'systemd-binfmt.hook'
+ 'systemd-catalog.hook'
+ 'systemd-daemon-reload.hook'
'systemd-hwdb.hook'
+ 'systemd-sysctl.hook'
'systemd-sysusers.hook'
'systemd-tmpfiles.hook'
+ 'systemd-udev-reload.hook'
'systemd-update.hook'
'0001-FSDG-man-Refer-to-the-operating-system-as-GNU-Linux.patch'
- '0002-FSDG-os-release-Default-to-PRETTY_NAME-GNU-Linux-ins.patch'
- '0003-FSDG-os-release-Default-to-NAME-GNU-Linux-instead-of.patch'
+ '0002-FSDG-os-release-Default-PRETTY_NAME-to-GNU-Linux-ins.patch'
+ '0003-FSDG-os-release-Default-NAME-to-GNU-Linux-instead-of.patch'
'0004-FSDG-os-release-Default-ID-to-gnu-linux-instead-of-l.patch'
'0005-FSDG-systemd-resolved-Fallback-hostname-to-gnu-linux.patch'
'0006-FSDG-man-Use-FSDG-operating-systems-as-examples.patch'
'0007-FSDG-bootctl-Say-Systemd-Boot-Manager-instead-of-Lin.patch')
sha512sums=('SKIP'
'SKIP'
- '6e75173430fb2bc02a560bdc23f30586e960826e31e17bb9db5cbe1c25d037bcde47b01f686fe4b7af810f0d866b55cf04874b013cde1c61d8c6feea780f2b65'
+ '9348683829190628e25b7b3300fd880c426d555bde330d5fc5150a9a54b3ad9d4d1f2e69ea1dc6d6f086693dacc53c5af30f1fa7ad9b479791fd77bcdafa430e'
+ '0b3cfe7b3bd722aad4f3c4b3d5f66e604da6b150587c71338f0265757867c0cb5ff4956732187e3124e09dfe7a8929dfc04ec9b3948aa805c121de0c04715d75'
'SKIP'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
- 'a70a779828e03c91275df1e046f78bdface08e2a8df0245a3f6e8d5904e3dbbe5d498cbf7f32d5ce61f2fb0d0a3d440d47ce9e41352a5547d80fa1bc29687159'
+ '01de24951a05d38eca6b615a7645beb3677ca0e0f87638d133649f6dc14dcd2ea82594a60b793c31b14493a286d1d11a0d25617f54dbfa02be237652c8faa691'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
'70b3f1d6aaa9cd4b6b34055a587554770c34194100b17b2ef3aaf4f16f68da0865f6b3ae443b3252d395e80efabd412b763259ffb76c902b60e23b6b522e3cc8'
'6c6f579644ea2ebb6b46ee274ab15110718b0de40def8c30173ba8480b045d403f2aedd15b50ad9b96453f4ad56920d1350ff76563755bb9a80b10fa7f64f1d9'
'a50bc85061a9a16d776235099867bc1a17c17dddb74c1ecf5614c849735a9779c5e34e5ddca8ca6af4b59a40f57c08ecf219b98cab09476ddb0f110e6a35e45c'
'b90c99d768dc2a4f020ba854edf45ccf1b86a09d2f66e475de21fe589ff7e32c33ef4aa0876d7f1864491488fd7edb2682fc0d68e83a6d4890a0778dc2d6fe19'
- '2c1f765e7cefc50f07ad994634ea25d9396e6b9c0de46e58f18377e642a471517a0dbf5eb547070a38c6ecf84ec8e030f650a6cee010871cd7a466a32534adda'
- '7d49a948f5d58f662a7d81544254528257ef8c0a08ca560834f09a7cdf566161d2df4d419ebbc2983196cd45c9eeefcd0c4c2c554376916dce42e895262afc30'
- 'e521d92674597f82d589b83c378c50c92c881fdb84c436c8b26f7a3436a4c91a20585824a5563933f6868a3023b9ee2fdc7bd58e04bb47c25a0a36e296308fd3'
- '10190fba9f39a8f4b620a0829e0ba8ed63bb4dbeca712966011ee7807880d01ab2abff1a80baafeb6674db70526a473fe585db8190e864f318fc4d6068552618'
- 'e85c5564348253e1bc49d943f0456c38ebef0c50a5a7782ea6ebb1f45bd624a69430d79693fe1223b0adace9f07c167b84133a003a09a8b61ae48d1b70610277'
- '0ad718e9441798a4479600ffce364c2f0e582fd0ccf7762dde90f99755dee4569bcee8299ea2ccbf3a010966c8d48c59fcd0b1f93c9b8a479332c2c128fc2b2a'
- '03ec8cfde36a0a7413993118707e32b0d8b693d366da8cb22a6e71e1c10178d1df05b2e2d1d5a2a298d49af005f3cdf80bfd8d40959d3e53310491b6ada39fed'
- '9c13df718d4db2592c50c348c7b6340bbd7dd6ee6951da0f2bbd9c1878e0f034b975dfa9b28081b57e76f91c49f0bbcce314d0baaf1c5916dcff11e98d426372'
- 'b45c4e40f626a02951a852ea4cd2304f00a172dc64b5c38a97f5c68e4a89ceb4f4164cc9221533c4a5c52662e0b9629a82c521514bfcc21f0c11ce517643c2c1'
- 'f5c4cbeecac8f9d8f009deb4ac1d0b797210bcd1a91fcc6bf8ec110320ad6ceb8fd2a28b184ca037d73078d09a22f224ad3fc46f4bbf972432cce23263b2e1dc'
- 'e276fd1aedd7718333324fa9d99493fe99d951f446e3b590a99e2cc9562a0bd0e29693907997cb52096c39168c5be62ded3feedf93bacd3c9659d58775b6ca8d')
-validpgpkeys=(
- '63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering
- '99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
-)
+ '12abea62121f4e0867ffbcf6ba96bb1540dd7d86775556fc180ae6c844abfd13310b6782ff6d0e665c8d875446c17b40495d6c2fbc7ddcb42f9a13e1b57a8c40'
+ 'b7ee4f212c910df62c3472103a64a3cdf0d31292bc2f8fa839e5c86f34faa3ef1a3693601f5716779c4552a0d2b1d57538d45610f4c2e1c80e155ffbf0af187d'
+ '5a6b6beef8c31c79018884d948de840f4d3dfb07d9a87081ebf65e2b8fe595bc8c96dbd7742920ccf948c233213ed0026abc913650cefd77ad90c6f8c89bddb8'
+ '4cff2ebd962e26e2f516d8b4ac45c839dbfa54dd0588b423c224a328b9f7c62306ca7b2f6cb55240c564caf9972d5bcd2e0efaf2de49d64729aeb3bc1560c9eb'
+ '872de70325e9798f0b5a77e991c85bd2ab6de24d9b9ba4e35002d2dd5df15f8b30739a0042a624776177ffc14a838cde7ee98622016ed41df3efda9a659730b2'
+ '96bb157de6921086a2bfc45a650414fbffa787bccff2cbd838cbe05c6fc635cbabd533360608eb7ca2f80ab7df795065a27abf4a1b1ea2b406612a3fcf420bdc'
+ 'da783e3bfc6469b92dee4064a13e2b427520d3d96b57c95a4e07aaca3e844d95210a8b16122b022080f5452d65096f274dd1c1467725bbdb2e40ef304b78774a'
+ '08a590d08043a21f30f04252164b94df972b1ff1022a0469d6aef713e14484a3a037cce290a2a582851e6fac3e64add69d6cc8fc130bbeeaea08626ebf3e1763'
+ '577e33a1c50b4b41157a67f64162b035dd0c4a541e19cee55a100048bdb50cb2c82852741b1372989a0fe4c4782ba477522747fcc81d72aed99b3db512a86447'
+ 'c4463fdd25e14a836ac3b874109861a55a0169c4206b6356b53974dd4621f645652087ebf4c738b18734a718fe7fd9ec6b700ce8dd9736525274eb16b10385e6'
+ '209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67'
+ 'a40678af1cd677535fb71084f70a10b74e61592c48a7f3901d6b51429c0bae179208b4aebd6700871fdf334d67703c955f01a0cd5165571f53435783c457d568'
+ 'ae00ccf95c8cf5b6051d7c316eed36a450939d40d0d2c62aaa0ba16eb6fe3a3b1d703ea73593ff2e73f2268d30fb3dce3810528b15c9259353c3a4c158b0cc38'
+ 'fd0df3d365892d4d461a78bb0b728201e81c1269af07a38e134fadfc0ffb29aade7642142d128abcf88803b86494d7629ff5990359ef067feea3d476c7238a67'
+ 'e9e884015a40dc796fd8cbd8f79b3b9eebc7e48a332b22d52104c21c492be9982b35b7dd30bc29f2c2d274707ffd043eda059659844a4cd50eb433b8a3f7648c'
+ '0d6b894149ec8d0612d1be1dee5daa1768345232e450435ddc750e36a8309dd96782a92f0220169c69103b1c4632af708e4a737cb7ba817944c92dcb61379a30'
+ 'cf0dd60f56160f6add80ecebf698632bde55ed25e54ffa6cd0fa18da4aa2d446d3e4394295446555db22d32bf3b5f563c7e77a52eeb342a8ddaabd1347032e83'
+ '28a5b3fc9e2c5cec9267bb96725c73ee77788514f140c0cf8df765af64bc8130dd02f4863d9128ac45d54256b2ab4f2b06d1a3f65660ce1dfba5727618cd1839')
_backports=(
- # cryptsetup: fix infinite timeout (#6486)
- '0864d311766498563331f486909a0d950ba7de87'
-
- # process-util: add getpid_cached() as a caching wrapper for getpid()
- '5c30a6d2b805ae9b5dd0ad003b9ee86b8965bc47'
- # tree-wide: make use of getpid_cached() wherever we can
- 'df0ff127758809a45105893772de76082d12a26d'
-
- # call chase_symlinks without the /sysroot prefix (#6411) (FS#54958)
- '98eda38aed6a10c4f6d6ad0cac6e5361e87de52b'
)
_reverts=(
)
-_validate_tag() {
- local success fingerprint trusted status tag=v${_pkgver%.*}
-
- parse_gpg_statusfile /dev/stdin < <(git verify-tag --raw "$tag" 2>&1)
-
- if (( ! success )); then
- error 'failed to validate tag %s\n' "$tag"
- return 1
- fi
-
- if ! in_array "$fingerprint" "${validpgpkeys[@]}" && (( ! trusted )); then
- error 'unknown or untrusted public key: %s\n' "$fingerprint"
- return 1
- fi
-
- case $status in
- 'expired')
- warning 'the signature has expired'
- ;;
- 'expiredkey')
- warning 'the key has expired'
- ;;
- esac
-
- return 0
-}
-
prepare() {
cd "$_pkgbase-stable"
- git remote add upstream ../systemd/
- git fetch --all
-
- _validate_tag || return
+ # add upstream repository for cherry-picking
+ git remote add -f upstream ../systemd
+ # merge the latest stable commit (fast-foward only to make sure
+ # the verified tag is in)
+ git merge --ff-only "${_commit}"
- local _commit
- for _commit in "${_backports[@]}"; do
- git cherry-pick -n "$_commit"
+ local c
+ for c in "${_backports[@]}"; do
+ git cherry-pick -n "$c"
done
- for _commit in "${_reverts[@]}"; do
- git revert -n "$_commit"
+ for c in "${_reverts[@]}"; do
+ git revert -n "$c"
done
- # core: store the invocation ID in the per-service keyring
- # core: run each system service with a fresh session keyring
- git show 'b3415f5daef49642be3d5f417b8880c078420ff7' \
- '74dd6b515fa968c5710b396a7664cac335e25ca8' \
- -- . ':!src/test/test-id128.c' | git apply --reverse --index
+ # Replace cdrom/dialout/tape groups with optical/uucp/storage
+ patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
# apply FSDG patches
local _patch
@@ -151,8 +128,6 @@ prepare() {
for _patch in "$srcdir/$pkgname-$pkgver"/????-*.patch; do
patch -Np1 -i "$_patch"
done
-
- ./autogen.sh
}
build() {
@@ -165,9 +140,6 @@ build() {
fi
local meson_options=(
- --buildtype=release
- -Db_lto=true
-
-Daudit=false
-Dima=false
-Dlz4=true
@@ -187,7 +159,7 @@ build() {
meson_options+=(-Dgnuefi=true)
fi
- meson "$_pkgbase-stable" build "${meson_options[@]}"
+ arch-meson "$_pkgbase-stable" build "${meson_options[@]}"
ninja -C build
@@ -198,6 +170,9 @@ build() {
# Put things in the main systemd package by default
DESTDIR="$srcdir/dest/systemd" ninja -C build install
+ install -dm755 "$srcdir/dest/common"/usr/lib/systemd
+ mv -T "$srcdir/dest"/{systemd,common}/usr/lib/systemd/libsystemd-shared-${pkgver%%.*}.so
+
install -dm755 "$srcdir/dest/libsystemd"/usr/{lib/pkgconfig,share/man/man3,include}
mv -T "$srcdir/dest"/{systemd,libsystemd}/usr/include/systemd
mv -T "$srcdir/dest"/{systemd,libsystemd}/usr/lib/pkgconfig/libsystemd.pc
@@ -210,6 +185,14 @@ build() {
mv "$srcdir/dest"/systemd/usr/lib/libudev.so* -t "$srcdir/dest"/libudev/usr/lib/
mv "$srcdir/dest"/systemd/usr/share/man/man3/*udev* -t "$srcdir/dest"/libudev/usr/share/man/man3/
+ install -dm755 "$srcdir/dest/udev"/{etc,usr/lib}
+ mv -T "$srcdir/dest"/{systemd,udev}/etc/udev/
+ mv -T "$srcdir/dest"/{systemd,udev}/usr/lib/udev/
+ while read -d '' -r file; do
+ install -dm755 "$srcdir/dest/udev/${file%/*}"
+ mv -T "$srcdir/dest/systemd/$file" "$srcdir/dest/udev/$file"
+ done < <(find "$srcdir/dest/systemd" \( -name '*udev*' -o -name '*hwdb*' \) -printf '%P\0')
+
local nssmodule
for nssmodule in systemd myhostname mymachines resolve; do
install -dm755 "$srcdir/dest/nss-$nssmodule"/usr/{lib,share/man/man8}
@@ -220,20 +203,26 @@ build() {
done
install -dm755 "$srcdir/dest/systemd-sysvcompat"/usr/share/man/man8
- mv "$srcdir/dest/systemd"/usr/share/man/man8/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8 \
+ mv "$srcdir/dest/systemd"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
-t "$srcdir/dest/systemd-sysvcompat"/usr/share/man/man8
rmdir "$srcdir/dest"/systemd/usr/{share/man/man3,lib/pkgconfig,include}
}
-package() {
- pkgdesc="system and service manager"
- depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
- 'libgcrypt' 'libsystemd' 'libidn' 'lz4' 'pam' 'libelf' 'libseccomp'
- 'util-linux' 'xz')
- provides=("systemd-tools=$_pkgver" "udev=$_pkgver")
- replaces=('systemd-tools' 'udev')
- conflicts=('systemd-tools' 'udev')
+check() {
+ cd build
+ meson test
+}
+
+package_notsystemd() {
+ pkgdesc='system and service manager'
+ license=('LGPL2.1')
+ depends=('bash' 'dbus' 'kbd' 'kmod'
+ 'libsystemd' 'pam' 'libelf'
+ 'util-linux' 'pcre2')
+ depends+=("notsystemd-common=$pkgver" 'udev')
+ provides=("systemd-tools=$_pkgver")
+ conflicts=('systemd-tools')
optdepends=('libmicrohttpd: remote journald capabilities'
'quota-tools: kernel-level quota management'
'systemd-sysvcompat: symlink package to provide sysvinit binaries'
@@ -247,67 +236,117 @@ package() {
etc/systemd/system.conf
etc/systemd/timesyncd.conf
etc/systemd/resolved.conf
- etc/systemd/user.conf
- etc/udev/udev.conf)
- install="systemd.install"
+ etc/systemd/user.conf)
+ install=systemd.install
pkgdesc+=", modified to work with other init systems"
- conflicts+=("$_pkgbase")
- provides+=("$_pkgbase=$_pkgver-$_pkgrel")
+ provides+=("${pkgname#not}=$_pkgver")
+ conflicts+=("${pkgname#not}")
- cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/$_pkgbase" "$pkgdir"
+ cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/${pkgname#not}" "$pkgdir"
# don't write units to /etc by default. some of these will be re-enabled on
# post_install.
- rm -r "$pkgdir/etc/systemd/system/"*.wants
- rm -r "$pkgdir/etc/systemd/system/"*.service
+ rm -rv "$pkgdir"/etc/systemd/system/*
- # add back tmpfiles.d/legacy.conf
- install -m644 "$_pkgbase-stable/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
-
- # Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
- sed -i 's#GROUP="dialout"#GROUP="uucp"#g;
- s#GROUP="tape"#GROUP="storage"#g;
- s#GROUP="cdrom"#GROUP="optical"#g' "$pkgdir"/usr/lib/udev/rules.d/*.rules
- sed -i 's/dialout/uucp/g;
- s/tape/storage/g;
- s/cdrom/optical/g' "$pkgdir"/usr/lib/sysusers.d/basic.conf
+ # we'll create this on installation
+ rmdir "$pkgdir"/var/log/journal/remote
- # add mkinitcpio hooks
- install -Dm644 "$srcdir/initcpio-install-systemd" "$pkgdir/usr/lib/initcpio/install/systemd"
- install -Dm644 "$srcdir/initcpio-install-udev" "$pkgdir/usr/lib/initcpio/install/udev"
- install -Dm644 "$srcdir/initcpio-hook-udev" "$pkgdir/usr/lib/initcpio/hooks/udev"
+ # executable (symlinks) shipped with systemd-sysvcompat
+ rm "$pkgdir"/usr/bin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
- # ensure proper permissions for /var/log/journal. This is only to placate
- chown root:systemd-journal "$pkgdir/var/log/journal"
- chmod 2755 "$pkgdir/var/log/journal"
+ # files shipped with systemd-resolvconf
+ rm "$pkgdir"/usr/{bin/resolvconf,share/man/man1/resolvconf.1}
- # match directory owner/group and mode from extra/polkit
- chown root:102 "$pkgdir"/usr/share/polkit-1/rules.d
- chmod 0750 "$pkgdir"/usr/share/polkit-1/rules.d
+ # avoid a potential conflict with [core]/filesystem
+ rm "$pkgdir"/usr/share/factory/etc/nsswitch.conf
+ sed -i '/^C \/etc\/nsswitch\.conf/d' "$pkgdir"/usr/lib/tmpfiles.d/etc.conf
- # we'll create this on installation
- rmdir "$pkgdir/var/log/journal/remote"
+ # add back tmpfiles.d/legacy.conf, normally omitted without sysv-compat
+ install -m0644 $_pkgbase-stable/tmpfiles.d/legacy.conf "$pkgdir"/usr/lib/tmpfiles.d
# ship default policy to leave services disabled
echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
- # allow core/filesystem to pristine nsswitch.conf
- rm "$pkgdir/usr/share/factory/etc/nsswitch.conf"
- sed -i '/^C \/etc\/nsswitch\.conf/d' "$pkgdir/usr/lib/tmpfiles.d/etc.conf"
+ # add mkinitcpio hooks
+ install -D -m0644 initcpio-install-systemd "$pkgdir"/usr/lib/initcpio/install/systemd
+
+ # ensure proper permissions for /var/log/journal
+ # The permissions are stored with named group by tar, so this works with
+ # users and groups populated by systemd-sysusers. This is only to prevent a
+ # warning from pacman as permissions are set by systemd-tmpfiles anyway.
+ install -d -o root -g systemd-journal -m 2755 "$pkgdir"/var/log/journal
+
+ # match directory owner/group and mode from [extra]/polkit
+ install -d -o root -g 102 -m 0750 "$pkgdir"/usr/share/polkit-1/rules.d
# add example bootctl configuration
- install -Dm644 "$srcdir/parabola.conf" "$pkgdir"/usr/share/systemd/bootctl/parabola.conf
- install -Dm644 "$srcdir/loader.conf" "$pkgdir"/usr/share/systemd/bootctl/loader.conf
- install -Dm644 "$srcdir/splash-parabola.bmp" "$pkgdir"/usr/share/systemd/bootctl/splash-parabola.bmp
+ install -D -m0644 parabola.conf "$pkgdir"/usr/share/systemd/bootctl/parabola.conf
+ install -D -m0644 loader.conf "$pkgdir"/usr/share/systemd/bootctl/loader.conf
+ install -D -m0644 splash-parabola.bmp "$pkgdir"/usr/share/systemd/bootctl/splash-parabola.bmp
- install -Dm644 "$srcdir/systemd-hwdb.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-hwdb.hook"
- install -Dm644 "$srcdir/systemd-sysusers.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-sysusers.hook"
- install -Dm644 "$srcdir/systemd-tmpfiles.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-tmpfiles.hook"
- install -Dm644 "$srcdir/systemd-update.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-update.hook"
+ # pacman hooks
+ install -D -m0755 systemd-hook "$pkgdir"/usr/share/libalpm/scripts/systemd-hook
+ install -D -m0644 -t "$pkgdir"/usr/share/libalpm/hooks *.hook
+ rm -- "$pkgdir"/usr/share/libalpm/hooks/*{udev,hwdb}*
# overwrite the systemd-user PAM configuration with our own
- install -Dm644 systemd-user.pam "$pkgdir/etc/pam.d/systemd-user"
+ install -D -m0644 systemd-user.pam "$pkgdir"/etc/pam.d/systemd-user
}
-# vim: ft=sh syn=sh et
+package_notsystemd-common() {
+ pkgdesc='systemd files shared between split packages'
+ license=('LGPL2.1')
+ depends=('acl' 'cryptsetup' 'libdbus' 'glibc' 'iptables' 'libcap'
+ 'libgcrypt' 'libidn' 'libseccomp' 'libsystemd.so'
+ 'libudev.so' 'libblkid.so' 'libmount.so' 'libuuid.so' 'lz4'
+ 'xz')
+
+ pkgdesc="not${pkgdesc}"
+ conflicts+=("${pkgname#not}")
+
+ cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/${pkgname#notsystemd-}" "$pkgdir"
+}
+
+package_notsystemd-udev() {
+ pkgdesc='Userspace device file manager'
+ license=('GPL2') # NB: different than the rest
+ groups=('base')
+ depends=("notsystemd-common=$pkgver" 'systemd-libudev'
+ 'hwids' 'kmod' 'util-linux' 'zlib')
+ backup=(etc/udev/udev.conf)
+
+ provides+=("${pkgname#notsystemd-}=$_pkgver")
+ conflicts+=("${pkgname#notsystemd-}")
+
+ provides+=("${pkgname#not}=$_pkgver")
+ conflicts+=("${pkgname#not}")
+
+ cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/${pkgname#notsystemd-}" "$pkgdir"
+
+ # add mkinitcpio hooks
+ install -D -m0644 initcpio-install-udev "$pkgdir"/usr/lib/initcpio/install/udev
+ install -D -m0644 initcpio-hook-udev "$pkgdir"/usr/lib/initcpio/hooks/udev
+
+ # pacman hooks
+ install -D -m0755 udev-hook "$pkgdir"/usr/share/libalpm/scripts/udev-hook
+ install -D -m0644 -t "$pkgdir"/usr/share/libalpm/hooks *{udev,hwdb}*.hook
+}
+
+package_notsystemd-resolvconf() {
+ pkgdesc='systemd resolvconf replacement'
+ license=('LGPL2.1')
+ depends=('notsystemd' "notsystemd-common=$pkgver")
+ provides=('openresolv' 'resolvconf')
+ conflicts=('openresolv')
+
+ pkgdesc="not${pkgdesc}"
+ provides+=("${pkgname#not}=$_pkgver")
+ conflicts+=("${pkgname#not}")
+
+ install -d -m0755 "$pkgdir"/usr/bin
+ ln -s resolvectl "$pkgdir"/usr/bin/resolvconf
+
+ install -d -m0755 "$pkgdir"/usr/share/man/man1
+ ln -s resolvectl.1.gz "$pkgdir"/usr/share/man/man1/resolvconf.1.gz
+}