summaryrefslogtreecommitdiff
path: root/libre/nettle-static/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2016-04-18 10:29:03 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2016-04-18 12:53:23 -0300
commitc1169c2a7aba84acf9aff2f61dd159343ec3679b (patch)
tree272ef178e49873b20c67e43e3051034500aae432 /libre/nettle-static/PKGBUILD
parent39c12e2fbdd5e54b8b4135b882f21c7ef1b52ea2 (diff)
downloadabslibre-c1169c2a7aba84acf9aff2f61dd159343ec3679b.tar.gz
abslibre-c1169c2a7aba84acf9aff2f61dd159343ec3679b.tar.bz2
abslibre-c1169c2a7aba84acf9aff2f61dd159343ec3679b.zip
nettle-static: add new package to [libre]
Diffstat (limited to 'libre/nettle-static/PKGBUILD')
-rw-r--r--libre/nettle-static/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/libre/nettle-static/PKGBUILD b/libre/nettle-static/PKGBUILD
new file mode 100644
index 000000000..8ab831635
--- /dev/null
+++ b/libre/nettle-static/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Márcio Silva <coadde@parabola.nu>
+# based of nettle
+
+_pkgname=nettle
+pkgname=nettle-static
+pkgver=3.2
+pkgrel=1
+pkgdesc="A low-level cryptographic library (static libraries only)"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.lysator.liu.se/~nisse/nettle/"
+license=('GPL2')
+depends=('gmp-static')
+checkdepends=('valgrind')
+options=('staticlibs')
+source=(https://ftp.gnu.org/gnu/$_pkgname/$_pkgname-$pkgver.tar.gz{,.sig})
+md5sums=('afb15b4764ebf1b4e6d06c62bd4d29e4'
+ 'SKIP')
+validpgpkeys=('343C2FF0FBEE5EC2EDBEF399F3599FF828C67298') # Niels Möller <nisse@lysator.liu.se>
+
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-static
+ make
+}
+
+check() {
+ cd $_pkgname-$pkgver
+ make -k check
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+
+ # remove conflicting files
+ rm -vr ${pkgdir}/usr/{bin,include,lib/pkgconfig,share}
+ rm -v ${pkgdir}/usr/lib/lib*.so*
+}