summaryrefslogtreecommitdiff
path: root/libre/netsurf/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-26 22:43:46 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-26 22:43:46 -0500
commit82548f6e7cba2ea97bc82330dee690aff6bfecc8 (patch)
treedc57da9537ad774d990cdafc778c2814d84eca59 /libre/netsurf/PKGBUILD
parent34da01520f42061a2eb5ef5194d8d1f44da8140f (diff)
downloadabslibre-82548f6e7cba2ea97bc82330dee690aff6bfecc8.tar.gz
abslibre-82548f6e7cba2ea97bc82330dee690aff6bfecc8.tar.bz2
abslibre-82548f6e7cba2ea97bc82330dee690aff6bfecc8.zip
netsurf-3.9-2.par1: updating version
Diffstat (limited to 'libre/netsurf/PKGBUILD')
-rw-r--r--libre/netsurf/PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/libre/netsurf/PKGBUILD b/libre/netsurf/PKGBUILD
index 3097b1ee5..1cc1b8383 100644
--- a/libre/netsurf/PKGBUILD
+++ b/libre/netsurf/PKGBUILD
@@ -6,26 +6,27 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=netsurf
-pkgver=3.8
+pkgver=3.9
pkgrel=2
pkgrel+=.par1
pkgdesc='Lightweight and fast web browser'
pkgdesc+=', without non-privacy search engines'
-arch=('x86_64')
-arch+=('i686' 'armv7h')
+arch=(x86_64)
+arch+=(i686 armv7h)
url='https://www.netsurf-browser.org/'
-license=('MIT' 'GPL2')
+license=(MIT GPL2)
replaces=(${pkgname}-libre)
conflicts=(${pkgname}-libre)
-depends=('curl' 'gtk3' 'libhubbub' 'libjpeg-turbo' 'libnsutils>=0.0.5' 'libutf8proc>=2.1.1'
- 'libwapcaplet')
-makedepends=('check' 'inetutils' 'libcss>=0.8.0' 'libdom>=0.3.3' 'libnsbmp>=0.1.5'
- 'libnsgif>=0.2.1' 'nsgenbind' 'perl-html-parser' 'setconf')
+depends=(curl gtk3 'libhubbub=0.3.6' libjpeg-turbo 'libnsutils=0.0.5-4'
+ 'libutf8proc>=2.4.0' 'libwapcaplet>=0.4.2' 'libdom>=0.4.0')
+# vim is needed only for xxd when building
+makedepends=(check inetutils 'libcss>=0.9.0' 'libnsbmp>=0.1.5'
+ 'libnsgif>=0.2.1' 'nsgenbind>=0.7' perl-html-parser setconf vim)
source=("https://download.netsurf-browser.org/netsurf/releases/source-full/netsurf-all-$pkgver.tar.gz"
- 'netsurf.sh'
- 'remove_nonprivacy_options.patch')
-sha256sums=('eb4864d4459d6f9958dd10a3301c272ea7f5df72667a7db0aad5bc5ae06c0e10'
- '1f1b495af685e611fe4d121c6d48ed63d6dfe0c69bd5637c41cd71b42429fa85'
+ netsurf.sh
+ remove_nonprivacy_options.patch)
+sha256sums=('11e384eaf47e65c186da5001f1055a02f2d72ff17b50f403b8392546a2cf65ff'
+ '34c1f41c02ff3791a1b734197d99ec7f58c403dee05f0f9b7b9b3509d32b51ac'
'61bec340c47a089b1b5c33d3ae330a340999a1e40be7fc8768fa572c6ca3b617')
prepare() {
@@ -113,7 +114,8 @@ prepare() {
}
build() {
- CFLAGS="$CFLAGS -w -Os -funroll-loops" make -C "$pkgname-all-$pkgver/$pkgname" \
+ CFLAGS="$CFLAGS -w -Os -funroll-loops" make \
+ -C "$pkgname-all-$pkgver/$pkgname" \
NETSURF_GTK_MAJOR=3 \
TARGET=gtk \
LIBDIR=lib \