summaryrefslogtreecommitdiff
path: root/libre/ndiswrapper-module/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2020-01-31 15:08:12 +0100
committerAndreas Grapentin <andreas@grapentin.org>2020-01-31 15:11:18 +0100
commit43453ca90eeee7dde9e1b6faecc433aa4dc889b9 (patch)
treed4f297da9e9f8a24fa258c9c2797426da8efdaa2 /libre/ndiswrapper-module/PKGBUILD
parent02710d03959105e09429a0406d7f58996d24495e (diff)
downloadabslibre-43453ca90eeee7dde9e1b6faecc433aa4dc889b9.tar.gz
abslibre-43453ca90eeee7dde9e1b6faecc433aa4dc889b9.tar.bz2
abslibre-43453ca90eeee7dde9e1b6faecc433aa4dc889b9.zip
libre/ndiswrapper-module: added
Diffstat (limited to 'libre/ndiswrapper-module/PKGBUILD')
-rw-r--r--libre/ndiswrapper-module/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/libre/ndiswrapper-module/PKGBUILD b/libre/ndiswrapper-module/PKGBUILD
new file mode 100644
index 000000000..0678ece28
--- /dev/null
+++ b/libre/ndiswrapper-module/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
+# Contributor (Arch): maz-1 <loveayawaka@gmail.com>
+# Contributor: Andreas Grapentin <andreas@grapentin.org>
+
+_basekernel=5.4.12-1
+
+pkgname=ndiswrapper-module
+pkgver=1.62
+pkgrel=24
+pkgrel+=.parabola1.basekernel${_basekernel%-*}
+pkgdesc="Module for NDIS (Windows Network Drivers) drivers supplied by vendors, kernel module for Linux kernel"
+pkgdesc+=' (built for the linux-libre kernel package)'
+arch=('x86_64')
+arch+=('i686')
+url="https://sourceforge.net/projects/ndiswrapper/"
+license=('GPL')
+makedepends=(linux-libre-headers=${_basekernel%-*} git libelf)
+conflicts=('ndiswrapper-arch')
+provides=('NDISWRAPPER-MODULE')
+replaces=('ndiswrapper-arch')
+source=("https://sourceforge.net/projects/ndiswrapper/files/stable/ndiswrapper-$pkgver.tar.gz"
+ 'kernel-5.3.patch' 'kernel-5.4.patch' 'kernel-5.5.patch')
+sha512sums=('a6e111bc699572642e44d6d31cc2f06374648a01b8dd7dd4e74d6ad5e187e39f99faee38f792c83a94d4618ae4d8866914fb3f60b1d80e838a753285ea7cf783'
+ 'c404f35280534b172235c5c578657d7a30ac2253c7c2abedd65a183d09390e95e7c3030cb409accb4d198ff0411482f8029f8664418c99d5672f92e9c733801d'
+ '36450042db79ed4545030276bff9db1bc9895259f38c1c0bf4dc238ad76ec61c2e08d437997dafd327f2a8fd1694d61e418941555e92144e3ec86c8066561429'
+ 'ed543cbfb236de0a20e1f164c22c83cd19aec416b5f50a58cee731857231c667d166c36814047174bddda36261af71e92ecdb2944e5b818a603085af279fbd89')
+
+prepare() {
+ cd ndiswrapper-$pkgver
+ patch --no-backup-if-mismatch -p2 -i "$srcdir"/kernel-5.3.patch
+ patch --no-backup-if-mismatch -p1 -i "$srcdir"/kernel-5.4.patch
+ patch --no-backup-if-mismatch -p1 -i "$srcdir"/kernel-5.5.patch
+}
+
+build() {
+ _kernver="$(</usr/src/linux-libre/version)"
+
+ cd ndiswrapper-$pkgver
+ make -C driver KVERS_UNAME="$_kernver"
+}
+
+package() {
+ depends=(linux-libre=${_basekernel%-*})
+
+ _extradir="/usr/lib/modules/$(</usr/src/linux-libre/version)/extramodules"
+ cd ndiswrapper-$pkgver
+ install -Dt "$pkgdir$_extradir" -m644 driver/*.ko
+ find "$pkgdir" -name '*.ko' -exec xz {} +
+}