summaryrefslogtreecommitdiff
path: root/libre/mplayer-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-02-10 10:03:33 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-02-10 10:03:33 -0300
commit66c2e4229b76e11c798f2897555beae76a056cbc (patch)
tree8855ca1e5f4feb16c278343a6cbcca1ef4d91113 /libre/mplayer-libre/PKGBUILD
parent8ff88e2d3f96711e2564612c66c1f5cc41935a23 (diff)
downloadabslibre-66c2e4229b76e11c798f2897555beae76a056cbc.tar.gz
abslibre-66c2e4229b76e11c798f2897555beae76a056cbc.tar.bz2
abslibre-66c2e4229b76e11c798f2897555beae76a056cbc.zip
mplayer-libre-32792-1
Diffstat (limited to 'libre/mplayer-libre/PKGBUILD')
-rw-r--r--libre/mplayer-libre/PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/libre/mplayer-libre/PKGBUILD b/libre/mplayer-libre/PKGBUILD
new file mode 100644
index 000000000..2d988c976
--- /dev/null
+++ b/libre/mplayer-libre/PKGBUILD
@@ -0,0 +1,60 @@
+# $Id$
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Maintainer for Parabola GNU/Linux: Omar Botta <omarbotta@gnulinuxlibre.net>
+
+pkgname=mplayer-libre
+pkgver=32792
+pkgrel=1
+pkgdesc="A movie player for linux. Libre version without faac."
+arch=('i686' 'x86_64')
+depends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss'
+ 'libgl' 'smbclient' 'aalib' 'jack' 'libcaca' 'x264' 'lirc-utils' 'ttf-dejavu' 'libxvmc' 'enca' 'libvdpau>=0.4'
+ 'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'speex')
+license=('GPL')
+url="http://www.mplayerhq.hu/"
+makedepends=('unzip' 'mesa' 'live-media>=2010.01.13' 'yasm')
+backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
+source=(ftp://ftp.archlinux.org/other/${pkgname%-libre}/${pkgname%-libre}-${pkgver}.tar.xz mplayer.desktop mplayer.png)
+provides=("mplayer=$pkgver")
+conflicts=('mplayer')
+replaces=("mplayer=$pkgver")
+
+build() {
+ # Custom CFLAGS break the mplayer build
+ unset CFLAGS LDFLAGS
+
+ cd ${srcdir}/${pkgname%-libre}
+
+ ./configure --prefix=/usr \
+ --enable-runtime-cpudetection \
+ --disable-gui \
+ --disable-arts \
+ --disable-liblzo \
+ --enable-speex \
+ --disable-openal \
+ --disable-fribidi \
+ --disable-libdv \
+ --disable-musepack \
+ --disable-esd \
+ --disable-mga \
+ --disable-faac \
+ --enable-xvmc \
+ --language=all \
+ --confdir=/etc/mplayer
+
+ [ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
+
+ make
+ make -j1 DESTDIR=${pkgdir} install
+ install -Dm644 etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
+ install -dm755 ${pkgdir}/usr/share/mplayer/
+ ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
+ rm -rf ${pkgdir}/usr/share/mplayer/font
+ #desktop file FS#14770
+ install -Dm644 ${srcdir}/mplayer.desktop ${pkgdir}/usr/share/applications/mplayer.desktop
+ install -Dm644 ${srcdir}/mplayer.png ${pkgdir}/usr/share/pixmaps/mplayer.png
+}
+md5sums=('a48845de4b410ab7799ee87a038dd58e'
+ 'c0d6ef795cf6de48e3b87ff7c23f0319'
+ 'd00874ccc644b7f43d6ef1c942fcef28')