summaryrefslogtreecommitdiff
path: root/libre/midori-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-09-02 15:08:37 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-09-02 15:08:37 -0300
commit2361f786df8f21fa83014ea2150efa99ab339e8d (patch)
tree5e43e3baa78b0d25cbee6be720bf791a6918f746 /libre/midori-libre/PKGBUILD
parentdff348f756b280299c85dc88af1ccab633bef6cf (diff)
downloadabslibre-2361f786df8f21fa83014ea2150efa99ab339e8d.tar.gz
abslibre-2361f786df8f21fa83014ea2150efa99ab339e8d.tar.bz2
abslibre-2361f786df8f21fa83014ea2150efa99ab339e8d.zip
midori-libre: add new package to libre repo
Diffstat (limited to 'libre/midori-libre/PKGBUILD')
-rw-r--r--libre/midori-libre/PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/libre/midori-libre/PKGBUILD b/libre/midori-libre/PKGBUILD
new file mode 100644
index 000000000..dd1f9e36d
--- /dev/null
+++ b/libre/midori-libre/PKGBUILD
@@ -0,0 +1,66 @@
+# $Id: PKGBUILD 95661 2013-08-15 11:42:31Z arodseth $
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: rabyte <rabyte.at.gmail.dot.com>
+# Contributor: Johannes Krampf <wuischke.at.amule.dot.org>
+# Contributor: Bartłomiej Piotrowski <barthalion@gmail.com>
+# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
+
+_pkgname=midori
+pkgname=midori-libre
+pkgver=0.5.5
+pkgrel=1
+pkgdesc='Lightweight web browser (GTK2), without non-privacy search providers'
+arch=('x86_64' 'i686')
+url='http://www.midori-browser.org/'
+license=('LGPL2.1')
+install='midori.install'
+replaces=$_pkgname
+conflicts=$_pkgname
+provides=$_pkgname=$pkgver
+depends=('libzeitgeist' 'webkitgtk2' 'libnotify' 'libxss' 'hicolor-icon-theme' 'desktop-file-utils' 'libunique')
+makedepends=('bzr' 'python2' 'intltool' 'vala' 'librsvg')
+optdepends=('gstreamer0.10-base-plugins: HTML5 OGG videos support'
+ 'gstreamer0.10-bad-plugins: HTML5 WebM videos support'
+ 'gstreamer0.10-ffmpeg: HTML5 H264 videos support'
+ 'aria2: download utility')
+options=('!emptydirs')
+source=("http://www.midori-browser.org/downloads/${_pkgname}_${pkgver}_all_.tar.bz2")
+sha256sums=('ca69382a285222a86028abebd73fed1976735883027ff0adc094b627789bbd62')
+
+prepare() {
+ cd "$srcdir/${_pkgname/-gtk3}-${pkgver}"
+
+ # remove non-privacy search providers
+ sed -i 's|Duck Duck Go|DuckDuckGo HTML|
+ s|duckduckgo[.]com|duckduckgo.com/html|
+ \|Yahoo|d
+ \|name=Yahoo|d
+ \|text=Yahoo Web Search|d
+ \|uri=http://search[.]yahoo[.]com/search?p=|d
+ \|token=y|d
+ \|Google|d
+ \|name=Google|d
+ \|text=Web Search|d
+ \|uri=http://www[.]google[.]com/search?q=%s|d
+ \|token=g|d
+ \|Localize text or URL|d
+ \|translate[.]google[.]com/?q=|d
+ ' config/search
+}
+
+build() {
+ cd "$srcdir/$_pkgname-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: