summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-01-05 14:45:30 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-01-05 14:45:30 -0300
commita8731e767fbd0e9364635447bac600259e8a0333 (patch)
tree4aa9f2249148e5675b62bf25e51e6161e108ecd9 /libre/linux-libre/PKGBUILD
parent18e3b6be34a29f043ccd050b3f4a98c98ac2c215 (diff)
downloadabslibre-a8731e767fbd0e9364635447bac600259e8a0333.tar.gz
abslibre-a8731e767fbd0e9364635447bac600259e8a0333.tar.bz2
abslibre-a8731e767fbd0e9364635447bac600259e8a0333.zip
libre/linux-libre-3.2-1
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD32
1 files changed, 12 insertions, 20 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 966e3d979..8ca117ae5 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -8,8 +8,8 @@ pkgbase=linux-libre
pkgname=('linux-libre' 'linux-libre-headers' 'linux-libre-docs') # Build stock -LIBRE kernel
# pkgname=linux-custom # Build kernel with a different name
_kernelname=${pkgname#linux-libre}
-_basekernel=3.1
-pkgver=${_basekernel}.7
+_basekernel=3.2
+pkgver=${_basekernel}
pkgrel=1
arch=('i686' 'x86_64')
url="http://linux-libre.fsfla.org/"
@@ -17,7 +17,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-libre/linux-${_basekernel}-libre.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/patch-${_basekernel}-libre-${pkgver}-libre.xz"
+# "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/patch-${_basekernel}-libre-${pkgver}-libre.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -25,23 +25,12 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-li
'boot-logo.patch'
'change-default-console-loglevel.patch'
'i915-fix-ghost-tv-output.patch'
- 'i915-fix-incorrect-error-message.patch'
'usb-add-reset-resume-quirk-for-several-webcams.patch')
-md5sums=('d73df15ab1d36fe3c102755d8f42117f'
- '47e4a10500ad90694b7f42fb447ab810'
- '267ea59695619730032f89ac70bf9391'
- '5a415fc0c864dc3f5c4afa63f1506c52'
- 'a8a3843046926eb7ab81312cd438c5c5'
- '04b21c79df0a952c22d681dd4f4562df'
- '9d3c56a4b999c8bfbd4018089a62f662'
- '263725f20c0b9eb9c353040792d644e5'
- 'a50c9076012cb2dda49952dc6ec3e9c1'
- '52d41fa61e80277ace2b994412a0c856')
build() {
cd "${srcdir}/linux-${_basekernel}"
- patch -Np1 -i "${srcdir}/patch-${_basekernel}-libre-${pkgver}-libre"
+# patch -Np1 -i "${srcdir}/patch-${_basekernel}-libre-${pkgver}-libre"
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
@@ -55,11 +44,6 @@ build() {
# needed.
patch -Np1 -i "${srcdir}/i915-fix-ghost-tv-output.patch"
- # In 3.1.1, a DRM_DEBUG message is falsely declared as DRM_ERROR. This
- # worries users, as this message is displayed even at loglevel 4. Fix
- # this.
- patch -Np1 -i "${srcdir}/i915-fix-incorrect-error-message.patch"
-
# Add the USB_QUIRK_RESET_RESUME for several webcams
# FS#26528
patch -Np1 -i "${srcdir}/usb-add-reset-resume-quirk-for-several-webcams.patch"
@@ -301,3 +285,11 @@ package_linux-libre-docs() {
# remove a file already in linux package
rm -f "${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile"
}
+md5sums=('27c641c4f6785fc647cdd3e44963a55c'
+ 'eb37c323f6993d6cc963c61a1f482956'
+ '4e9be096386838d247672963f9af9ea8'
+ 'a8a3843046926eb7ab81312cd438c5c5'
+ '04b21c79df0a952c22d681dd4f4562df'
+ '9d3c56a4b999c8bfbd4018089a62f662'
+ '263725f20c0b9eb9c353040792d644e5'
+ '52d41fa61e80277ace2b994412a0c856')