summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-12 14:09:59 -0300
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-12 14:09:59 -0300
commita8a0c9d4965d7b004de5659cb9dcbadd8d8d714d (patch)
tree9eae7925679039fbcf8d80340c1462cf94a5e2de /libre/linux-libre/PKGBUILD
parent6d006ae5a02b1276e0fe231c95a23465e126e759 (diff)
downloadabslibre-a8a0c9d4965d7b004de5659cb9dcbadd8d8d714d.tar.gz
abslibre-a8a0c9d4965d7b004de5659cb9dcbadd8d8d714d.tar.bz2
abslibre-a8a0c9d4965d7b004de5659cb9dcbadd8d8d714d.zip
linux-libre-3.4.2-2: fix potential nfs4 issue and updating version for mips64el
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 4f10a211a..78f03392c 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -14,8 +14,8 @@ _kernelname=-LIBRE
_basekernel=3.4
_sublevel=2
pkgver=${_basekernel}.${_sublevel}
-_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
-pkgrel=1
+_lxopkgver=${_basekernel}.2 # nearly always the same as pkgver
+pkgrel=2
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -32,6 +32,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'i915-fix-ghost-tv-output.patch'
+ '3.4.2-rpc_pipefs.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('a5e128ca059cceb8b69148b41ff4ac6f'
'ea827952923c8a926c0831ad3f124190'
@@ -43,7 +44,8 @@ md5sums=('a5e128ca059cceb8b69148b41ff4ac6f'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
'263725f20c0b9eb9c353040792d644e5'
- 'f70a4bf0ee00d8be680cfbd65459836d')
+ '18b3877f9014c8cdd5eb8f6a9e8a3a3a'
+ '972b3b460764780ee48f031a043a9c09')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -60,6 +62,11 @@ build() {
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
+ # fix nfs4 regression
+ patch -Np1 -i "${srcdir}/3.4.2-rpc_pipefs.patch"
+ # add latest fixes from stable queue, if needed
+ # http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+
# Some chips detect a ghost TV output
# mailing list discussion: http://lists.freedesktop.org/archives/intel-gfx/2011-April/010371.html
# Arch Linux bug report: FS#19234