summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2019-05-24 18:35:51 -0400
committerDavid P <megver83@parabola.nu>2019-05-24 18:35:51 -0400
commit55df9017ecf53f6301558215dfa19fee80845c92 (patch)
treebc032539b4e33ef7fa8c045029d41aa99bf85610 /libre/linux-libre/PKGBUILD
parent9ac6b69431ce03a8e7caf055cb45fa9762af7ed7 (diff)
downloadabslibre-55df9017ecf53f6301558215dfa19fee80845c92.tar.gz
abslibre-55df9017ecf53f6301558215dfa19fee80845c92.tar.bz2
abslibre-55df9017ecf53f6301558215dfa19fee80845c92.zip
revert 2c0e4d1e9bf9a8ec731ac35aabcbfd265ccb866e
this is the normal behaviour the kernels *must* have, because that means that configs have to be updated Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD30
1 files changed, 9 insertions, 21 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 43c009f1a..9e80fdd0e 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -6,7 +6,6 @@
# Contributor: Michał Masłowski <mtjm@mtjm.eu>
# Contributor: Luke R. <g4jc@openmailbox.org>
# Contributor: Andreas Grapentin <andreas@grapentin.org>
-# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
# Based on linux package
@@ -22,7 +21,7 @@ _replacesoldmodules=() # '%' gets replaced with _kernelname
_srcname=linux-${_srcbasever%-*}
_archpkgver=${_srcver%-*}
pkgver=${_srcver//-/_}
-pkgrel=2
+pkgrel=1
rcnrel=armv7-x3
arch=(i686 x86_64 armv7h)
url='https://linux-libre.fsfla.org/'
@@ -34,9 +33,7 @@ source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcbasever/linux-libre-$_srcbasever.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcver/patch-$_srcbasever-$_srcver.xz"{,.sign}
"https://repo.parabola.nu/other/linux-libre/logos/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
- parabola-i686_defconfig # the kernel configuration for the i686 architecture
- parabola-x86_64_defconfig # the kernel configuration for the x86_64 architecture
- parabola-armv7h_defconfig # the kernel configuration for the armv7h architecture
+ config.i686 config.x86_64 config.armv7h # the main kernel config files
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
@@ -124,6 +121,11 @@ prepare() {
install -m644 -t drivers/video/logo \
../logo_linux_{clut224.ppm,vga16.ppm,mono.pbm}
+ msg2 "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "$_kernelname" > localversion.20-pkgname
+
if [ "$CARCH" = "armv7h" ]; then
# RCN patch (CM3 firmware deblobbed and AUFS/WireGuard removed)
# Note: For stability reasons, AUFS has been removed in the RCN patch.
@@ -148,23 +150,9 @@ prepare() {
patch -Np1 < "../$src"
done
- # Parabola changes
- # Copy the parabola configuration in the source code
- # - This makes sure that all the configuration of all
- # architectures are available in the source code
- # - Using the built-in kenrel mechanism should take
- # care of making sure that no user input is required
- cp -f ../parabola-armv7h_defconfig arch/arm/configs/
- cp -f ../parabola-i686_defconfig arch/x86/configs/
- cp -f ../parabola-x86_64_defconfig arch/x86/configs/
msg2 "Setting config..."
- make parabola-${CARCH}_defconfig
- # end of Parabola changes
-
- msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
+ cp ../config.$CARCH .config
+ make olddefconfig
make -s kernelrelease > ../version
msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"