summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2021-02-27 19:27:55 -0500
committerDavid P <megver83@parabola.nu>2021-02-27 19:27:55 -0500
commitca819c9780da3a59cf2f02bb7477fddc221123b8 (patch)
treec2eb17b20dcc135245ff363a636045e86ddc7e58 /libre/linux-libre-lts/PKGBUILD
parentad032a5f195584167d07c37cd65647f3b5650258 (diff)
downloadabslibre-ca819c9780da3a59cf2f02bb7477fddc221123b8.tar.gz
abslibre-ca819c9780da3a59cf2f02bb7477fddc221123b8.tar.bz2
abslibre-ca819c9780da3a59cf2f02bb7477fddc221123b8.zip
updpkg: libre/linux-libre-lts 5.10.19-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rw-r--r--libre/linux-libre-lts/PKGBUILD108
1 files changed, 52 insertions, 56 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index b499afa50..a803865df 100644
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -14,20 +14,20 @@ _replacesoldkernels=() # '%' gets replaced with kernel suffix
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre-lts
-pkgver=5.4.85
+pkgver=5.10.19
pkgrel=1
pkgdesc='LTS Linux-libre'
-rcnver=5.4.82
-rcnrel=armv7-x39
+rcnver=5.10.17
+rcnrel=armv7-x26
url='https://linux-libre.fsfla.org/'
arch=(i686 x86_64 armv7h)
license=(GPL2)
makedepends=(
- bc kmod libelf cpio perl tar xz
+ bc kmod libelf pahole cpio perl tar xz
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
)
options=('!strip')
-_srcname=linux-5.4
+_srcname=linux-5.10
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu/patch-${_srcname##*-}-gnu-$pkgver-gnu.xz"{,.sign}
@@ -44,30 +44,24 @@ source=(
0002-fix-Atmel-maXTouch-touchscreen-support.patch
# Arch Linux patches
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-virt-vbox-Add-support-for-the-new-VBG_IOCTL_ACQUIRE_.patch
- sphinx-workaround.patch
+# 0002-virt-vbox-Add-support-for-the-new-VBG_IOCTL_ACQUIRE_.patch
+# sphinx-workaround.patch
+)
+source_i686=(
+ # avoid using zstd compression in ultra mode (exhausts virtual memory)
+ no-ultra-zstd.patch
)
source_armv7h=(
# RCN patch (CM3 firmware deblobbed and bloatware removed)
"https://repo.parabola.nu/other/rcn-libre/patches/$rcnver/rcn-libre-$rcnver-$rcnrel.patch"{,.sig}
- # Arch Linux ARM patches
- 0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
- 0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
- 0003-SMILE-Plug-device-tree-file.patch
- 0004-fix-mvsdio-eMMC-timing.patch
- 0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
- 0006-set-default-cubietruck-led-triggers.patch
- 0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
- 0008-ARM-dove-enable-ethernet-on-D3Plug.patch
- 0009-USB-Armory-MkII-support.patch
)
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('0d0915133864eb031adfc6700066147dcf3e768a50a31c39754950c95ef4fd322dc701cd50af49c403ef0325adfcb07e354d5e46c1be3dcdd719a7a55c963f37'
+sha512sums=('ccc52db049a66ff146d9fc84fb00e783f2d04211156233a382f87589fec7631b8fbb3e76bfd94279607b883d25f9745e6c7d2bd62b13311dc6b425002bd42ec0'
'SKIP'
- '48121612535f6352d540557ee1f5e3d808db4d1118cfd35886670242cb87fa5c51ae8546e1847698f731732e9531dbf1a15de8bcbaae6288489d706eeee1b17c'
+ 'ed4bf87f5b9f4bcc3cdaa3aa7e4fb1e39d5182157d96c49aaff4d54f9454922330b1a47c74f40af62869ee81ff5e3cb78abcfe883af5463084180c556961f068'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -75,26 +69,16 @@ sha512sums=('0d0915133864eb031adfc6700066147dcf3e768a50a31c39754950c95ef4fd322dc
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- 'fc11b0ca6a25eb8458699de19ccf69c2f59152afa62cb861cd2ae43a5b43eb58ff881f93ee66887c1ce25b38e8bbec013fac6648b6283a8c802f1984c34c97a0'
- 'ad502397780138036df3dd1649e9ec4d2fa485f7ba9dd1bc8bbdef58fb5ab14a6170663bfab0003c49965d5611bdeedadd8c669aa7b48c32cc1dbaab15c6e206'
- '4d7e613ada85e48c9b57f9ea17b8445bd96fd6d16662186dba5073b40afc2b43de0bef5977afdaa82f789bfb7df3f99db1b2babd7588099df213fe60f00fed70'
+ '925ea83572cb743b9b105d58fd9ea79b89efa0baf4fbe5b29b2224b55ac739cdf5d32dd93ff6d8e20c4f3930b68f2c93915fdea40981ade5f9721928efcc0428'
+ '878559fa9e83a3095185633cd279437dc0dc8ad120614e008ecc0e361e87966af836ee569c82930da4a4daf9f5ad5314d0cc2b8636e5627ce9339a3f6b7213fd'
+ '6012fa7b97c15ada82f0c205ea983bebac8b672ca498e22f524d219bdd8715784b24ce7d457803e8221a945c3daff95c4e467f70a420b9c2aa95d627f2d160a9'
'53103bf55b957b657039510527df0df01279dec59cda115a4d6454e4135025d4546167fa30bdc99107f232561c1e096d8328609ab5a876cf7017176f92ad3e0b'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- '423d2a2327a47505a0f55b312fff8b00e439b3fcfbbe89dcc6e4f32f0e8239a779dd53978e1b4dbded8fd43bee10415516bb46e69bd52aad8d191f85713f19d3'
- '315aaf31af7b869ba64e324ab33ffa5050b761ecbd7aa6b9a900b8b2ca655d80f840fca9973d4f12ec067519ba4ab2ebdd41d518a9fda4586377ee9c9e9a2fda'
- '8081673a6594e5fc2fddc98fa434e99817aa822f7136d3c14c8d465fa7b93c9ac5d3a4150a5b632e25b1dc76a814dfa19d8aede37d58b935db288465b6585c58')
-sha512sums_armv7h=('e52a25225f3dab659bae8b3b01ed93cf92e7915c8d4c4882ea61e658221b972cbca04b5608a99c9d1d0cdc9048378dfe9b23166e20ab1566d1c2b44862b1173e'
- 'SKIP'
- 'b576a9c40ba59485c350f71b9234d9e71f245e25b26382bd2f67019f3309c3b5705a6020eae0a9dfccacc763fb2056a5937c0a8ff4e64f99ba1d60f0b2acb03f'
- '85a13a274d4cbaca3ddbe8eaf883f1a1184765f8d09d6d40bb32defbe0876cb0153513e8db8671d7fc053e383ced793b74245ff29364a760e1a52bb36ebc8e85'
- 'f9ce0bb4f06be6f742d8a31384e90fdab1a4686f14d5a8845e0c341dcfa62ae59db933237174223de9b32f9d91f99125c20ede7dff664755f1d42ea0cecdefdb'
- 'b32623904f984118ebdd8ec31816885d73776ed80a68fa23925e67451f28a8f080dd8545307bb2f857435894adfa8b3db7c8a99aa02b8b3f2b5f8e3223d98a47'
- 'd114f1e69504413e81dd67684f5b1ce69aa09d5bc768c7eee96a7d6b7ec47b32cd8f02593c878b0e9091475467de36a3d7c478e34a39148fa849548f53637b84'
- 'bc0c6b1726679498393be8d4c417c62e1f356fe5c617c71ff23532652fdd5f314e5bfc6172eaca79cd4806b81031bf2f879d7d1a6050ad4c616c04e6bdf93c2a'
- 'b13bea6412580325dba0d02cf0dc712e860f659569ffcb968aa4836fdb2882448cfee4659a675a70affccae02c8d2589d80b7239eef5ae7b615162aeaa76f3bb'
- 'cff59f974651614587313674455a968ae5390a5ca825d204f0e2f8de2b422d577b007f5297a398e2afeb33ed0d324d34ad58ff4cd56e645bd4ca9a6bdc1354c5'
- '54adbec4b6b85cda901df7d2b3eb1f517f10d3528326e60c7afa4b49ccc7cfb43b0d1f574ceb5d7d03c94a0fbcc97c0ef785258292dd26ed46728355da27332c')
+ 'fccfdee24ffa1c3ed52595c2b1eb35e2e5a8fa717c0230494df71ad96d6e91b7c4ff84157be532e8af3bd913cb123f3ae61a4295d254944ec15968557f9a6221')
+sha512sums_i686=('3a346ff5e0fdefafd28bc3dd0e4b6cd68e3f0014e59d1611d99f2edb8d074fd32649eeb0894a7e340e4f907b5cfc0e08e0753e0427a68dc113bb22835a892968')
+sha512sums_armv7h=('1bbc67e63485b29bd0762bbd08e7df75c47ef84d6a1d1e56b6636bb4a6840b26c725a44911caf3e1b9fb14f27fc11b3ce9ed65d47310ac789231f0e75c937a67'
+ 'SKIP')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -137,6 +121,17 @@ prepare() {
done
fi
+ if [ "$CARCH" = "i686" ]; then
+ local src_i686
+ for src_i686 in "${source_i686[@]}"; do
+ src_i686="${src_i686%%::*}"
+ src_i686="${src_i686##*/}"
+ [[ $src_i686 = *.patch ]] || continue
+ echo "Applying patch $src_i686..."
+ patch -Np1 < "../$src_i686"
+ done
+ fi
+
local src
for src in "${source[@]}"; do
src="${src%%::*}"
@@ -165,9 +160,11 @@ _package() {
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-libre-firmware: firmware images needed for some devices')
- provides=("${_replacesarchkernel[@]/%/=$pkgver}" "LINUX-ABI_VERSION=$pkgver")
- conflicts=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
- replaces=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ replaces=(wireguard-lts)
+ provides+=("${_replacesarchkernel[@]/%/=$pkgver}" "LINUX-ABI_VERSION=$pkgver")
+ conflicts+=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
+ replaces+=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
cd $_srcname
local kernver="$(<version)"
@@ -182,7 +179,7 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -231,6 +228,18 @@ _package-headers() {
cp -t "$builddir/arch/$KARCH" -a arch/$KARCH/include
install -Dt "$builddir/arch/$KARCH/kernel" -m644 arch/$KARCH/kernel/asm-offsets.s
+ # from linux-armv7
+ if [ "$CARCH" = "armv7h" ]; then
+ for i in dove exynos omap2; do
+ mkdir -p "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/mach-$i"
+ cp -a arch/$KARCH/mach-$i/include "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/mach-$i/"
+ done
+ for i in omap orion samsung versatile; do
+ mkdir -p "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/plat-$i"
+ cp -a arch/$KARCH/plat-$i/include "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/plat-$i/"
+ done
+ fi
+
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
@@ -256,22 +265,6 @@ _package-headers() {
echo "Removing documentation..."
rm -r "$builddir/Documentation"
- # Parabola changes
- #
- # since we don't want to diverge too much from Arch's PKGBUILD, we'll
- # start marking our changes as such
- if [ "$CARCH" = "armv7h" ]; then
- for i in dove exynos omap2; do
- mkdir -p "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/mach-$i"
- cp -a arch/$KARCH/mach-$i/include "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/mach-$i/"
- done
- for i in omap orion samsung versatile; do
- mkdir -p "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/plat-$i"
- cp -a arch/$KARCH/plat-$i/include "$pkgdir/usr/lib/modules/$kernver/build/arch/$KARCH/plat-$i/"
- done
- fi
- # end of Parabola changes
-
echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
@@ -293,6 +286,9 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
+
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"