summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-08 14:34:10 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-08 14:34:10 -0200
commitbe181c3f30b40a33a22eb166cb7feeabf69fa696 (patch)
treea1a5e8cc8af9ae74ca52bdb06c62948941c40daf /libre/linux-libre-lts/PKGBUILD
parentceb47adec9fe8463d4b5c181d5c46ed14c76f31a (diff)
downloadabslibre-be181c3f30b40a33a22eb166cb7feeabf69fa696.tar.gz
abslibre-be181c3f30b40a33a22eb166cb7feeabf69fa696.tar.bz2
abslibre-be181c3f30b40a33a22eb166cb7feeabf69fa696.zip
linux-libre-lts-3.10.29-1: updating version
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rw-r--r--libre/linux-libre-lts/PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index e2da7fff9..e9a5a667a 100644
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 204934 2014-01-31 16:13:52Z bpiotrowski $
+# $Id: PKGBUILD 205544 2014-02-06 22:42:03Z bpiotrowski $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -10,9 +10,9 @@
pkgbase=linux-libre-lts # Build stock -LIBRE-LTS kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.10
-_sublevel=28
+_sublevel=29
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1.1
+pkgrel=1
_lxopkgver=${_basekernel}.28 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -30,10 +30,9 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
- '0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
- '1eeedf694bd64b34a031ac27549bc7a3'
+ '13df9c49d6fbac852959f517fc0c1036'
'85ce008eaacbb2fc54b81116d35cf946'
'16867e648e4b9f89bec949cb643888c2'
'c072b17032e80debc6a8626299245d46'
@@ -42,7 +41,6 @@ md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
'04b21c79df0a952c22d681dd4f4562df'
'f3def2cefdcbb954c21d8505d23cc83c'
'd50c1ac47394e9aec637002ef3392bd1'
- '336d2c4afd7ee5f2bdf0dcb1a54df4b2'
'cec0d90f5d3fae8752b0020c6b785954')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
@@ -75,9 +73,6 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
- # CVE-2014-0038
- patch -Np1 -i "${srcdir}/0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch"
-
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-lts|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \