summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-09-18 15:46:24 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-09-18 15:46:24 -0300
commitf6a8a034eacc656c22f1b79725bd53479736ea2a (patch)
treea8ea00f20b7037e8b391daf5db7588e3ecd4f8b9 /libre/linux-libre-lts/PKGBUILD
parent5de05feec61b83260b62a3dd0e67b5da3d1f66c8 (diff)
downloadabslibre-f6a8a034eacc656c22f1b79725bd53479736ea2a.tar.gz
abslibre-f6a8a034eacc656c22f1b79725bd53479736ea2a.tar.bz2
abslibre-f6a8a034eacc656c22f1b79725bd53479736ea2a.zip
linux-libre-3.0.43-1: updating version
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rwxr-xr-xlibre/linux-libre-lts/PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index 03c280487..77bc80f7d 100755
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -7,10 +7,10 @@
pkgbase=linux-libre-lts # Build stock -LIBRE-LTS kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.0
-_sublevel=42
+_sublevel=43
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.41 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.43 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -30,9 +30,9 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'ext4-options.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('5f64180fe7df4e574dac5911b78f5067'
- '8f1c9341d99e941b07d1d6f85f1953aa'
- '8cd05778fc1c2d8145b3b9932b4e3164'
- '87a54dc6251cf2adf35f72ddeddb6ea8'
+ 'c4b4e6d908e70fc6f991a1789a3ac620'
+ '2e7d5f58da4d66e87bbe2c9294c50aef'
+ '77608e2de7b30a08ecd8e422bf2b16bb'
'c072b17032e80debc6a8626299245d46'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
@@ -40,7 +40,7 @@ md5sums=('5f64180fe7df4e574dac5911b78f5067'
'9d3c56a4b999c8bfbd4018089a62f662'
'263725f20c0b9eb9c353040792d644e5'
'f36222e7ce20c8e4dc27376f9be60f6c'
- '1f082cc9e5a18e227f7a044ff429914a')
+ '2c4870ef22f87ef885f3be392d1aaa90')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -224,11 +224,11 @@ _package() {
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}${_localversionname:--LIBRE-LTS}"
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}${_localversionname:--LIBRE-LTS}/version"
- # move module tree /lib -> /usr/lib
- mv "$pkgdir/lib" "$pkgdir/usr"
-
# Now we call depmod...
depmod -b "$pkgdir" -F System.map "$_kernver"
+
+ # move module tree /lib -> /usr/lib
+ mv "$pkgdir/lib" "$pkgdir/usr"
}
_package-headers() {