summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-01 05:30:40 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-02-01 05:30:40 -0200
commitbdff7426b28ccae584227d40b11959ec44a00542 (patch)
treed0470902ebe062f941587d118ddba541a6af75f5 /libre/linux-libre-lts/PKGBUILD
parent9ea68f9235142ce90cba64262d8d6968eddbf628 (diff)
downloadabslibre-bdff7426b28ccae584227d40b11959ec44a00542.tar.gz
abslibre-bdff7426b28ccae584227d40b11959ec44a00542.tar.bz2
abslibre-bdff7426b28ccae584227d40b11959ec44a00542.zip
linux-libre-lts-3.10.28-1.1: fix CVE-2014-0038
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rw-r--r--libre/linux-libre-lts/PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index 79265fad1..76a795a7e 100644
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 204715 2014-01-25 20:46:36Z andyrtr $
+# $Id: PKGBUILD 204934 2014-01-31 16:13:52Z bpiotrowski $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -12,7 +12,7 @@ pkgbase=linux-libre-lts # Build stock -LIBRE-LTS kernel
_basekernel=3.10
_sublevel=28
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
+pkgrel=1.1
_lxopkgver=${_basekernel}.28 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -30,7 +30,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
- "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
+ "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
'1eeedf694bd64b34a031ac27549bc7a3'
'85ce008eaacbb2fc54b81116d35cf946'
@@ -41,6 +41,7 @@ md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
'04b21c79df0a952c22d681dd4f4562df'
'f3def2cefdcbb954c21d8505d23cc83c'
'd50c1ac47394e9aec637002ef3392bd1'
+ '336d2c4afd7ee5f2bdf0dcb1a54df4b2'
'cec0d90f5d3fae8752b0020c6b785954')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
@@ -72,7 +73,10 @@ prepare() {
# allow criu without expert option set
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
-
+
+ # CVE-2014-0038
+ patch -Np1 -i "${srcdir}/0001-x86-x32-Correct-invalid-use-of-user-timespec-in-the-.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-lts|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \