summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-13 08:30:20 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-05-13 08:30:20 -0300
commit0dbc7d243ce4a002c3b25e444753e386b0d8da28 (patch)
tree050c035fb51a3d80d43aa14cdc2128edecbb1156 /libre/linux-libre-lts/PKGBUILD
parentfbf11371027cbe3afb893d10bbafe9e9be052163 (diff)
downloadabslibre-0dbc7d243ce4a002c3b25e444753e386b0d8da28.tar.gz
abslibre-0dbc7d243ce4a002c3b25e444753e386b0d8da28.tar.bz2
abslibre-0dbc7d243ce4a002c3b25e444753e386b0d8da28.zip
linux-libre-lts-3.10.39-2: fix CVE-2014-0196
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rw-r--r--libre/linux-libre-lts/PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index dc9477d16..44978f9ba 100644
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 212087 2014-05-06 15:55:48Z bpiotrowski $
+# $Id: PKGBUILD 212332 2014-05-13 08:23:48Z bpiotrowski $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -12,8 +12,8 @@ pkgbase=linux-libre-lts # Build stock -LIBRE-LTS kernel
_basekernel=3.10
_sublevel=39
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
-_lxopkgver=${_basekernel}.38 # nearly always the same as pkgver
+pkgrel=2
+_lxopkgver=${_basekernel}.39 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -30,6 +30,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
+ '0001-n_tty-Fix-n_tty_write-crash-when-echoing-in-raw-mode.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
'0663686c1e5495b999a175aa7809ea92'
@@ -41,7 +42,8 @@ md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
'04b21c79df0a952c22d681dd4f4562df'
'f3def2cefdcbb954c21d8505d23cc83c'
'd50c1ac47394e9aec637002ef3392bd1'
- 'e5ae030129ed128c61fe29b926476a19')
+ 'da00b78faadbe939943b32305e4c68f8'
+ '64e128839d1e32bd0789cf1b3fc3d64b')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -73,6 +75,9 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
+ # CVE-2014-0196
+ patch -Np1 -i "${srcdir}/0001-n_tty-Fix-n_tty_write-crash-when-echoing-in-raw-mode.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-lts|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \