summaryrefslogtreecommitdiff
path: root/libre/linux-libre-hardened/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2019-08-04 14:20:04 -0400
committerDavid P <megver83@parabola.nu>2019-08-04 14:20:04 -0400
commitf653b0023464a5f566ba8c780caa34467e3353ec (patch)
treeee9c8328ea5be71fcd96ccf5e8fb18026ea073bf /libre/linux-libre-hardened/PKGBUILD
parentdb08b019a45f09549c6b90d69fe4b466cfb9bf8f (diff)
downloadabslibre-f653b0023464a5f566ba8c780caa34467e3353ec.tar.gz
abslibre-f653b0023464a5f566ba8c780caa34467e3353ec.tar.bz2
abslibre-f653b0023464a5f566ba8c780caa34467e3353ec.zip
upgpkg: libre/linux-libre-hardened 5.2.5.a_gnu-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre-hardened/PKGBUILD')
-rw-r--r--libre/linux-libre-hardened/PKGBUILD39
1 files changed, 26 insertions, 13 deletions
diff --git a/libre/linux-libre-hardened/PKGBUILD b/libre/linux-libre-hardened/PKGBUILD
index b0bfcd32e..3f59676a8 100644
--- a/libre/linux-libre-hardened/PKGBUILD
+++ b/libre/linux-libre-hardened/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Márcio Silva <coadde@hyperbola.info>
pkgbase=linux-libre-hardened
-_srcbasever=5.1-gnu
-_srcver=5.1.17-gnu
+_srcbasever=5.2-gnu
+_srcver=5.2.5-gnu
_hardenedver=a
_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
@@ -18,15 +18,16 @@ pkgrel=1
arch=(x86_64)
url='https://linux-libre.fsfla.org/'
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf)
+makedepends=(
+ xmlto kmod inetutils bc libelf python-sphinx python-sphinx_rtd_theme
+ graphviz imagemagick
+)
options=('!strip')
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcbasever/linux-libre-$_srcbasever.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$_srcver/patch-$_srcbasever-$_srcver.xz"{,.sign}
"https://github.com/anthraxx/linux-hardened/releases/download/${_srcver%-*}.${_hardenedver}/linux-hardened-${_srcver%-*}.${_hardenedver}.patch"{,.sig}
- "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_clut224.ppm"{,.sig}
- "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_mono.pbm"{,.sig}
- "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_vga16.ppm"{,.sig}
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
config.x86_64 # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
@@ -46,19 +47,19 @@ validpgpkeys=(
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
'E240B57E2C4630BA768E2F26FC1B547C8D8172C8' # Levente Polyak
)
-sha512sums=('42510bffa69746e0f919fecef5a23da4adb2473239ee67730fa1eb2340256fb4618c6acab439c01ae781df768a2e1ac4b76ad80fe0e4a432eaceb7f01f275439'
+sha512sums=('3359b0a10ac04243399a1b0aa84f6c09e3c1914880be19a7e931189da92900ca77e467e7ab5c296a03d2ff0ab3238ec75b13fd41bd2796049b63e71f6896900e'
'SKIP'
- '2cf1ee4110fdfa12da2e4ea136f02bcc72ceab3fc88949555b9566db141f2fcd75115e5011b17cc5803542d147bfb19f5d52b268b205e26f2f5a856267cb5c2c'
+ '9b35cbb7b1b7ef851a0fb9531ade4360487a75723d8bd9ebfd064b54d3b9697741d60b4b38dca15317e1b1f11d403c830d8f85b663bae56615f1b361eedeae35'
'SKIP'
- '10a47bd17073447da1655c28668d585c3c55a5b5fa516d458caecc44fdc882f2d7e0ceaf3071a7642f40983b7d703534ad7796515b01aed35de33961bd4752a0'
+ '57083de51666701ba546d971ede7dd7f9a4cd7a7c1ea3c8e64830d2cd21ec52555d7a3542db88bda4e85264a4a127de4298c2d44d40b3e36f02a8091c941aa38'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
- '267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
- 'SKIP'
'7a3716bfe3b9f546da309c7492f3e08f8f506813afeb1c737a474c83313d5c313cf4582b65215c2cfce3b74d9d1021c96e8badafe8f6e5b01fe28d2b5c61ae78'
'SKIP'
- '680a588ffd7c6283e18e27e061849fd62218338832c70d833f63a665d5e9a97ca8279a3905e870ea842438f0388b474102f3982ff7f28fc92eed02f88c3e52ae'
+ '267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
+ 'SKIP'
+ '21dea7aac85914638d40c13050637a2de8026e9a2c1c1a824afe54aafa9a78951710b48ed0d3dbae7f4ed9965f94698a968c2e9a59a1ac6eb835f2098bd3fe2b'
'7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
'4a8b324aee4cccf3a512ad04ce1a272d14e5b05c8de90feb82075f55ea3845948d817e1b0c6f298f5816834ddd3e5ce0a0e2619866289f3c1ab8fd2f35f04f44'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
@@ -107,7 +108,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules
+ make bzImage modules htmldocs
}
_package() {
@@ -268,6 +269,18 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
+ msg2 "Removing doctrees..."
+ rm -r "$builddir/Documentation/output/.doctrees"
+
+ msg2 "Moving HTML docs..."
+ local src dst
+ while read -rd '' src; do
+ dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
+ mkdir -p "${dst%/*}"
+ mv "$src" "$dst"
+ rmdir -p --ignore-fail-on-non-empty "${src%/*}"
+ done < <(find "$builddir/Documentation/output" -type f -print0)
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"