summaryrefslogtreecommitdiff
path: root/libre/linux-libre-hardened/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2020-01-06 22:42:47 -0300
committerDavid P <megver83@parabola.nu>2020-01-06 22:42:47 -0300
commit8971402589d668a3a5fc2b6e9b9f3e9775b6dd35 (patch)
tree14c6c94af13be6ff9272962a595e1d6db3747b4a /libre/linux-libre-hardened/PKGBUILD
parent656abdad351bf389106fd83f04469ac50c8fc659 (diff)
downloadabslibre-8971402589d668a3a5fc2b6e9b9f3e9775b6dd35.tar.gz
abslibre-8971402589d668a3a5fc2b6e9b9f3e9775b6dd35.tar.bz2
abslibre-8971402589d668a3a5fc2b6e9b9f3e9775b6dd35.zip
updpkg: libre/linux-libre-hardened 5.4.7.a-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre-hardened/PKGBUILD')
-rw-r--r--libre/linux-libre-hardened/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/libre/linux-libre-hardened/PKGBUILD b/libre/linux-libre-hardened/PKGBUILD
index d06b0dfa6..0d3eab58d 100644
--- a/libre/linux-libre-hardened/PKGBUILD
+++ b/libre/linux-libre-hardened/PKGBUILD
@@ -9,7 +9,7 @@ _replacesoldkernels=('linux-grsec' 'linux-libre-grsec') # '%' gets replaced with
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre-hardened
-pkgver=5.3.15.a
+pkgver=5.4.7.a
pkgrel=1
pkgdesc='Security-Hardened Linux-libre'
url='https://linux-libre.fsfla.org/'
@@ -20,7 +20,7 @@ makedepends=(
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
)
options=('!strip')
-_srcname=linux-5.3
+_srcname=linux-5.4
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver%.*}-gnu/patch-${_srcname##*-}-gnu-${pkgver%.*}-gnu.xz"{,.sign}
@@ -42,11 +42,11 @@ validpgpkeys=(
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
'E240B57E2C4630BA768E2F26FC1B547C8D8172C8' # Levente Polyak
)
-sha512sums=('85d83c973ef96ab414354414da70ab3e1c3df19c3088458498cec1594952878b7967a8988bd9e36d4e728cc573a36e6eac056dbcab2f9aa742f18cbb4fb3164f'
+sha512sums=('0d0915133864eb031adfc6700066147dcf3e768a50a31c39754950c95ef4fd322dc701cd50af49c403ef0325adfcb07e354d5e46c1be3dcdd719a7a55c963f37'
'SKIP'
- '53ad8cc46fcc54d4504a8711e8bce06d862e285499435a31afe9097cf907948688aa409e0918dac443988d72b6a8dae2fd4d87d1b6ce87a0a3f6f64e589fcd36'
+ '1e1f7ad15de74134d900ec7a54180c6bf9f349b02aa6f62927ffa81720413b3d37fc932b3b8b17b6d684d12ddbd80e53c6176b963f90a9d98a9f94a2d4f6867b'
'SKIP'
- '78604abfd436c2b46ca23048bbfbcbf4e788bcf0001c88a92a0967c48c612c7a367996ace05b5e9741dba091a8b22a663ce5092296ed6687019150b93e2cd8be'
+ 'a5d1722a7a7d83c741ae068b339fb8dd085dc5a76da51e22376702e1fb3880f33a0237eccdd353d2e43c33cd842553a3dba52340d2cb7d9bf1615931525641e0'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -54,7 +54,7 @@ sha512sums=('85d83c973ef96ab414354414da70ab3e1c3df19c3088458498cec1594952878b796
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- '9330c175265136b9a0fcf36350d8235cec88899534cb7ea31ce9175b177e3cca5c4e315ff24ad5871baff7cb9093b13e5f149556a10f145cc6a369d1e764c049'
+ 'b0b722275efc84fa09f5ea4f4d648112596b3bcd7f401151708459e1a7cb6bbaf78f2afd8750339fe0fe081aca12ae1fb8fd9570318b559fcd675ad60788da68'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168')
@@ -139,7 +139,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for $pkgdesc kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
provides=("${_replacesarchkernel[@]/%/-headers=${pkgver%.*}}")
conflicts=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
replaces=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")