summaryrefslogtreecommitdiff
path: root/libre/linux-libre-grsec/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-06-09 02:18:42 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-06-09 02:36:11 -0300
commitc0e56d7943f11461bbd36ceec141f1805b52c22f (patch)
treead98d112b1feb209076939a51ecb0fcb7cb7dfed /libre/linux-libre-grsec/PKGBUILD
parent3dd5b8298e985ae1dca25adf59a4b072fd2bdc36 (diff)
downloadabslibre-c0e56d7943f11461bbd36ceec141f1805b52c22f.tar.gz
abslibre-c0e56d7943f11461bbd36ceec141f1805b52c22f.tar.bz2
abslibre-c0e56d7943f11461bbd36ceec141f1805b52c22f.zip
linux-libre kernels: move freedo logos and loongson-community patches to repo
Diffstat (limited to 'libre/linux-libre-grsec/PKGBUILD')
-rw-r--r--libre/linux-libre-grsec/PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/libre/linux-libre-grsec/PKGBUILD b/libre/linux-libre-grsec/PKGBUILD
index a934f8327..bf5bd1050 100644
--- a/libre/linux-libre-grsec/PKGBUILD
+++ b/libre/linux-libre-grsec/PKGBUILD
@@ -35,33 +35,44 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
"http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}/patch-${_pkgbasever}-${_pkgver}.xz.sign"
"https://repo.parabola.nu/other/grsecurity-libre/test/grsecurity-libre-${_grsecver}-${_pkgver%-*}-${_timestamp}.patch"
"https://repo.parabola.nu/other/grsecurity-libre/test/grsecurity-libre-${_grsecver}-${_pkgver%-*}-${_timestamp}.patch.sig"
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_clut224.ppm"
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_clut224.ppm.sig"
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_mono.pbm"
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_mono.pbm.sig"
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_vga16.ppm"
+ "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_vga16.ppm.sig"
# the main kernel config files
'config.i686' 'config.x86_64' 'config.mips64el'
# standard config files for mkinitcpio ramdisk
'linux.preset'
- 'logo_linux_'{clut224.ppm,vga16.ppm,mono.pbm}
'change-default-console-loglevel.patch'
# loongson-community patch: http://linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/
# Note: Makefile patching was removed due which we are using specific flags from grsecurity patch
- '4.0.2-ae91f13af5-loongson-community.patch')
+ "https://repo.parabola.nu/other/linux-libre/patches/4.0.2-ae91f13af5-loongson-community_grsecurity.patch"
+ "https://repo.parabola.nu/other/linux-libre/patches/4.0.2-ae91f13af5-loongson-community_grsecurity.patch.sig")
sha256sums=('0e2dd5be12c1f82ab3d03b89cbe3f1a20e14332ec42c102efb226a6283fdd38a'
'SKIP'
'e447de9a53c5aefd25f0474f3304ab87076b88353badaae20dcbd85712e85e61'
'SKIP'
'fde84ebae38758cd99d86177791d830f4e8bfae8b16eed46a357d5581783c213'
'SKIP'
+ 'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
+ 'SKIP'
+ '13bd7a8d9ed6b6bc971e4cd162262c5a20448a83796af39ce394d827b0e5de74'
+ 'SKIP'
+ '6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
+ 'SKIP'
'd4e66b81d29d5048f072b3eda89b12e1564c2b3c9d0e27f9efbd7290b52cc9ee'
'5c12d80d81dbde43c138acf69a036640a28c8b49c02c8547033a60a0fecc9f08'
'3383ed8dfa70ec91275e52c12965c2e265fffe494c2ee1904c20e3d2773a5993'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
- 'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
- '6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
- '13bd7a8d9ed6b6bc971e4cd162262c5a20448a83796af39ce394d827b0e5de74'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '13e141279af2bc17decfc041e015710daac9a6cd1c9b4e871a76cb8f916b9e22')
+ 'ac7232b38f5a25a79a23c25c8cd5ed4579ca5402466d3370dd093626998092b3'
+ 'SKIP')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'C92BAA713B8D53D3CAE63FC9E6974752F9704456' # André Silva
+ '684D54A189305A9CC95446D36B888913DDB59515' # Márcio Silva
)
_kernelname=${pkgbase#linux-libre}
@@ -129,8 +140,6 @@ prepare() {
build() {
cd "${srcdir}/${_srcname}"
- #export CC="gcc -std=gnu89"
- export CFLAGS="$CFLAGS -std=gnu89"
make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}