summaryrefslogtreecommitdiff
path: root/libre/linux-libre-firmware/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-05-05 17:14:39 -0300
committerDavid P <megver83@parabola.nu>2018-05-05 17:14:39 -0300
commitea1f2d25bfb09eb46ec0fe75b50c5a67c2eab150 (patch)
tree0d8df2fb6ec60aa55809be5b3a1f22671a57bf11 /libre/linux-libre-firmware/PKGBUILD
parent88a62e57ce83be878e9766d14944cc89d8e7317f (diff)
downloadabslibre-ea1f2d25bfb09eb46ec0fe75b50c5a67c2eab150.tar.gz
abslibre-ea1f2d25bfb09eb46ec0fe75b50c5a67c2eab150.tar.bz2
abslibre-ea1f2d25bfb09eb46ec0fe75b50c5a67c2eab150.zip
libre/linux-libre-firmware: rebuild with GCC8
Other changes: - update makedepends - add 0001-remove-external-toolchains.patch to replace remove-wget.patch - add 0002-carl9170fw-gcc-8-fix.patch Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre-firmware/PKGBUILD')
-rw-r--r--libre/linux-libre-firmware/PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/libre/linux-libre-firmware/PKGBUILD b/libre/linux-libre-firmware/PKGBUILD
index 3597f2c41..e0ec3fb91 100644
--- a/libre/linux-libre-firmware/PKGBUILD
+++ b/libre/linux-libre-firmware/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=linux-libre-firmware
pkgver=1.2
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Firmware files for Linux-libre'
arch=('any')
url='https://jxself.org/firmware'
license=('GPL3' 'GPL2')
-makedepends=('cmake' 'gmp' 'gperf' 'arm-linux-gnueabi-gcc' 'sh-elf-gcc' 'sh-elf-newlib' 'xtensa-unknown-elf-gcc')
+makedepends=('cmake' 'arm-linux-gnueabi-gcc' 'sh-elf-gcc' 'sh-elf-newlib' 'xtensa-elf-gcc')
provides=('linux-firmware')
conflicts=('linux-firmware'
'linux-firmware-git'
@@ -31,23 +31,22 @@ conflicts=('linux-firmware'
'ath9k-htc-firmware')
replaces=(${conflicts[@]})
options=(!strip)
-source=("${url}/${pkgname}-${pkgver}.tar.lz"{,.asc}
- 'remove-wget.patch' # remove the download of external toolchains
-)
+source=("${url}/${pkgname}-${pkgver}.tar.lz"{,.asc} '0001-remove-external-toolchains.patch' '0002-carl9170fw-gcc-8-fix.patch')
sha512sums=('2f70207ae7a98a71b74950a909e899c58617e46693a4b069cd16de1b2f0bb31c6abb07c0f4db88b5cecc3f3c50da56265da0b771c58b164981d628231f130387'
'SKIP'
- 'b5327fb56c1881f2eb834181a5a22df3ec08f90cccef3a71f7b194b845cb2610f7c1a7d8d7b9d8194959938a1c4bec613da6e8311cef57c7379be8964c9997d9')
+ 'cc3417dcf165442260b509facc391fcce9125befea26c22b0748715484ab2373c56e5fa6e306ff74c1f39baccf8f5a0aee067d444d5980796e9d2c6fa6179fe5'
+ 'f1326f1af1586b39ca738ff9c263c5ac1388996914cbab9898adac3430dba2b28fecc5495ab624b098c853cc9795b646d0ca631b696413db14d7f4a47b4a2374')
validpgpkeys=('F611A908FFA165C699584ED49D0DB31B545A3198') # Jason Self
prepare() {
cd $srcdir/$pkgname-$pkgver
- # Some firmwares download toolchains with wget. We don't want that
- patch -p1 -i ../remove-wget.patch
+ # do not download toolchains so we can build offline
+ patch -p1 -i ../0001-remove-external-toolchains.patch
+
+ # fix building with GCC 8+
+ patch -p1 -i ../0002-carl9170fw-gcc-8-fix.patch
- # CARL9170 configuration
- sed -e '13s|config/conf|config/conf --alldefconfig|' \
- -i src/carl9170fw/autogen.sh
}
build() {