summaryrefslogtreecommitdiff
path: root/libre/liferea-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-07 15:06:26 -0200
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-07 15:06:26 -0200
commit5f3eabd848657c26140fd65f06849c677061e47a (patch)
tree5fd384c8d60d47b6649c08aa1f56c951c139b2a5 /libre/liferea-libre/PKGBUILD
parent1722278e64c39b82b4945b1acaa8f8b99b53a390 (diff)
downloadabslibre-5f3eabd848657c26140fd65f06849c677061e47a.tar.gz
abslibre-5f3eabd848657c26140fd65f06849c677061e47a.tar.bz2
abslibre-5f3eabd848657c26140fd65f06849c677061e47a.zip
libre/liferea-libre
Diffstat (limited to 'libre/liferea-libre/PKGBUILD')
-rw-r--r--libre/liferea-libre/PKGBUILD36
1 files changed, 10 insertions, 26 deletions
diff --git a/libre/liferea-libre/PKGBUILD b/libre/liferea-libre/PKGBUILD
index 8ee55b4ba..74eb223e1 100644
--- a/libre/liferea-libre/PKGBUILD
+++ b/libre/liferea-libre/PKGBUILD
@@ -1,10 +1,11 @@
-# $Id$
+# $Id: PKGBUILD 144935 2011-12-11 03:21:39Z eric $
# Maintainer: Eric Bélanger <eric@archlinux.org>
-# Contributor: bitlord
+# Contributor (Parabola): bitlord
+# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
pkgbasename=liferea
pkgname=liferea-libre
-pkgver=1.6.6b
+pkgver=1.8.0
pkgrel=1
pkgdesc="A desktop news aggregator for online news feeds and weblogs"
arch=('i686' 'x86_64')
@@ -13,35 +14,18 @@ provides=("liferea=$pkgver")
replaces=('liferea')
conflicts=('liferea')
license=('GPL')
-depends=('gconf' 'libwebkit' 'libxslt' 'libglade' 'sqlite3' 'hicolor-icon-theme')
-makedepends=('pkg-config' 'intltool' 'lua' 'libnotify')
-optdepends=('lua: for lua scripting support'
- 'libnotify: for notification support')
+depends=('gconf' 'libwebkit' 'libnotify' 'libunique' 'json-glib' 'hicolor-icon-theme')
+makedepends=('intltool')
options=('!libtool' '!emptydirs')
install=liferea.install
-source=(http://repo.parabolagnulinux.org/other/$pkgname-$pkgver.tar.gz
- libnotify-0.7.patch
+source=(http://downloads.sourceforge.net/sourceforge/liferea/liferea-${pkgver}.tar.gz
remove-non-free-suggestions.patch)
-md5sums=('3e6a113a30f8d813c3a7ece4691d5afe'
- 'fca97e3316c1c51e0179c4c7dcce47a2'
- 'e138b67a6bc62d4ba0eb64b781105bf0')
-
-# source PKGBUILD ; mksource
-mksource() {
- wget http://downloads.sourceforge.net/sourceforge/liferea/liferea-${pkgver}.tar.gz \
- -O - | tar xzf -
-
- pushd liferea-$pkgver >/dev/null
- patch -Np1 -i "../remove-non-free-suggestions.patch" || return 1
- popd >/dev/null
-
- tar cvzf $pkgname-$pkgver.tar.gz liferea-$pkgver/
- rm -rvf liferea-$pkgver/
-}
+md5sums=('6313e3049b586be110c9402900609fe0'
+ 'e2fdcbc485ce6ff7956c8527be152ca6')
build() {
cd "${srcdir}/liferea-${pkgver}"
- patch -Np1 -i "$srcdir/libnotify-0.7.patch"
+ patch -Np1 -i "$srcdir/remove-non-free-suggestions.patch"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-schemas-install
make
}