summaryrefslogtreecommitdiff
path: root/libre/libretools/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 20:55:26 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 20:55:26 -0600
commit84531aa9eb51c6fff1bc47aee6a25609bbf69126 (patch)
treea77939f0c04c3f002862dc0bec468b764594ce9e /libre/libretools/PKGBUILD
parentc4062b116fa9b14497aa00fa15e3579c44565e61 (diff)
downloadabslibre-84531aa9eb51c6fff1bc47aee6a25609bbf69126.tar.gz
abslibre-84531aa9eb51c6fff1bc47aee6a25609bbf69126.tar.bz2
abslibre-84531aa9eb51c6fff1bc47aee6a25609bbf69126.zip
move libretools and depends from [libre-testing] to [libre]
Diffstat (limited to 'libre/libretools/PKGBUILD')
-rw-r--r--libre/libretools/PKGBUILD60
1 files changed, 43 insertions, 17 deletions
diff --git a/libre/libretools/PKGBUILD b/libre/libretools/PKGBUILD
index 9f67689df..07878d1c0 100644
--- a/libre/libretools/PKGBUILD
+++ b/libre/libretools/PKGBUILD
@@ -4,38 +4,64 @@
pkgbase=libretools
pkgname=(libretools libretools-mips64el)
-pkgver=20130117
pkgdesc="Programs for Parabola development"
-url="https://projects.parabolagnulinux.org/libretools.git/"
-license=('GPL3+' 'GPL2')
+url="https://projects.parabolagnulinux.org/packages/libretools.git/"
+license=('GPL3' 'GPL2')
-pkgrel=3
+pkgver=20130605
+_libretools_commit=adc6865b29b31a32cce195d6912af039ef7eab77
+_devtools_commit=bf8513ae631484a0c292ad085ea7ede9859f8e0f
+
+_packages_url=https://projects.parabolagnulinux.org/packages
+source=($_packages_url/libretools.git/snapshot/libretools-$_libretools_commit.tar.bz2
+ $_packages_url/devtools-par.git/snapshot/devtools-par-$_devtools_commit.tar.bz2)
+
+pkgrel=1
arch=('any')
-groups=(base-devel)
-depends=(openssh rsync git wget tokyocabinet)
-conflicts=(chroottools)
-source=(https://projects.parabolagnulinux.org/$pkgbase.git/snapshot/$pkgbase-$pkgver.tar)
+makedepends=(emacs) # emacs --batch is used during the build to process text
+checkdepends=(sh-roundup)
build() {
- cd "$srcdir/$pkgbase-$pkgver"
- make
+ cd "$srcdir"
+ ln -sf devtools-par-$_devtools_commit devtools-par
+ cd "$srcdir/$pkgbase-$_libretools_commit"
+ make build-libretools build-libretools-mips64el build-doc
+}
+
+check() {
+ cd "$srcdir/$pkgbase-$_libretools_commit"
+
+ make check TESTENVFLAGS='--no-network --no-sudo'
}
package_libretools() {
- backup=(etc/libretools.conf etc/libretools.d/chroot.conf)
+ backup=(etc/libretools.conf etc/libretools.d/chroot.conf etc/libretools.d/librefetch.conf)
install=libretools.install
+ replaces=(chroottools)
+ conflicts=(devtools)
+
+ depends=(
+ arch-install-scripts # `archroot` uses `pacstrap`
+ git # `createworkdir` (also mips-add in -mips64el)
+ openssh # `librerelease`
+ rsync # `librerelease` and `makechrootpkg.sh`
+ subversion # `diff-unfree`
+ tokyocabinet # `treepkg`
+ wget # `aur` and `lib/blacklist.sh`
+ )
+ optdepends=('namcap: to check package files')
- cd "$srcdir/$pkgbase-$pkgver"
- make install-libretools DESTDIR="$pkgdir"
- install -Dm755 rePKGBUILD.proto ${pkgdir}/usr/share/pacman/rePKGBUILD.proto
+ cd "$srcdir/$pkgbase-$_libretools_commit"
+ make install-libretools install-doc DESTDIR="$pkgdir"
}
package_libretools-mips64el() {
pkgdesc="Scripts for Parabola development (for mips64el architecture)"
- backup=('etc/libretools.d/mips64el.conf')
+ depends=("$pkgbase=$pkgver")
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir/$pkgbase-$_libretools_commit"
make install-libretools-mips64el DESTDIR="$pkgdir"
}
-md5sums=('77dcfb2fbf5b8a9894a13c5e6151b693')
+md5sums=('60a3bb7d86f1591658b74ed482bc0423'
+ 'b28b1492fda205be7c577fc03cbc3399')