summaryrefslogtreecommitdiff
path: root/libre/libquicktime/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-02 06:41:22 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-02 06:41:22 -0300
commitfcce4e670cd2d81990b3f50e8a682b44d40a73cc (patch)
tree2634d6d68316f3f4dd51f378e826da884a919288 /libre/libquicktime/PKGBUILD
parentc5822ca785d156da9849d5e25dc79a93d1fac22d (diff)
downloadabslibre-fcce4e670cd2d81990b3f50e8a682b44d40a73cc.tar.gz
abslibre-fcce4e670cd2d81990b3f50e8a682b44d40a73cc.tar.bz2
abslibre-fcce4e670cd2d81990b3f50e8a682b44d40a73cc.zip
remove parabola suffix and add complex pkgrel on the packages
Diffstat (limited to 'libre/libquicktime/PKGBUILD')
-rw-r--r--libre/libquicktime/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/libre/libquicktime/PKGBUILD b/libre/libquicktime/PKGBUILD
new file mode 100644
index 000000000..1cdd7cdc8
--- /dev/null
+++ b/libre/libquicktime/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 116382 2014-07-26 16:36:46Z bpiotrowski $
+# Maintainer (Arch): Federico Cinelli <cinelli@aur.archlinux.org>
+# Maintainer (Arch): Mateusz Herych <heniekk@gmail.com>
+# Contributor: Jorge Lopez <jorginho@lavabit.com>
+
+pkgname=libquicktime
+pkgver=1.2.4
+pkgrel=10.parabola1
+pkgdesc="A library for reading and writing quicktime files, without nonfree faac support"
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL')
+url="http://libquicktime.sourceforge.net/"
+depends=('gtk2' 'ffmpeg' 'libxv' 'libxaw' 'faad2')
+makedepends=('mesa-libgl' 'x264')
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+ ffmpeg2.0.patch)
+sha256sums=('1c53359c33b31347b4d7b00d3611463fe5e942cae3ec0fefe0d2fd413fd47368'
+ 'a1c8415e8e7bc04c81b946b9e3746f7d5ef24819135962280c3a7ddb3f2baa2b')
+replaces=("${pkgname}-libre" "${pkgname}-parabola")
+conflicts=("${pkgname}-libre" "${pkgname}-parabola")
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../ffmpeg2.0.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-gpl \
+ --with-ffmpeg \
+ --with-x264 \
+ --without-doxygen
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}