summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-03-13 00:17:27 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2022-03-26 05:57:45 -0400
commitfdad940b19b35572064e0f9925946bb4f9d0729a (patch)
tree5298977b05b8cf736eae2d6ee814e144d6f68b49 /libre/iceweasel/PKGBUILD
parent9d0cd632a5e27a5e04194ada36e2a2d458a702c8 (diff)
downloadabslibre-fdad940b19b35572064e0f9925946bb4f9d0729a.tar.gz
abslibre-fdad940b19b35572064e0f9925946bb4f9d0729a.tar.bz2
abslibre-fdad940b19b35572064e0f9925946bb4f9d0729a.zip
[iceweasel]: rename user profile dir
this corresponds to (requires) the change in iceweasel-branding.git with commit message: 'rename user profile dir'
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index e123f66a8..57a711174 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -37,6 +37,7 @@
# - allow skipping profiling build for x86_64 (_x86_64_skip_pgo)
# - prefer as many system libs as possible, over their vendored couterparts
# - Rebrand to Iceweasel, per the mozilla trademark policy, due to the FSDG changes
+# - set user profile directory to ~/.mozilla/iceweasel
#
# privacy:
# - Remove Google API keys and usage
@@ -596,4 +597,21 @@ END
if [[ -e $nssckbi ]]; then
ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
fi
+
+
+ # BEGIN RENAME_PROFILE
+ # replace binary with a temporary wrapper, to rename the user profile directory
+ # NOTE: prior to v98, if another 'firefox' is installed in addition to iceweasel,
+ # both applications would share a profile, which is not very sane behavior.
+ # TODO: this 'rename-profile' source file, and the following two LOC,
+ # could be removed after a reasonable deprecation period (eg: in 2023)
+ mv "${pkgdir}"/usr/lib/iceweasel/ice{,-}weasel
+ install -Dm755 ../rename-profile.sh "${pkgdir}"/usr/lib/iceweasel/iceweasel
+ # END RENAME_PROFILE
}
+
+
+# BEGIN RENAME_PROFILE - temporary - see note in package()
+depends+=(gxmessage) ; source+=(rename-profile.sh) ;
+sha256sums+=('e8f8a53ff340e36912c39247d40b6c2915bbbe437d2fc21b3e7cc09b1b534389')
+# END RENAME_PROFILE