summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorgrizzlyuser <grizzlyuser@protonmail.com>2020-07-02 20:57:23 +0300
committerAndreas Grapentin <andreas@grapentin.org>2020-07-10 11:28:48 +0200
commiteaed1ac70bff2a6a818e100cf153a5a4235bf8fd (patch)
tree7d5eccf3993a29ad2d17297849c0234d32f6fe76 /libre/iceweasel/PKGBUILD
parent76c2518597b9475498150f2d6ad19d358e61f6d5 (diff)
downloadabslibre-eaed1ac70bff2a6a818e100cf153a5a4235bf8fd.tar.gz
abslibre-eaed1ac70bff2a6a818e100cf153a5a4235bf8fd.tar.bz2
abslibre-eaed1ac70bff2a6a818e100cf153a5a4235bf8fd.zip
libre/iceweasel: update search engines patching
Apart from upstream updates to list.json, there is also a bit of preparation for the next significant change of how search engines are handled upstream. 78.0 enabled this new mechanism, but 78.0.1 disabled it again because of [1]. For details see [2]. It looks like Mozilla can now update the list of available and visible search engines remotely. So removing all engines except Wikipedia and DuckDuckGo just to avoid surprises in future. [1] https://bugzilla.mozilla.org/show_bug.cgi?id=1649393 [2] https://bugzilla.mozilla.org/show_bug.cgi?id=1542235 Signed-off-by: Andreas Grapentin <andreas@grapentin.org>
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index a8d215351..73b742ba9 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -267,15 +267,23 @@ END
# browser/components/search/extensions/<ID>/
# local _remove_engines_sed='s|.*oogle.*| "ddg", "duckduckgo-html", "duckduckgo-lite", "internet-archive", "parabola-labs", "parabola-packages", "parabola-wiki-en", "searx", "wikipedia", "yacy"|g'
local _remove_engines_sed='s|.*oogle.*| "ddg", "wikipedia"|g'
- local _search_config_file=browser/components/search/extensions/list.json
echo "applying libre-searchengines.patch"
patch -Np1 -i "$srcdir/libre-searchengines.patch"
- sed -i "${_remove_engines_sed}" ${_search_config_file}
+
+ pushd browser/components/search/extensions
+ sed -i "${_remove_engines_sed}" list.json
# Sanity-check search-engines patching
_removed_engines_regex='Bing|Google|Seznam|Twitter|Yahoo|Yandex|Яндекс|amazon|bing|google|ebay|twitter'
_err_msg="search-engines patch needs re-working"
- ! grep -E ${_removed_engines_regex} ${_search_config_file} > /dev/null || ! echo "${_err_msg}"
+ ! grep -E ${_removed_engines_regex} list.json > /dev/null || ! echo "${_err_msg}"
+
+ find -mindepth 1 -maxdepth 1 \
+ -not -name ddg \
+ -not -name wikipedia \
+ -not -name list.json \
+ -exec rm -rf {} \;
+ popd
# Removing What's New tab from Developer Tools, usages are removed by libre.patch
rm -rf devtools/client/whats-new