summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-08-01 22:09:20 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-08-01 22:10:11 -0400
commit496f0df7df6708309ad59b8d7eba32d9a5997a73 (patch)
tree362de1fd61051f629ba8122375c6e09786263c8e /libre/iceweasel/PKGBUILD
parent6f2d971e550b9898df0003adffc8cc858ffc2700 (diff)
downloadabslibre-496f0df7df6708309ad59b8d7eba32d9a5997a73.tar.gz
abslibre-496f0df7df6708309ad59b8d7eba32d9a5997a73.tar.bz2
abslibre-496f0df7df6708309ad59b8d7eba32d9a5997a73.zip
[iceweasel]: better comments for FIXME issues
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index f21eb290f..0f9c00c54 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -56,7 +56,7 @@ depends+=(sqlite icu)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
python nodejs python2-psutil cbindgen nasm)
-# FIXME: 'mozilla-serarchengines' package needs re-working
+# FIXME: 'mozilla-serarchplugins' package needs re-working
makedepends+=(quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -176,8 +176,9 @@ END
local brandingdestdir=browser/branding/${pkgname}
rm -rf -- ${brandingdestdir}
cp -aT -- ${brandingsrcdir}/branding ${brandingdestdir}
-# TODO: dont know what aboutlogins.svg is supposed to be or what it is for
-cp ${brandingdestdir}/iceweasel_logo.svg ${brandingdestdir}/content/aboutlogins.svg
+ # FIXME: dont know what aboutlogins.svg is supposed to be or what it is for
+ # but it should go into the branding repo
+ cp ${brandingdestdir}/iceweasel_logo.svg ${brandingdestdir}/content/aboutlogins.svg
# FIXME: the newtab page (aka "Start Page") has changed significantly
# some of the branding components (commented out) above may no longer be used
@@ -187,11 +188,15 @@ cp ${brandingdestdir}/iceweasel_logo.svg ${brandingdestdir}/content/aboutlogins.
# and any unused branding components may be deleted from the branding package
# this is essentially re-branding, so perhaps 'newtab.patch' should eventually
# be moved into the branding tarball
- # Put "Start Page" branding images in the source code
+ # Put "Start Page" branding images in the source code # FIXME: delete
#install -m644 -t browser/base/content/abouthome -- \
- # "${brandingsrcdir}/branding"/{drm-free,gnu_headshadow,parabola-banner}.png
+ # "${brandingsrcdir}/branding"/{drm-free,gnu_headshadow,parabola-banner}.png # FIXME: delete
#install -m644 -t browser/extensions/onboarding/content/img -- \
- # "${brandingsrcdir}/branding/watermark.svg"
+ # "${brandingsrcdir}/branding/watermark.svg" # FIXME: delete
+ # FIXME: newtab patch below will not work
+ # the new tab page needs to be a plugin, created externally
+ # see: the branding-dev-build/ dir ont the '68.0' branch of the branding git repo
+ @ that will also be useful for creating a replacement 'mozilla-searchplugins' package
# custom new tab page
local newtabdestdir=browser/components/newtab/data/content/assets/
patch -Np1 -i "${srcdir}/newtab.patch"