summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorgrizzlyuser <grizzlyuser@protonmail.com>2020-12-30 21:48:02 +0200
committerbill-auger <mr.j.spam.me@gmail.com>2021-01-12 00:47:06 -0500
commit29c463c7da91d2c08b1bf8f1a24e7dea4afabb0c (patch)
tree023ec8f8eb16b00cf3374c74188cb097f8b104e8 /libre/iceweasel/PKGBUILD
parent396b6e8f5de478001aefb76fc4b8a6706bc5e9e2 (diff)
downloadabslibre-29c463c7da91d2c08b1bf8f1a24e7dea4afabb0c.tar.gz
abslibre-29c463c7da91d2c08b1bf8f1a24e7dea4afabb0c.tar.bz2
abslibre-29c463c7da91d2c08b1bf8f1a24e7dea4afabb0c.zip
libre/iceweasel: Add JSON processing script
jq was not enough. It lacks functionality necessary to do all these changes in one pass, like verification by JSON schemas, or automatic unique timestamp generation for changed records. Python script can be updated in future to support more Remote Settings dumps, not just main/search-config and monitor/changes.
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 84542ba6f..77fff6406 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -62,8 +62,7 @@ makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
python-setuptools python-psutil python-zstandard lld)
# FIXME: 'mozilla-serarchplugins' package needs re-working (see note in prepare())
-makedepends+=(quilt libxslt imagemagick git jq)
-makedepends+=(rust=1:1.46.0) # FIXME: FTBS with rust v1.47.0
+makedepends+=(quilt libxslt imagemagick git jq python-jsonschema)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -76,8 +75,8 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
$pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
libre.patch
- libre-searchengines.patch
libre-0001-always-sync-remote-settings-with-local-dump.patch
+ libre-process-json-files.py
vendor.js.in)
source_armv7h=(arm.patch
build-arm-libopus.patch)
@@ -338,7 +337,6 @@ END
## libre patching ##
- # Remove remaining non-free bits
# Remove test-related networking dumps, because they contain code from
# some Amazon webpage with no clear licensing, thus nonfree.
# Also they interfere with checking of Remote Settings patching done later,
@@ -374,7 +372,9 @@ END
-e '!third_party/python/**/*.egg-info/'
rm -rf .git
- # Patch and remove anything that's left
+ python ../libre-process-json-files.py "$srcdir/firefox-$pkgver" "${brandingsrcdir}"
+
+ # Remove remaining non-free bits
echo "applying libre.patch"
patch -Np1 --no-backup-if-mismatch -i "${srcdir}"/libre.patch
}