summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorgrizzlyuser <grizzlyuser@protonmail.com>2020-09-27 17:38:54 +0300
committerbill-auger <mr.j.spam.me@gmail.com>2020-10-12 16:59:20 -0400
commit2fce21447fd2b874ef9fb0f00ddb21e397496269 (patch)
treee62d50e21293f078fea419f149fd7e4987405fbf /libre/iceweasel/PKGBUILD
parent673f6aa0ff609f848c4dbe7924e9e11a951bf31f (diff)
downloadabslibre-2fce21447fd2b874ef9fb0f00ddb21e397496269.tar.gz
abslibre-2fce21447fd2b874ef9fb0f00ddb21e397496269.tar.bz2
abslibre-2fce21447fd2b874ef9fb0f00ddb21e397496269.zip
libre/iceweasel: Update to 81.0-2.parabola1
Setting MOZ_APP_NAME is necessary now because paths to binaries will contain 'firefox' not 'iceweasel' due to changes in this release of upstream Firefox.
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 9a253d858..c11a28efc 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -44,8 +44,8 @@
pkgname=iceweasel
epoch=1
-pkgver=80.0.1
-pkgrel=1
+pkgver=81.0
+pkgrel=2
pkgrel+=.parabola1
_brandingver=80.0
_brandingrel=1
@@ -57,7 +57,7 @@ url="https://wiki.parabola.nu/Iceweasel"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
- python-setuptools python-psutil lld)
+ python-setuptools python-psutil python-zstandard lld)
# FIXME: 'mozilla-serarchplugins' package needs re-working (see note in prepare())
makedepends+=(quilt libxslt imagemagick git jq)
optdepends=('networkmanager: Location detection via available WiFi networks'
@@ -69,6 +69,8 @@ replaces=('firefox')
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
+ 0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
+ 0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
$pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
libre.patch
@@ -78,16 +80,18 @@ source_armv7h=(arm.patch
build-arm-libopus.patch)
source_i686=('avoid-libxul-OOM-python-check.patch'
'rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums=('596b085e32a2d683ba960e161ea65c6271f90f576d4bf956e0d48e83af992c21'
+sha256sums=('9328745012178aee5a4f47c833539f7872cc6e0f20a853568a313e60cabd1ec8'
'SKIP'
- '3bb7463471fb43b2163a705a79a13a3003d70fff4bbe44f467807ca056de9a75'
+ 'e0eaec8ddd24bbebf4956563ebc6d7a56f8dada5835975ee4d320dd3d0c9c442'
+ 'c2489a4ad3bfb65c064e07180a1de9a2fbc3b1b72d6bc4cd3985484d1b6b7b29'
+ '52cc26cda4117f79fae1a0ad59e1404b299191a1c53d38027ceb178dab91f3dc'
'44be8e819b8334ed36e9410d62dbc6c16dd8f8329a191403bfdce3cf2e9181fc'
'228b7d316ab6836a6e69aa7070033b1ae073f3579474a49d8c306702b1c1413e'
'SKIP'
'5cfcadbd168c52b1b1e3f2f2c45911a4ae1a9d8a05918be68475a31985607bd8'
'0ed6b8efa00f73a96bceaba2d6a31fb11d416106729ab9b8289b191eb9acccfa'
'0ace0929a7487bd3d464a432e9be643a8f62d135cdfc1b4b2c55846aee8c04dc')
-sha256sums_i686=('bf2829f280ef05a608584ce7ec95875e147f315bac9609f5e18052bc03e3c4f9'
+sha256sums_i686=('80b6461579398398c28f9b72b0c55220f261d9bf6c5a253e3bc66dc8a65131f6'
'e661665ee00ecec66c33e115b0af3474452022f0d8ceda634a6315dc8cb99014')
sha256sums_armv7h=('bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9')
@@ -107,9 +111,13 @@ prepare() {
cd firefox-$pkgver
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
- echo "applying 0001-Use-remoting-name-for-GDK-application-names.patch"
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+ # https://bugs.archlinux.org/task/67978
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1660901
+ patch -Np1 -i ../0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
+ patch -Np1 -i ../0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
+
cat >../mozconfig <<END
ac_add_options --enable-application=browser
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
@@ -134,6 +142,7 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=nu.parabola
ac_add_options --with-unsigned-addon-scopes=app,system
ac_add_options --allow-addon-sideload
+export MOZ_APP_NAME=$pkgname
export MOZ_APP_REMOTINGNAME=${pkgname//-/}
export MOZ_TELEMETRY_REPORTING=
export MOZ_REQUIRE_SIGNING=
@@ -343,6 +352,7 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MACH_USE_SYSTEM_PYTHON=1
# LTO needs more open files
ulimit -n 4096