summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-10-20 13:00:30 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-10-20 13:04:30 -0300
commitc16880844717ab905670fbef95d4e3bd58bd36f2 (patch)
tree78b9509f015954115511700cf7fda6c99ed12c73 /libre/icecat/PKGBUILD
parent6f468c3b9af56791c981643b3531eee0981833e6 (diff)
downloadabslibre-c16880844717ab905670fbef95d4e3bd58bd36f2.tar.gz
abslibre-c16880844717ab905670fbef95d4e3bd58bd36f2.tar.bz2
abslibre-c16880844717ab905670fbef95d4e3bd58bd36f2.zip
icecat-38.3.0_gnu1-3: add missing icons
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 9e3cc91bb..e09de2525 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -15,7 +15,7 @@ _pgo=true
pkgname=icecat
_pkgver=38.3.0-gnu1
pkgver=${_pkgver//-/_}
-pkgrel=2
+pkgrel=3
pkgdesc="GNU IceCat, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64)
@@ -105,7 +105,7 @@ prepare() {
# WebRTC build tries to execute "python" and expects Python 2
ln -s /usr/bin/python2 "$srcdir/path/python"
- # configure script misdetects the preprocessor without an optimization level
+ # Configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
@@ -143,8 +143,9 @@ package() {
brandingdir=browser/branding/official
icondir="$pkgdir/usr/share/icons/hicolor"
- for i in 16x16 32x32 48x48; do
- install -Dm644 "$brandingdir/default${i/x*/}.png" "$icondir/$i/apps/$pkgname.png"
+ for i in 16 22 24 32 48 256; do
+ install -Dm644 "$brandingdir/default$i.png" \
+ "$icondir/${i}x${i}/apps/$pkgname.png"
done
install -Dm644 "$brandingdir/content/icon64.png" \
"$icondir/64x64/apps/$pkgname.png"
@@ -169,6 +170,6 @@ package() {
ln -sf /usr/lib/mozilla/searchplugins "$pkgdir/usr/lib/$pkgname/browser/searchplugins"
# Workaround for now:
- #https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf $pkgname "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
}