summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-01-29 02:14:12 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-01-29 02:14:12 +0100
commitad582ecc880b9a5a5f7bfaaf48be7348692b0242 (patch)
tree71f266253ddeb576d71cf5ed87006a86d00e6722 /libre/icecat/PKGBUILD
parent2c1a4eefc1de3ddae2f939e7376e7e74d820a2e3 (diff)
downloadabslibre-ad582ecc880b9a5a5f7bfaaf48be7348692b0242.tar.gz
abslibre-ad582ecc880b9a5a5f7bfaaf48be7348692b0242.tar.bz2
abslibre-ad582ecc880b9a5a5f7bfaaf48be7348692b0242.zip
libre/icecat: updated to 60.3.0_gnu1
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD119
1 files changed, 44 insertions, 75 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
index 1cf005bd2..80ad3d4a0 100644
--- a/libre/icecat/PKGBUILD
+++ b/libre/icecat/PKGBUILD
@@ -15,68 +15,52 @@
# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
pkgname=icecat
-_pkgver=52.6.0-gnu1
+_pkgver=60.3.0-gnu1
pkgver=${_pkgver//-/_}
-pkgrel=6
+pkgrel=2
pkgdesc="GNU IceCat - a libre standalone web browser based on Mozilla Firefox."
arch=(x86_64 i686 armv7h)
license=(MPL GPL LGPL)
url="http://www.gnu.org/software/gnuzilla/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font libpulse libvpx icu)
-depends+=('icu>=63' 'icu<64')
+ nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack mozilla-searchplugins)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
- 'upower: Battery API')
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip)
source=(http://ftp.gnu.org/gnu/gnuzilla/${_pkgver%-*}/$pkgname-$_pkgver.tar.bz2{,.sig}
$pkgname.desktop
- $pkgname-install-dir.patch no-crmf.diff
- $pkgname-fixed-loading-icon.png
- disable-crypto-hardening-settings.patch
- disable-spoofSource-referer.patch
gnu_headshadow.png
libre.patch)
-sha256sums=('0a0cf3acb2067e0580204b44bb5a02fab2033c6bbf7c0b47522a3c4c1f29d625'
+sha256sums=('6145327092b4b195a4f63d0e86f4857eeba5607ffeb69b6f3bceb36e89a19645'
'SKIP'
- '52df9ffeb52166ed4abd9a132ee4a9017b9c4980f0725ba383610ccfb06d4745'
- 'a7755c929fed4bc2008319dacad92b543db71168294b124855c5d3a19e46ae8a'
- 'd5f0279bcefb5c846ac86c487d540dfc75a5ee45af08e40651e50e778c65f2c0'
- '68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
- 'bb1fc90d117c4a7810e202d23ff44a2dac11b675336533054b5a70dd8606df38'
- 'c50043266e69f5844e6dce9ea7193af79587dcaa66806932d7867281a176f03e'
+ '2f9d117c1524312fb45f3e953cb0de02c525fd385a9b2b6d47308c8aaab0aedd'
'93e3001ce152e1d142619e215a9ef07dd429943b99d21726c25da9ceb31e31cd'
'd32f97e812c536efd9bdc7043efd6f9472a1edd9f814b453805c7c10ffea25a6')
validpgpkeys=('A57369A8BABC2542B5A0368C3C76EED7D7E04784') # Ruben Rodriguez
prepare() {
- mkdir path
- ln -s /usr/bin/python2 path/python
-
cd "$srcdir/$pkgname-${pkgver%_*}"
- patch -Np1 -i ../$pkgname-install-dir.patch
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
- patch -Np1 -i ../no-crmf.diff
+ # Patch to move files directly to /usr/lib/icecat. No more symlinks.
+ sed -e 's;$(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION);$(libdir)/$(MOZ_APP_NAME);g' -i config/baseconfig.mk
+ sed -e 's;$(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION);$(libdir)/$(MOZ_APP_NAME)-devel;g' -i config/baseconfig.mk
cat >.mozconfig <<END
-. \$topsrcdir/browser/config/mozconfig
+ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
-
-ac_add_options --enable-default-toolkit=cairo-gtk3
+ac_add_options --enable-linker=gold
+ac_add_options --enable-hardening
+ac_add_options --enable-optimize
+ac_add_options --enable-rust-simd
# Branding
ac_add_options --enable-official-branding
-ac_add_options --with-app-basename=icecat
-ac_add_options --with-app-name=icecat
-ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.gnu
# System libraries
@@ -87,7 +71,6 @@ ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -96,9 +79,14 @@ ac_add_options --enable-alsa
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
-ac_add_options --disable-safe-browsing
-ac_add_options --disable-url-classifier
+ac_add_options --disable-debug-symbols
+ac_add_options --disable-tests
ac_add_options --disable-eme
+ac_add_options --disable-gconf
+
+ac_add_options --with-app-basename=icecat
+ac_add_options --with-app-name=icecat
+ac_add_options --enable-update-channel=release
END
if [[ "$CARCH" == arm* ]]; then
@@ -116,56 +104,42 @@ END
fi
# Put gnu_headshadow.png in the source code
- install -m644 "$srcdir/gnu_headshadow.png" \
- browser/base/content/abouthome
+ # install -m644 "$srcdir/gnu_headshadow.png" \
+ # browser/base/content/abouthome
# Patch and remove anything that's left
- patch -Np1 -i "$srcdir/libre.patch"
- rm -v browser/base/content/abouthome/snippet*.png || true
- sed -i '\|abouthome/snippet|d
- ' browser/base/jar.mn
-
- # Fix tab loading icon (doesn't work with libpng 1.6)
- # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
- cp "$srcdir/$pkgname-fixed-loading-icon.png" \
- browser/themes/linux/tabbrowser/loading.png
+ # patch -Np1 -i "$srcdir/libre.patch"
+ # rm -v browser/base/content/abouthome/snippet*.png || true
+ # sed -i '\|abouthome/snippet|d
+ # ' browser/base/jar.mn
# Load our searchplugins
- rm -rv browser/locales/searchplugins
- cp -av /usr/lib/mozilla/searchplugins browser/locales
-
- # Disable crypto hardening settings for now
- # https://lists.parabola.nu/pipermail/assist/2015-October/000534.html
- # https://labs.parabola.nu/issues/842
- patch -Np1 -i "$srcdir/disable-crypto-hardening-settings.patch"
-
- # Disable spoofSource referer since it breaks referer function used by some sites
- # https://labs.parabola.nu/issues/1073
- patch -Np1 -i "$srcdir/disable-spoofSource-referer.patch"
+ # rm -rf -- browser/locales/searchplugins
+ # cp -aT -- /usr/lib/mozilla/searchplugins browser/locales/searchplugins
}
build() {
cd "$srcdir/$pkgname-${pkgver%_*}"
- # _FORTIFY_SOURCE causes configure failures
- CPPFLAGS+=" -O2"
-
- export PATH="$srcdir/path:$PATH"
-
- # Do PGO
- #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
- # make -f client.mk build MOZ_PGO=1
- make -f client.mk build
+ ./mach build
+ ./mach buildsymbols
}
package() {
+ local _icu_ver
+ _icu_ver=$(pacman -S --print-format='%v' icu)
+ depends+=("icu>=${_icu_ver}" "icu<$((${_icu_ver%%.*} + 1))")
+
cd "$srcdir/$pkgname-${pkgver%_*}"
- make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
+ DESTDIR="$pkgdir" ./mach install
_vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
+pref("intl.locale.requested", "");
+
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);
@@ -207,6 +181,9 @@ app.distributor.channel=$pkgname
app.partner.parabola=parabola
END
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m755 -d ${pkgdir}/usr/share/pixmaps
+
for i in 16 22 24 32 48 256; do
install -Dm644 "browser/branding/official/default$i.png" \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
@@ -223,14 +200,6 @@ END
install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/$pkgname.desktop"
- # fix permissions on extensions folders
- chmod 755 "$pkgdir"/usr/lib/$pkgname/browser/extensions/*/icons
-
- # Use system-provided dictionaries
- rm -r "$pkgdir"/usr/lib/$pkgname/dictionaries
- ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh